Discussion in 'HyperWRT Firmware' started by riku2015, Jul 25, 2006.

  1. riku2015

    riku2015 LI Guru Member

    Hi all!

    Is anyone compiled vtund server and kernel tun/tap module already for hyperwrt or Thibor firmware? or any firmware?

    Thanks already. :)

  2. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    OpenWrt has vtun 2.6_1 available, there are probably a couple more.
  3. riku2015

    riku2015 LI Guru Member

    yes, but i dont want openwrt. it looks more complicated, heh :)
    Im already familiar with hyperwrt.
    just asking if anyone have the module and binarys already maded.

    maybee i just compile myself, it's good to keep the skills up. :D
    And then put share to internet, to other users as well.

  4. kop48

    kop48 Network Guru Member

    lol how is OpenWRT complicated? It takes approximately 5 mins (including copying certificates back and forwards) to setup. =P
  5. riku2015

    riku2015 LI Guru Member

    what im understaded, openwrt does not have web configuration. telnet yes.

    i should read more and maybee try it. today i will get wrt54gl from store, to play witch.
  6. Toxic

    Toxic Administrator Staff Member

    Thats correct OpenWRT has no GUI or a very limited one. the settings are all done in the cli.
  7. riku2015

    riku2015 LI Guru Member

    yes, anyway i found a bug at thibor sourcecode. some refers to wrong location:
    something like: /home/carl/WRT/

    heh, i maded easiest way: ln -s /home/riku/development/thibor/WRT54GSV3_4_71_1_0411_US/release/ /home/carl/WRT/

    that worked. or compilation goes forward now. it's compiling take some time with dual p3. cannot use distcc to mipsel compiler, heh.
    i maybee code gui to do something to change wan port to eth1(wlan) i have done it sussefully via CLI, it takes via WLAN connection to ap an shares internet via lan ports(nat).

    if thibor is reading this, please correct that directory.
  8. Thibor

    Thibor Super Moderator Staff Member Member

    there are no hard coded locations to where i build, most likely explanation is that it needed cleaning to remove .dep files
  9. riku2015

    riku2015 LI Guru Member

    i have firmware working now with tun module :)

    only bad thing is:

    # ./vtund -f vtund.conf koekoe -n
    vtund[2253]: VTun client ver 2.6 07/28/2006 started
    vtund[2253]: Connecting to
    vtund[2253]: Session koekoe[] opened
    vtund[2253]: UDP connection initialized
    Segmentation fault

    that is lol. i really don't know how they put that working at wrt... :D
  10. riku2015

    riku2015 LI Guru Member

    i fouded the segmentation problem. it's the SSL that not working.
    maybee thibor's ssl libs is not compatible with vtund.

    i have compiled with follow command:
    ./configure --target=mipsel-linux --host=mipsel-linux --build=i386-pc-linux-gnu --disable-zlib --disable-lzo --with-ssl-lib=/kovot/home/riku/development/thibor/WRT54GSV3_4_71_1_0411_US/release/src/router/openssl --with-ssl-headers=/kovot/home/riku/development/thibor/WRT54GSV3_4_71_1_0411_US/release/src/router/openssl/include/
  11. Thibor

    Thibor Super Moderator Staff Member Member

    keep at it, you'll get there
  12. riku2015

    riku2015 LI Guru Member

    yes. im testing now without SSL. tunnel work fine. it work very good. now i can bridge networks without WDS.

    but im keep it up, now next maybee web page config, need to get some experience with those how it work.
  13. riku2015

    riku2015 LI Guru Member

    hi again,
    silly question. anyone have docs about this? tried google etc.. no luck.

    where i can find startup script? not that on /tmp or nvram

    if i install very new router there is nothing on nvram, so no shell start script? where is the httpd etc.. is started?
  14. Thibor

    Thibor Super Moderator Staff Member Member

    only /tmp is writable. /bin, /sbin, /usr/bin and /usr/sbin are where the files are executed from. the startup and firewall scripts are stored in nvram and converted to file format for execution.
  15. riku2015

    riku2015 LI Guru Member

    yes i know that.

    but when(at boot, yes.)/where is nvram is converted?
    any manual for this :) or more information?
    becouse i need put somwhere the conversion fron vtund.conf to file.
    now it's maded from startup script(at webadmin) that is not good for first time using.

    other question, how to remove NAT option off from router?
    my approach is 5port ethernet switch bridged to wlan via vtun tap module.
  16. Thibor

    Thibor Super Moderator Staff Member Member

    your changes will need to be made in router/rc/network.c, firewall.c & rc.c/h
    if you make it in web interface, check router/shared/broadcom.c/h and defaults.c
  17. riku2015

    riku2015 LI Guru Member

    Thanks Thibor:)

    that helped. looks very complicated, lot's of C-Code.
    im not expert at c-code, but i have very newbie skills. so with that i can start :)

    thanks again. i look to code.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice