WAG 200G Firmware AnnexA_1.01.06_01_EU EN & MULTI

Discussion in 'Other Linksys Equipment' started by Sterge, Nov 30, 2007.

  1. Sterge

    Sterge Network Guru Member

    I've just compiled the following firmware:
    WAG200G AnnexA (PSTN) 1.01.06(01) Europe English & Multilingual.

    The source code comes from
    The release date is 20/11/2007

    I have no release notes and failed to find any in the source.

    Mirrors are welcome.


    PS This distribution has been tested!
  2. ReDFlaG

    ReDFlaG Network Guru Member

    thanks for the sharing, may be you could post a quick "how to compile" for those who wants to learn?

  3. mstombs

    mstombs Network Guru Member

    I've not tried with the latest WAG200G but the previous version really do compile "out of the box" Here's my log from previous version - commands typed in bold, reset comments or output

    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2007.09.23 18:37:19 =~=~=~=~=~=~=~=~=~=~=~=
    login as: [B]root[/B]
    root@vector.lan's password:
    Vector Linux 5.8 SOHO Beta 1   Feb-22-2007 on Linux 2.6.20
    You are working as root
    # This environment variable breaks the Linksys scripts - so remove it (My PC issue)
    vector://home/user root:# [B]unset CFLAGS[/B]
    # expand the tarball - must not start with deeper directory
    vector://home/user root:# [B]tar -xzf WAG200G_1.01.05.tar.gz[/B]
    #start in the newly created directory
    vector://home/user root:# [B]cd wag200g-gpl/[/B]
    # run the supplied build script
    vector://home/user/wag200g-gpl root:# [B]./build.sh[/B]
    echo "make links"
    make links
    ln -sf asm-mips /home/user/wag200g-gpl/code/kernel/src/include/asm
    ln -sf sangam_atm_B_5.00.04 /home/user/wag200g-gpl/code/kernel/src/drivers/atm/sangam_atm
    cp -f /home/user/wag200g-gpl/code/driver/atm/tiatm_V3.o /home/user/wag200g-gpl/code/target/lib/modules/2.4.17_mvl21-malta-mips_fp_le/kernel/drivers/atm/tiatm.o
    cp -f /home/user/wag200g-gpl/code/driver/wifi/tiap.o /home/user/wag200g-gpl/code/target/lib/modules/
    cp -f /home/user/wag200g-gpl/code/driver/wifi/wlan_init /home/user/wag200g-gpl/code/target/usr/sbin/
    cp -f /home/user/wag200g-gpl/code/driver/wifi/wpa_authenticator /home/user/wag200g-gpl/code/target/usr/sbin/wpa_auth
    cp -f /home/user/wag200g-gpl/code/driver/atm/annex_a/ar0700mp.bin.5.00.02 /home/user/wag200g-gpl/code/target/lib/modules/ar0700xx.bin
    /home/user/wag200g-gpl/code/tools/makeimage/mksquashfs /home/user/wag200g-gpl/code/target /home/user/wag200g-gpl/code/image/fsa.bin -b 32768 -noappend
    Creating little endian filesystem on /home/user/wag200g-gpl/code/image/fsa.bin, block size 32768.
    Little endian filesystem, data block size 32768, compressed data, compressed metadata, compressed fragments
    Filesystem size 2143.95 Kbytes (2.09 Mbytes)
    25.18% of uncompressed filesystem size (8514.17 Kbytes)
    Inode table size 4584 bytes (4.48 Kbytes)
    32.63% of uncompressed inode table size (14050 bytes)
    Directory table size 3334 bytes (3.26 Kbytes)
    38.95% of uncompressed directory table size (8560 bytes)
    Number of duplicate files found 43
    Number of inodes 604
    Number of files 450
    Number of fragments 100
    Number of symbolic links  88
    Number of device nodes 32
    Number of fifo nodes 0
    Number of socket nodes 0
    Number of directories 34
    Number of uids 1
    root (0)
    Number of gids 0
    #/home/user/wag200g-gpl/code/tools/makeimage/mkcramfs /home/user/wag200g-gpl/code/target /home/user/wag200g-gpl/code/image/fsa.bin
    /home/user/wag200g-gpl/code/tools/makeimage/makeImage_4M /home/user/wag200g-gpl/code/image/WAG200G_A_1.01.05_EN.img /home/user/wag200g-gpl/code/bootloader/loader.bin /home/user/wag200g-gpl/code/bootloader/download.bin /home/user/wag200g-gpl/code/kernel/src/ram_zimage_pad.bin /home/user/wag200g-gpl/code/image/fsa.bin /home/user/wag200g-gpl/code/tools/makeimage/PID_A1.01.05
    /home/user/wag200g-gpl/code/bootloader/loader.bin read 39 kbytes maximum 92 kbytes
    /home/user/wag200g-gpl/code/bootloader/download.bin read 14 kbytes maximum 36 kbytes
    /home/user/wag200g-gpl/code/kernel/src/ram_zimage_pad.bin read 576 kbytes maximum 704 kbytes
    /home/user/wag200g-gpl/code/image/fsa.bin read 2144 kbytes maximum 2879 kbytes
    /home/user/wag200g-gpl/code/tools/makeimage/PID_A1.01.05 read 0 kbytes maximum 0 kbytes
    rm -f /home/user/wag200g-gpl/code/image/fsa.bin
    vector://home/user/wag200g-gpl root:# [B]ls -laF  code/image[/B]
    total 4160
    drwxrwxrwx 2 root root    4096 2007-09-23 20:20 ./
    drwxrwxrwx 9 root root    4096 2007-09-23 20:20 ../
    -rwxr-xr-x 1 root root     413 2007-06-22 02:22 Makefile*
    -rwxr-xr-x 1 root root  102685 2007-06-22 02:22 WAG200G_1.00.09_DE.lang*
    -rwxr-xr-x 1 root root   97660 2007-06-22 02:22 WAG200G_1.00.09_EN.lang*
    -rwxr-xr-x 1 root root  101659 2007-06-22 02:22 WAG200G_1.00.09_FR.lang*
    -rwxr-xr-x 1 root root   98915 2007-06-22 02:22 WAG200G_1.00.09_SV.lang*
    -rw-r--r-- 1 root root 3801088 2007-09-23 20:20 WAG200G_A_1.01.05_EN.img
    -rwxr-xr-x 1 root root   16164 2007-06-22 02:22 make_firmware*
    Note: I don't have a WAG200G - so this was untested!
  4. ReDFlaG

    ReDFlaG Network Guru Member

    thanks. I was thinking it was needing a "make config" before compiling but it seems to be "straightforward"
  5. Sterge

    Sterge Network Guru Member

    It's been a pleasure! You are welcome.

    As mstombs said it's not that hard with the WAG200G firmware. In fact it comes with all the cross compilation tools already compiled for you; that's why the source download is too big.

    mstombs, you don't really have to be root to compile the firmware. What Linux distro are you on? I use SuSE 10.3 myself.

    Anyway, here is what I did for the WAG200G:
    >tar -zxf WAG200G_v1.01.06_eu.tar.gz
    > cd wag200g_v1.01.06_eu
    > cat Readme.txt  
    > cd code
    > make
    That's all you need to do.
    Once make finishes successfully, you'll get a relevant message at the end.
    >cd image
    > ls -l
    The .img files is your firmware binaries.

    Finally, I've tried to compile firmware for my old router the WAG54GV2 as well as for the WAG354GV2 (for a mate). The problem is that those distributions do not have precompiled cross-compilation tools but the come with the source. I had a really time to get binUtils and uClibc to compile. Instead of using the packaged distributions, I downloaded the latest versions from http://www.uclibc.org/ and http://www.gnu.org/software/binutils/. uClibc compiled fine, however binutils gave me a really long list of questions about the mipsel architecture such as Endianess, tagert platform (32 or 64bit) along with variations of those that I don't really understand. I would appreciate any help on this and I can provide list of the questions.

  6. mstombs

    mstombs Network Guru Member

    I have never managed the WAG54V2/AG241 etc either, and gave up with trying to build the tools, definitely a dark art compiling cross tools!. You can get quite some way using the WAG200G toolchain (ie you need the Montavista Linux hardhat preview kit), or the Acorp mcmcc precompiled AR7 toolchains. There is an expert user "Bored Individual" on the Aus Whirlpool forums who regularly does compile these newer firmwares so it is possible!

    My P3-500MHz Linux box runs vectorlinux SOHO, a single CD distro based on Slackware very recent kernel and lots of tools/apps, I only use it remotely via ssh / samba share and am lazy to log in only as root - and building firmware takes hours!. I have had a problem which led to a reinstall before because of this - some mips modem firmware installed itself in the root directories due to a simple path error...
  7. ItalianJob

    ItalianJob LI Guru Member

    The official binaries are out.
    They are the same as the 1.01.06 Second beta from months ago...
  8. Carciofone

    Carciofone LI Guru Member

    Someone tried to compile the woytekm sources?
  9. Sterge

    Sterge Network Guru Member

    I can give it shot.
    Give us the link to the sources
  10. ReDFlaG

    ReDFlaG Network Guru Member

    source are already compiled and downloadable onto the web site of woytekm. (source and binary for 1.01.06 will be ready soon)
  11. Carciofone

    Carciofone LI Guru Member

    The Woytekm source is available here: http://www.openlinksys.info/downloads.php?cat_id=26&download_id=141
    You need registration.
    I had some problems to compile with Ubuntu, because the source is zipped in superuser mode and so the single files.

    Attention that telnet only works on firmware 1.01.06 recompiled, and NOT with the original downloaded from the Linksys site.
  12. Sterge

    Sterge Network Guru Member


    The site is in a language I cannot understand. Could you get the source and upload it elsewhere so that I can get it; if this is legal that is.

    As for the super user mode, try the following assuming the zip file name is "source.zip" and your Unix user name is "carc":
    # enter your root password here
    mkdir source
    cd source
    mv ppp/source.zip . #where ppp is the path where your source.zip resides
    unzip source.zip
    ls -l # to see if the archive is in a directory. if it is issue "cd ddd" where ddd is the directory name
    cd .. # to exit the source directory you created in step 2
    chown -R carc source 
    chgrp -R ggg source # where ggg is carc's group; ls -l to see your group, it's next to your user name.
    This should enable you to ./configure;make;make install or whatever in the source or source/ddd directory.

    If you are still having trouble, drop us a line.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice