WAG200G + Cable Modem

Discussion in 'Other Linksys Equipment' started by Splintter, Oct 8, 2010.

  1. Splintter

    Splintter Networkin' Nut Member


    I have a WAG200G Annex A and a Cable Modem from my ISP

    I want (i need) to connect to internet by Cable Modem and want to use WAG200G as a wired/wireless router, connecting the RJ45 from the Cable Modem on port 1, and connect the computers by wireless and others ports (2,3,4).

    I have modded it with OpenWAG200 1.1 and i see a option to enable external modem, but it doesn`t work.

    Please, anyone helps.
    wlkn likes this.
  2. Splintter

    Splintter Networkin' Nut Member

    I'll do it when i get on the home.
    wlkn likes this.
  3. whats85

    whats85 Networkin' Nut Member

    Did you get it working? Want to do the exact same thing. When i connect the cable modem on port 1 and my pc on port 2 internet works but the pc doesnt get a ip from linksys dhcp.
  4. potyo

    potyo Addicted to LI Member

    I'm also interested in this. wlkn, if you have inspiration to make this work, i can give to you remote access to my computer. Please answer here or contact me by pm.
  5. hflobo

    hflobo Networkin' Nut Member

    The exact same issue

    I am having the exact same problema. Anyone know the answer for it?
  6. Linek

    Linek Networkin' Nut Member

    Solution found

    Here's my solution to the problem (originally running WAG200G Annex A + Linksys firmware 1.01.01):

    1. Just in case (perhaps it is unnecessary), upgrade the firmware to the latest original version (in my case: 1.01.09): http://www.linksysbycisco.com/UK/en/support/WAG200G/download.
    I connected over the wire, did a backup of my settings, reset them to defaults and disabled wireless (Wireless->Wireless Network Mode). Only then, I used the Administration->Firmware Upgrade option.

    2. Upgrade to the latest OpenWAG200 firmware (in my case, the corresponding version 1.3-A). The procedure is like before, the .img file can be obtained from: http://sourceforge.net/projects/openwag200/files/. Afterwards, you can restore your settings from the original firmware and perform the remaining steps over the wireless connection if you like.

    The option MySetup->WAN->PPPoE Client did NOT work for me. I was able to ping websites from the router, but I could not access them from my host. However, I tried the piece of advice given in this thread:http://www.linksysinfo.org/forums/showthread.php?t=61683, modifying it slightly, which worked! :)

    1. First, in Setup->Basic Setup set the encapsulation to RFC 2516 PPPoE. But do not put any username and password there, it's not needed here. Then, connect your cable modem to your router's Ethernet port 1 (the leftmost yellow one).

    2. Log on to your WAG200 using Putty or any other SSH client (login: root, password: your password to the WAG, which is admin by default).

    3. Create a mtd5 filesystem: http://openwag200.sourceforge.net/?p=spfeatures#mtd5 (type make_mtd5 in SSH, and then in the browser under MySetup->other check Mount /dev/... and Run rc.local, reboot the router).

    4. Having rebooted, log through SSH again and create the executable rc.local script (type cd /mnt/mtd5; touch rc.local; chmod u+x rc.local).

    5. Now, we want to put into this file the routine to establish the PPPoE connection with our cable modem. Paste into the command line (in Putty, pasting is done by right-clicking):
    echo "/usr/sbin/pppd plugin pppoe eth0 user PROV_LOGIN password PROV_PWD nodetach defaultroute usepeerdns ipcp-accept-remote ipcp-accept-local lcp-echo-interval 15 lcp-echo-failure 3 mru 1492 mtu 1492&" > rc.local
    where PROV_LOGIN is the login given from the provider, and PROV_PWD is the password. Now, the routine will be called every time during the router start-up.

    6. Finally, leave the current directory before rebooting (important! Otherwise mtd5 won't be able to unmount, and our rc.local will be lost), and reboot (type cd ..;cd ..;reboot).

    7. This is it. It works for me and my Passive Optical Network modem. In Status->Gateway window I see the following:
    wlkn likes this.
  7. b39ppr

    b39ppr Networkin' Nut Member

    Hi Linek,

    Thank you for your solution.

    I recently changed from ADSL to cable, however, I don't think I have a username/password from the provider for cable connection. I just activated the cable modem at the first use and that's all, I can access internet.

    So I'm wondering what values I should put it the PROV_LOGIN and PROV_PWD, or should I delete the whole "user PROV_LOGIN password PROV_PWD" part.

    I also read a pppd manual (not quite understand though), it has an 'noauth' option. Maybe I should put this too?

    Thank you very much.
  8. dsingtc

    dsingtc Networkin' Nut Member

    I applied WAG200G_V1.01.09.openwag200-build-1.3-A.img
    and set MySetup->WAN->PPPoE Client
    and I also tried
    echo "/usr/sbin/pppd plugin pppoe eth0 noauth nodetach defaultroute usepeerdns ipcp-accept-remote ipcp-accept-local lcp-echo-interval 15 lcp-echo-failure 3 mru 1492 mtu 1492&" > rc.local
    and have gotten limited success...
    - when i restart my router with my laptop wireless turned on, my laptop will get my isp modem's ip address
    - if i now turn on another wireless device, it will get the dhcp ip address, and this device will not be able to connect to the internet.

    What configuration is missing/incorrect?

    Thank you very much in advance.
  9. dsingtc

    dsingtc Networkin' Nut Member

    Thank you for your reply.

    I am using a modem with a fibre connection(not sure what type of modem you call this).
    Like b39ppr's post above in Jul 17, 2011 - I just connect my computer directly to the modem and it works.

    Since noauth is currently not supported, do I just specify "fake" user and password?
    Or, there is absolutely no way to use the WAG200?
    I am a little confused too, since I seemed to be able to get it to "work" when a machine connected via wifi gets the ip address of the modem. So, it seems like some misconfiguration on my part, where I need to get the machines connected via wifi (with a dhcp ip address from WAG200) - to get WAG200 to route the traffic to the modem. (not sure if I am making sense as I am not very familiar with this)

    Thank you in advance.
    Best Regards.
    wlkn likes this.
  10. dsingtc

    dsingtc Networkin' Nut Member

    Hi wlkn,

    Thank you for your update.
    I had applied v1.4, went to MySetup->WAN->PPPoE Client Settings - and selected that it is "Using an external modem for Internet Connection", as well as, "Do NOT require my ISP to authenticate itself (pppd noauth option)". Save MySettings and hard rebooted the WAG (via
    After doing this, my laptop would be able to connect to the internet - my laptop would be having an ip address as if I directly connected to my external modem instead of an ip address of 192.168.x.x
    GREAT! :)

    From my laptop, I disconnected from my WAG and then reconnect again.
    Doing this would give me an ip address of 192.168.x.x and it would not connect to the internet.

    If I then performed a hard reboot (via, my laptop would then be able to connect to the internet - having an ip address as if I directly connected to my external modem instead of an ip address of 192.168.x.x

    Am I missing some configuration steps?
    My external modem is a Huawei EchoLife HG863 - not sure if it matters.

    Thank you very much.
  11. potyo

    potyo Addicted to LI Member


    I have (i think) similar internet connection. It's through the cable tv network, and the router or the pc connected to the modem gets the ip from the internet provider using dhcp. There is no PPPoE or other kind of authentication. The cable modem is identified by it's serial number or mac address (i don't know the exact details). If you want, i can give to you access to my computer, and you can do tests using it.
  12. MikeG

    MikeG Serious Server Member

    Hi wlkn,

    I'm new to this so pardon me if this has been asked before.

    I would like to use the WAG200G as a router to filter and control access (time schedules) for my children multiple pieces of hardware. I've tested the above method that you've suggested (pass-through). I can access the internet when connecting to the WAG200G but the access restriction settings will not work.

    Any suggestions?

    Thanks very much in advance.
  13. MikeG

    MikeG Serious Server Member

    My cable provider gave me a Netgear CG3100 Cable Modem Router but the access restriction function is nothing compared to that of WAG200G! That is why I want to configure my WAG200G for access restriction.
  14. MikeG

    MikeG Serious Server Member

    I think my cable provider is not using PPPoE connection (if you're interested, I subscribe to BigPond Utimate Cable (100Mbps) - A Telstra Australia ISP). As such, can I still use OpenWAG for my purpose? I'm of the opinion of 'no'. Kindly enlighten me. Thanks very much in advance. Cheers...
  15. MikeG

    MikeG Serious Server Member

    This is the partial ipconfig /all output. Please be aware that this is from my PC that is connected to the Netgear CG3100 directly. I've disconnected the WAG200G. If you want something else, please let me know and I can reconnect the WAG200G.


    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Michael-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Bluetooth Network Connection 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network) #2
    Physical Address. . . . . . . . . : 00-11-67-87-5C-7F
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Physical Address. . . . . . . . . : 00-26-18-0C-B3-35
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::757d:5856:c46:d637%11(Preferred)
    IPv4 Address. . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Lease Obtained. . . . . . . . . . : Thursday, 26 April 2012 05:20:26 AM
    Lease Expires . . . . . . . . . . : Thursday, 26 April 2012 06:50:27 AM
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DHCPv6 IAID . . . . . . . . . . . : 184559128
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-F0-B4-41-00-26-18-0C-B3-35
    DNS Servers . . . . . . . . . . . :
    NetBIOS over Tcpip. . . . . . . . : Enabled
  16. MikeG

    MikeG Serious Server Member

    Thanks for your help and pointers. I will check-out RouterTech Firmware. Cheers...
  17. sh_vipin

    sh_vipin Serious Server Member

    Hi Volkan,

    I am trying to achieve the same ( comment # 1 : ADSL router WAG200G but use it with another Modem for LAN + WAN connections) I want to connect modem output @ Ethernet port #1 and connect computers on { 2,3, 4}.

    I have followed this post and have done the following.

    1) Upgraded to Linksys firmware ANNEX A 1.01.09
    2) Then upgraded to WAG200G_V1.01.09.openwag200-build-1.4-A.

    I am working on windows and logged in router @ through putty.

    Followed Linek's comments (#8)
    3) created mtd5 partition through $wag200g> make_mtd5 which successfully created the partition but "read Only"
    -- Since the partition is read only, i couldn't make the file by "$touch rc.local"
    -- I tried to do chmod 777 -R mtd5 , but that also didn't work.

    Then I moved to dsingtc's comments (#16)
    4) Checked on "Using an external modem for Internet Connection", and,
    5) Checked on "Do NOT require my ISP to authenticate itself (pppd noauth option)"
    6) Rebooted the server.

    My LAN is working but Wireless connection is not working yet.

    Then I followed wlkn's comments #19
    7) Changed Router IP address to 76.103.XXX.X
    8) Disabled DHCP and saved settings.

    But now, as it always happens with my router ( Linksys WAG200G) , as soon as I disable DHCP , i can not access my Gateway through or either 76.103.abc.X

    Can you please help me further. I guess I am close. My LAN ( at least on one of the ports) is working and just WAN needs to work.

    Here are some details.
    - Router : Linksys WAG200G
    - ISP : Comcast
    - Modem : DOCSIS , CISCO DPC3000

    - IP address
    Computer on LAN (through WAG200G port # 3) : 76.103.abc.63
    Default gateway : 76.103.abc.1

    Laptop Connected to Wireless ( WLAN , but Internet not working ) : (preferred)
    Default Gateway :

    Computer on Comcast :76.103.abc.63
    Default Gateway : 76.103.abc.101

    My LAN is working but Wireless connection is not working yet. Probably my other LAN ports(3,4) are also not working.
    Once I disabled DHCP, WAG200G gateway access also has got stopped. What should I appropriately assign router IP for it to be in subnet mask fro with ISP address ( say for e.g. 76.103.abc.63)

    Thanks in advance for help !!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice