WAG200g - disconnects.. no auto-reconnect

Discussion in 'Other Linksys Equipment' started by sam_linksysinfo, May 4, 2007.

  1. sam_linksysinfo

    sam_linksysinfo LI Guru Member


    I recently bought the WAG200g and after setting it up (very easy with the disk ... and manually via the web page based menu), it seemed to work fine, but, I started to notice that even with the 'keep alive' option selected, if the DSL connection was lost, the WAG200g would not automatically re-establish connection and the front panel status led's would stay green, even though the unit was in fact disconnected.

    I have the latest firmware installed (downloaded from the official Linksys site), version 1.01.04 (dated April 2007) and so far, suggestions from technical support have included...

    Re-install the latest firmware then press and hold the reset button on the rear of the unit for at least 15 seconds, then re-start the WAG200g and my PC......

    Change the MTU value (default is 1500) to 1365

    So far, none of these suggestions has brought about a cure to this problem and I'm just wondering if anyone knows if there is a new version of the firmware for the WAG200g coming out soon?

    I have a Netgear modem/router (few years old now so I decided to get the Linksys as a spare/backup) which has a similar 'keep alive' function and the Netgear does re-establish connection if the connection is dropped for whatever reason. I assume the WAG200g should do the same with the 'keep alive' function enabled?

    Cheers,and thanks for any info
  2. ReDFlaG

    ReDFlaG Network Guru Member

    i ve no prob with my wag.

    First of all, you should do a "load factory default", then power off and wait a minute, then power on and reconfig every settings. (in fact, when you upgrade with a new firmware this is the best way to do, i think, so that you have a very clean device . don't forget to disable WIFI as it is said in the manual before flashing). boring way, but safe way.

    Be carefull about dsl parameters since some ISP need some specific entries (multiplex, QS, modulation...)

    anyway, keep alive is ok for me, so it should be for you.
  3. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Hi ... thanks for the reply.

    I think I've now tried flashing the unit with the latest firmware about 4 times now and each time, I've more or less followed the method you suggest... I certainly powered down both computer and WAG200g and re-started them both and did a clean, fresh (via the installation disk) install.

    While the unit is connected it works a treat and I have no problems, but as stated, if/when it loses connection, the status LED's stay green and the unit then does not re-connect... I have to go into the menu system... press the 'disconnect' button, then press the 'connect' button (or just re-boot the unit).

    I've been told different stories from the technical support people at Linksys... one told me there was a beta version of the firmware (later than version 1.01.04 I assume they mean?) that may help with this problem, and another support person said the latest beta version WAS 1.01.04 !

    My understanding is that firmware version 1.01.04 is, at this time, the latest full version available to all, not a beta version. All rather confusing (for the Linksys technical support people :wink: ).

    I'm using my trusty Netgear modem/router again at the moment. It has a similar 'keep alive' function which actually works. I'll wait to see if a later version of the firmware fixes this problem but if not, I'll send the unit back and get a refund :frown:

    Thanks for your help
  4. ReDFlaG

    ReDFlaG Network Guru Member

    1.01.04 is the latest official firmware.

    can you do a test (if you don't already have):
    1 disable WIFI (wag)
    2 power off router
    3 connect only one PC with a cable (deactivate/remove every wifi card)
    4 power on router
    5 power on PC
    6 surf some time, power off pc a while, then power it on again and check if keep alive worked?

    if yes, then keep the same config, but enable WIFI only onto the router (keep it disabled on PC), and do the same test. if ok, then enable wifi onto the PC and redo testing.
  5. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Hi again... thanks for helping.

    I don't normally use the wifi side of things as my (3) computers are all linked via cable and one of the first things I did was to switch off wifi. I have also run with just one PC connected to the box.

    Here's a funny thing.... I got a call from Technical support earlier today asking how things were and they asked me to 'roll back' the firmware to version 1.0.09 (seems they know that was a very stable version) which I've now done and so far (everything crossed here), the box has been keeping the connection alive :)

    I'll keep this version running while it's working ok but it would seem to point at their being an issue with the latest firmware? If that is so, then the hopes are that any future firmware will also fix the problem.

    Thanks again
  6. ReDFlaG

    ReDFlaG Network Guru Member

    strange since i don't have that issue with my device using the latest firmware.

    anyway, it now rocks for you ;)
  7. magsi

    magsi Network Guru Member

    ADSL or ADSL2+? if ADSL2+ perhaps the L2/L3-Problem.
  8. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Been running the WAG200g now for a few days with the firmware rolled back to v1.0.09 and it now seems to be working ok :)

    What I've noticed different with v1.0.09 from the latest firmware release (v1.01.04) is that if the connection drops, the LED status lights change from green, to red and the unit then re-syncs and connection re-made and the LED goes back to green when connection is restored.

    I know people are using the latest firmware and not experiencing this problem, but this suggests to me that there is an issue with the latest firmware and hopefully a future release will address this issue. In the meantime, I'm sticking with v1.0.09 :wink:

  9. santinod

    santinod LI Guru Member

    Could you please give some references to the problem you mentioned? I am observing exactly the same behaviour with my WAG200G (1.01.04) and an ADSL2+ service. Thanks!
  10. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Hi ...

    After first setting up the WAG200g, I downloaded the latest firmware from the Linksys site and flashed it was version


    I started to realise that the unit would lose connection, but still show a GREEN front panel LED, but the unit was in fact

    disconnected. I would then have to manually force a connection by going into the web based menu and clicking 'disconnect',

    then 'connect' button, or of course re-boot the WAG200g. The WAG200g would then re-establish connection.

    The last thing that Linksys technical supported suggested was that I return it to the store I bought it from. They said

    they were not aware of other people having this problem with the WAG200g and that the unit might be faulty.

    I was not convinced and decided to look around for information and started here at these forums.

    After some scratching around, I decided to try an earlier version (version 1.0.09) of the firmware as it was suggested

    that this was a good stable version.

    I flashed the WAG200g with version 1.0.09 a few days ago and this is what I've been noticing ....

    If the WAG200g loses connection, the front panel status LED turns RED giving a true indication that the unit has lost


    After a short while (guess it's about 1.5 minutes.... that would be the time it takes for the 'keep alive' function to

    check that the unit is in a disconnected state?) the unit would re-establish connection and the front panel status LED

    would turn GREEN, indicating the the unit was connected again... as indeed it is.

    To me, this suggests a problem with the latest version of the firmware, version 1.01.04. I'm sticking with version 1.0.09

    and hoping that a later release of the firmware will fix the problem.

    I guess you could try and flash your WAG200g with version 1.0.09 and see if it helps with your problem, as it has with


    Good luck
  11. santinod

    santinod LI Guru Member

    Indeed, that was the exact description of my problem.

    I was wondering what the "L2/L3-Problem" mentioned by magsi might be...
  12. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Not sure what those problems were/are but I'm hoping that a future (soon?) update to the firmware will have fixes for these issues.

    I can report that using version 1.0.09 of the firmware has solved my problem and the WAG200g is working as I believe it should.
  13. NickToye

    NickToye LI Guru Member

    I am finding that whenever my landline becomes active, by me making a call or a call coming in, the router disconnects the internet, forcing me to reboot.

    I have also backtracked to 1.0.09 - seems to not make that much difference.
  14. wlgspotter

    wlgspotter LI Guru Member

    I seem to be experienceing the EXACT same problem as well - just got my WAG200G yesterday and upgraded to v1.01.04 (from original of v1.01.01) and seeing the same issue. The thing is I'm down here in New Zealand and no where can I find v1.00.09 from Linksys NZ's website - I'm wondering where can I get the firmware for v1.0.09 and will it be safe to apply to my WAG200G for use in New Zealand?

  15. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Here's where I grabbed version 1.0.09 from ...


    I'm in the UK and to be honest, I'm not sure if this version would be ok for you down there in NZ ... might be best to ask around first before attempting to flash your unit with the firmware.

    I can say though that applying this version of the firmware, for me at least, has made the WAG200g perform correctly with regards to this disconnect issue.

    I'm still hoping the guy's/gals at firmware/software development are now working feverishly to produce a new version of the firmware for the WAG200g to cure this, and other issues ? :wink:

    Good luck!
  16. wlgspotter

    wlgspotter LI Guru Member

    Thanks - I think I might hold off and wait for the official fix (hopefully soon!) from Linksys..!

    An interesting note tho - a friend of mine has also got a WAG200G, and he's using v1.01.01 (which was the default loaded when it first arrived) - and he's not seeing the reconnection problem... I'm quite tempted to revert back to v1.01.01 but a bit concerned about the UDP security problem with v1.01.03 and below...I'd rather have the reconnection problem than a potential UDP security hole...
  17. wesmond

    wesmond LI Guru Member

    The disconnect problem - log.

    Hi all,

    I've been experiencing exactly the same almost-hourly disconnect problem, where the light stays green, but I get no more bytes. Unfortunately, downgrading to firmware 1.0.09 made no difference to mine. After a couple of live chats with Linksys, they suggested firstly that I should push the reset button, and secondly that the device was faulty, but similar to others here, I'm not sure that's right - there are too many people who have the same problem. So I installed the log viewer, and this is what happens:-

    250 Fri May 18 8:43:17 2007 Initialize LCP.
    251 Fri May 18 8:43:17 2007 Plugin pppoa loaded.
    252 Fri May 18 8:43:17 2007 PPPoA Plugin Initialized
    253 Fri May 18 8:43:17 2007 Plugin pppoa called.
    254 Fri May 18 8:43:17 2007 PPPoATM setdevname_pppoatm - SUCCESS
    255 Fri May 18 8:43:17 2007 Options file - /etc/ppp/options.0.38.
    256 Fri May 18 8:43:17 2007 pppd 2.4.1 started by root, uid 0
    257 Fri May 18 8:43:17 2007 setting line discipline hook
    258 Fri May 18 8:43:17 2007 connect_pppoatm_ses...Enter
    259 Fri May 18 8:43:17 2007 connect_pppoatm_ses: socket created fd - 0x6.
    260 Fri May 18 8:43:17 2007 connect_pppoatm_ses: setsockopt called.
    261 Fri May 18 8:43:17 2007 connect_pppoatm_ses: connect successful.
    262 Fri May 18 8:43:17 2007 Calling line discipline hook
    263 Fri May 18 8:43:17 2007 Setting pppoatm line discipline.
    264 Fri May 18 8:43:17 2007 vc encaps.
    265 Fri May 18 8:43:17 2007 using channel 387
    266 Fri May 18 8:43:17 2007 Using interface ppp0
    267 Fri May 18 8:43:17 2007 Connect: ppp0 <-->
    268 Fri May 18 8:43:17 2007 LCP is allowed to come up.
    269 Fri May 18 8:43:47 2007 LCP: timeout sending Config-Requests
    270 Fri May 18 8:43:47 2007 This terminate is called from lcp_finished()
    271 Fri May 18 8:43:47 2007 Connection terminated.
    272 Fri May 18 8:43:47 2007 Exit.

    And this repeats time and time again while the modem is struggling to restart its connection - no.268-269 is the critical bit. Must be a firmware bug to my mind?

  18. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    I have little doubt now that the disconnect (and other) problems people are having with the WAG200g is firmware related.

    I just wish technical support and Linksys would take this on board and get out some firware that fixes these issues, without delay.
  19. ReDFlaG

    ReDFlaG Network Guru Member

    i told you i doubt about a firmware problem since i (and other friends) don't have any issue...
    Can those who got the issue write where they live and who is their provider?
  20. wlgspotter

    wlgspotter LI Guru Member


    Yeah I actually think it could be a firmware issues - read somewhere on some forums it's probably due to them using an "older" version of pppd which might now be able to detect a ppp disconnection...

    Anyway, I took the plunge to tried v1.00.09 as you've suggested... and it works for me like yours...

    Actually, prior to trying I did contact Linksys Support NZ, and the support engineer did ask me to try v1.00.09 as well and it fixed it... Interestingly tho, I submitted the contact via LinksysNZ (email something like anzsupport@linksys.com), and it was a UK Support Desk engineer who replied.

    Anyway, the reconnect problem is now gone, however, reading some other info/forums it seems firmware prior to the latest v1.01.04 has a information disclosure problem - it'll reveal a bunch of info if you send a packet/query to it via UDP port 916/ So far I think the problem is only confined to the "LAN" side - the WAN and/or WiFi seemed OK. I tried using NMAP to scan mine from one of the PC connected directly to it, and hey presto got the info out of it.. Scary..! Wondering if you have this issue and can confirm the WAN side is OK..? Some of those internet port scanners I used revealed port 916 is closed but I want to be absolutely sure...

    I mentioned it to Linksys support and am waiting for a reply from them - hopefully they'll fix it sooner rather than later.

  21. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    I'm in the UK and my ISP is EntaNet

    I appreciate that you and some of your friends are not having a problem, but myself and others are and it does seem to be the firmware that is the cause (given that upgrading to version 1.01.04 causes the problem... rolling back the firmware to version 1.0.09 seems to cure it... for some) :wink:

    In another posting in the forum, someone suggested that they had a beta version of the firmware (v1.01.07) ... as yet though, the writer has not come back and confirmed where they got it from and any info from the changelog :confused:
  22. wlgspotter

    wlgspotter LI Guru Member

    I am in New Zealand and my ISP is WorldXchange. I've also supplied this information to Linksys support and hopefully something can de done about it.

    As for the supposedly beta version 1.01.07... I found on a forum (I think it's whirlpool forums based in australia) that someone received the so-called beta from Linksys support and was disappointed to find the so-called "beta" is actually v1.00.07..! See this link - the 3 last messages...http://forums.whirlpool.net.au/forum-replies.cfm?t=693249&p=2
  23. wlgspotter

    wlgspotter LI Guru Member


    I did a further test on this issue, and have the logging enabled. I noticed whenever attempt to simulate an ADSL disconnect and reconnect (i.e. pull out the phone jack, and re-insert it again), this is what shows in the log (note this was done using v1.01.04 latest firmware):

    Sun, 2007-05-20 14:23:57 - lcp echos pending >= lcp_echo_fails!

    Sun, 2007-05-20 14:24:22 - We have just avoided a PPPRceivedTerminate right now

    Sun, 2007-05-20 14:24:24 - lcp echos pending >= lcp_echo_fails!

    It looks like when the ADSL line is disconnected, the PPP session in the router is still up, and when the line is reconnected, and a new PPP session is automatically initialized, it fails as the router thinks the PPP is up...

    Anyone knows what this means..?
  24. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Like yourself, I don't know what all that stuff means (not a programmer :wink: ) but again I'd suggest all this is more evidence pointing to the issue's being with the firmware (v1.01.04).

    Thanks for clearing up the confusion over the (so called) beta version. Actually, even Linksys are confused about their own firmware versions... originally, I was told I'd be sent a beta version by a technical support rep'... after about a week or so and it not being sent to me, I contacted them again only to be told they had made a mistake and thought that version 1.01.04 was a beta, and not the currently available full version :confused:

    With regards the possible vulnerabilities with version 1.0.09 ... again, not sure what they are or how bad a threat they are. Guess for the moment I'll have to rely on my internet security packages to try and protect my system while running this version.... more reasons I guess for Linksys to get out a later version of the firmware to address these issues.

    Thanks for the info :wink:
  25. wesmond

    wesmond LI Guru Member

    I live near Dunstable, UK, and my provider is Talk Talk.

    I seem to have a steady connection with the TalkTalk-supplied modem (Huawei SmartAX 882, connecting 1k slower than Linksys for some resaon)- I'm now running on that and trying to establish whether that one disconnects regularly but picks itself up successfully again, or whether the disconnections don't happen at all.

    That will point the way as ot whether the Linksys is shaky when a disconnection happens at TalkTalk's end, or whether the Linksys actually causes the dropout itself in some way.
  26. ReDFlaG

    ReDFlaG Network Guru Member

  27. wesmond

    wesmond LI Guru Member

    New firmwares...

    I've not got the software to build the 1.01.04a... have to wait for a build of that one to materialise!

    The woytekm alternative firmware worked as well as the Linksys firmware for me, in that everything worked nicely, and the extra stuff (if you need it) is probably cool, although I'm afraid I'm not so much in need of the extra bits. I had to power off and on before it started up, but that's not unusual. Alas, it didn't fix my disconnection problem though... but then I don't think that was something woytekm was particularly aiming to do.

    It seems from the logs of my Hauwei modem that the Linksys is actually causing its own disconnections, and not recovering - not a murmur of instability on the line from the Hauwei SmartAX 882 modem, so I don't think line problems are the first cause of the disconnection problems.
  28. wlgspotter

    wlgspotter LI Guru Member


    Thanks for pointing to the link for v1.01.04a... However, I'm not a programmer either and don't know how to build it... Maybe I'll just wait... unless someone here is willing to help out..?

    As for the customized firmware by woytekm... I've asked about it in another thread and no it won't fix the disconnect issue (it's based on v1.01.01 I think and it still has same issue).. See this http://www.linksysinfo.org/forums/showthread.php?p=301457#post301457

    For the security threats on 1.00.09, apparently it's on the router itself as it discloses certain information in clear text when a UDP packet is sent to it via port 916. However, seems like it's only on the LAN (and maybe WiFi?) side and not from WAN/ADSL, so unless someone has physical access to the router it's probably quite safe..

    Now, I've had a further play with v1.01.04, and I may have found a solution to the keepalive issue... Still need further playing and testing tho... This is a workaround and not a fix...

    Instead of using keepalive, I use the Connect on Demand, and set idle time to say xxx mins (tested with 3-5 mins).. After 3-5 mins of no activity (pulled out my PC cables etc), the PPP/internet disconnects. Plug my cables back in, and fire up my browser, and the internet comes back on - the router log shows ppp reestablishes again.... So, I'm thinking if we set the time to be "low enough", perhaps when an ADSL disconnection occurs, and after the "idle time" has elapsed, maybe the session would be reconnected..? Just me thinking out loud really and it may not make sense..

    Just my thots!
  29. ReDFlaG

    ReDFlaG Network Guru Member

    i was pointing to this firmware too, because those extra tools might have helped you finding what was going wrong.
    Anyway, i think all those issues could be solved with the alternative firmware since you can set up a crontab, so let says a nice script could be run (directly into the router) every minute to do some check, and if the result is ko then it do a "clean" line down/line up.
    (may be if asked gently to the firmware builder...).

    you can build the source firmware with a linux, or cygwin for windows (kind of linux emulator, in fact its not really that. Those linux addict will kill me if they hear). May be google can help you to find how to...

    anyway, i still don't understand why only a part of users are affected, that 's why i asked about the handling of the dsl lines in your both country.

    I will try to find some usefull stuff if i can, later.
  30. wlgspotter

    wlgspotter LI Guru Member

    Well, just thot I'd like to clarify some points regarding my WAG200G and the disconnect/reconnect problems...

    Generally, my ADSL line is very stable and I don't get disconnects like some other people may have experienced - I've had the WAG200G and an old D-link DSL-302G connected for days and not a single disconnect.

    However, I noticed on the odd occasion when I do have disconnects, the WAG200G does not know how to re-establish the PPP connection again - from the log it looks like the firmware/router does not even know a PPP session has terminated, hence would not reinitiate a reconnection again (or doesn't "accept" the PPP reconnection). That's where the problem lies for me.

    Tried it with v1.00.09, and from the log I can see the moment my ADSL light goes off after disconnection, the PPP session would also be terminated. It will reestablish again after I plug back the phone line and ADSL followed by PPP negotiation/connection starts. So yeah it works (for me) with v1.00.09, not with v1.01.01 or v1.01.04.

    I still think it's firmware related, cos when I pull out the phone line from my DSL, after a few seconds BOTH the ADSL and Internet led light goes off, and the webmin web page shows DSL status is "not connected" - but the router/gateway page shows I still have a PPP session and IP address, when in actual fact I don't anymore. Upon reconnection of the phone line, the DSL comes up after a few blinks, followed by the Internet light, suggestion PPP has been re-established, but I don't get a new PPP IP address (I should cos my ISP uses dynamic IP and chances of getting the same IP addr again is very very slim)..

    For the record, here in NZ ADSL lines go thru Telecom NZ's network, and the exchanges uses a mixed of Nokia DSLAMs and Alctel ASAM. I know the exchange/DSL port I'm on is on a Nokia DSLAM.
  31. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Hi Again ... thanks to all for your input.

    I can confirm very similar, if not identical situation as yourself and once I realised what was happening, I could tell when the connection had dropped because their was actitivity on the Lan port LED (trying to kick the dsl connection I guess?) but the internet Led light would stay Green and the unit would be stuck.

    It does seem odd, I admit, that some people are finding running version ok, and others not, but I'm as convinced as I can be that it is the firmware version causing this.

    I did think about changing the 'keep alive' setting for the other option and from your description, I guess it might work.... not sure if I want to roll forward again to v1.01.04 to try it though.... still feel traumatised by that version :biggrin:

    My other Modem/Router (Netgear) although a few years old now works without fault and when I do lose connection, automatically re-estabilishes the link without me having to do anything.

    I guess version 1.0.09 is the one for me, until such times as Linksys brings out a new (fix) version.

  32. wlgspotter

    wlgspotter LI Guru Member


    Yes thanks to all your your inputs and comments too... I am too quite puzzled about this - in fact I've got a friend of mine (who is also in NZ, with the same ISP, and has also a WAG200G running v1.01.01), do some tests in his unit and it seemed OK..! But I still think it's firmware related like yourself.

    Anyway, for me I've rolled forward to v1.01.04 - yes the disconnection is bad, but it doesn't happen to me often and I don't leave my line/router running for long periods of time so I think I was live with it. And I must say other than this "little" issue, the WAG200G is good in other aspects - for WiFi speeds, good downloads etc. I did consider perhaps trying to get it replaced but I guess it's not wortn the hassle, so am holding onto my unit for now and hopefully a firmware fix could do the job.

  33. virgo17

    virgo17 Network Guru Member

    I have two WAG200g's both bought in the UK but at slightly different times. Both have been 'upgraded' to V1.01.04 of the firmware. One of the units is here in the UK using Newnet as an ISP. The other unit is in my house in Spain using Telefonica as the ISP.

    Both units have the same problem as the OP reports. In fact this morning I got up (in the UK) to find my connection down but the green LED still illuminated. I had to manually disconnect and then re-connect to get it back. On the Newnet forum on ThinkBroadband a few users reported a quick disconnection at about 1.00am this morning. It would seem that other modems re-connected OK but my WAG200g did not. This also happened in Spain on the last night I was there.

    I am going to revert both units to firmware V1.0.09 as I am convinced the problem comes from the later firmware.

  34. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Yes, without doubt, this disconnection... and then no 're-connect' via the 'keep alive' function is a problem with the latest firmware.

    I've been running with version 1.0.09 for some weeks now and the WAG200g does re-establish connection if the link is lost.

    Fingers crossed rolling back to the earlier version will do the trick for you, as it has for me and others. Good luck.
  35. wlgspotter

    wlgspotter LI Guru Member


    Yes, I've no doubt here too that it's the later firmware. I said "later" as I've even tried 1.01.01, but it's no use. Only 1.00.09 fixes the disconnection problem.

    However, having said that, I still reverted back to v1.01.04 as I don't have a lot of disconnection, and I still feel "safer" with the fix that v1.01.04 offers with regards to the UDP issue.

    Fingers crossed, an updated firmware will be released to address this issue..
  36. DonJuancho

    DonJuancho LI Guru Member

    I want to understand this problem better, why is it that keep-alive appears to work for some people?

    Do your WAN IPs change everytime you reconnect to your ISPs network? For those with working keep-alives with the latest firmware, do your IPs change between sessions?
    For those with keep-alive failures - try to compare the WAN IPs that you have on Status with the one that appears in the routing table. (do this when the problem has just occured)
  37. wlgspotter

    wlgspotter LI Guru Member

    OK... let me try and explain my situation. I'm obviously one of those who have this keep-alive issue.

    My connection is generally (almost always actually) very stable - no dropouts whatsover. My ISP does not change my WAN IP as long as the connection is there - i.e. no changes within sessions. It does uses dynamically assigned IP for my WAN, however, and thus if I disconnect (or power off the router) and connect again, my WAN IP may change.

    Now, back to my ADSL connection - it's very stable. However, on the odd occasion, if I do have a disconnection, despite the "keep-alive" setting on my router, would not know how to establish a connection again. I could even simulate a disconnection by just purely unplugging the phone jack on the router and plug it back in again. I would not be able to even ping my ISP's DNS servers after plugging in - suggesting the reconnection did not occur as expected.

    The interesting is, checking on the status and routing table pages on my modem, when I have a disconnection (i.e. pull out my phone jack), it still shows my gateway status as connection with my "previous session" WAN IP (it should have shown no connection now..) - suggesting the router did not even know a disconnection has occured, and hence a probably a reconnection did not occur as expected.

    If I used v1.00.09, once the disconnection occured, the router status page would automatically refresh and will no longer show I have a WAN IP, and my routing table would show no WAN IP and no default route. This is more like an expected behaviour.

    I'm not sure why some people's work and some don't - I can only think of perhaps there's are "different batches" of units produced at different times that may see different chip behaviour, altho I don't think that is the real cause. I still think it's firmware related.
  38. DonJuancho

    DonJuancho LI Guru Member

    Thanks for the response wlgspotter.
    So in your case, the router does not even detect that the connection has already been lost. Does the behavior hold true with the status page even if you refreshed it manually (try several refreshes to be sure)?
    I'm working on a possible angle already, in that it could be that the router does re-establish a new ppp session, but fails to update the default route with the new WAN info. This would help explain why keepalive works for some and not for most. (my IP changes every week, it varies from time to time, but it's usually one week - kinda okay, but it can be a problem with IP bans, which i don't really want to talk about :))
  39. wlgspotter

    wlgspotter LI Guru Member


    Well yes the router does not seem to detect the connection being lost. I'm pretty sure the status page shows the WAN IP connected even after a couple of refreshes - I'm not at home at the moment so can't confirm - will check it later and let you know.

    In the meantime, on one of my earlier posts, I mentoined this is the status log when I pull out the phone cable...

    Sun, 2007-05-20 14:23:57 - lcp echos pending >= lcp_echo_fails!

    Sun, 2007-05-20 14:24:22 - We have just avoided a PPPRceivedTerminate right now

    Sun, 2007-05-20 14:24:24 - lcp echos pending >= lcp_echo_fails!

    Not really sure what it means, but the 2nd line looks like the router is "trying to keep-alive", by refusing a PPP-terminate request..!

    Also, I just spoke with a friend of mine (also from Wellington, NZ, with the same ISP) who also has the WAG200G, with the default firmware v1.01.01. We've just got him to try the disconnect and connect action I mentioned, and his was OK - managed to surf the web after re-connection..! The only difference, from the network technical point of view, is that the DSLAM to which his line is connected to is running off an Alcatel 7300 ASAM, whereas my line is running off a Nokia D50e DSLAM (we live in different parts of the city, running off different exchanges). In terms of sync-up rates, he's getting around 3MB down and 160kb up (here in NZ our ISP DSL plan is full rate down and 128k rate limited up, so 160kb up is normal sync up rate). For me I usually get sync up rates of around 6.5MB down and 160kb up. I'm about 1.8km from the exchange and I think my friend is approx 2.5km from the exchange. Not sure if this will help but....

  40. virgo17

    virgo17 Network Guru Member

    Hi DonJuancho,

    I hope I can provide some helpful information for you.

    As I mentioned, I have one WAG200g in Spain and one in the UK. In Spain my ISP is Telefonica who supply a dynamic IP. Here in the UK my ISP is Newnet who provide a static IP.

    In either location the WAG200g doesn't seem to know that it has lost the link and therefore just sits there with all the green lights on. This happened here (in the UK) two nights ago and in Spain about two weeks ago.

    In Spain, I am always allocated a new IP address after the link is lost whereas here in the UK it obviously remains the same. The way in which the WAG200g responds (or rather doesn't) in either country seems to be the same.

    I have now rolled back my UK unit to 1.0.09 and will do the same to my unit in Spain in two weeks when I am there. The unit in Spain will be more of a test as there is normally a loss of sync once every two weeks or so. Not because of poor line stats but probably because Telefonica are working on the exchange or lines.


  41. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    My ISP provides me with a fixed IP address which I embed in my modem/router and also set in the Windows settings so that I always use the same IP address (I also set fixed DNS servers as well).

    I've been using version 1.0.09 for some weeks now (cured the disconnect problem for me) but from memory, when running version 1.01.04, I suspect that the router did not detect a drop in connection (status LED light staying green) and the logs did not show any loss of connection, even though there was.

    Now, if connection is lost, the status LED light turns red and the unit goes through the 'keep alive' operation and re-establishes connection for me.

    Sure is a mystery as to why some are finding the WAG200g is ok with the latest firmware, and others are not but I'll leave that to the techi' people to suss out ; )
  42. wlgspotter

    wlgspotter LI Guru Member

    Hi DonJuancho,

    OK have re-tested this again at home, using v1.01.04.

    Basically, when I pull out the phone line, the DSL and Internet status led remains green, for about 30 secs, before going out. Once it goes out, the status page of the router shows the internet interface as down, but still with my WAN IP address. Obviously the routing table still shows the default route via my WAN, which obviously doesn't exist now - I've refreshed the pages a couple of times to confirm. Interesting is at this point I can even pin the WAN IP, but now the WAN's gateway (the other end of the PPPoA connection)..! This is not right cos I shouldn't have a WAN IP now...

    I then plug back the phone line, and ofter a while, the DSL link starts blinking (retraining) and stays green, followed by the internet light. On the router status page now it shows internet interface as up, with the SAME WAN IP, and routing table obviously doesn't change. Of course I can continue ti ping that same WAN IP, but not the default gateway or DNS servers.

    I have to manually click on disconnect, and connect again to get it to work, by which obviously have assigned my a new WAN IP.
  43. DonJuancho

    DonJuancho LI Guru Member

    Hi Everyone,

    I was finally able to reproduce the problem myself. It turns that why it didn't happen before is that I didn't reboot the router after flashing firmware 1.01.04 onto it. The odd thing is that my WAN IP isn't changing at all (not like in your case WLG).
    I don't believe this is a viable workaround at all, but keep-alive works on 1.01.04 if you have just flashed it. Prior to loading the firmware, the router must be on 1.00.09 and properly configured with your WAN settings.

    Keep-alive will continue to work until the router is rebooted/power-off/etc.. Try it out.
  44. wlgspotter

    wlgspotter LI Guru Member


    I don't quite understand what you mean....Can u elaborate further on the steps you've taken to solve this, if it's possible at all..?

    I've actually tried flashing firmware a couple of times, even from 1.00.09 (with correct WAN settings) to v1.01.04, but still doesn't seem to work for me. Besides, leaving the router turned on all the time is really not quite an option for me...

  45. DonJuancho

    DonJuancho LI Guru Member

    I don't actually consider it a solution, because as soon as the router is rebooted, the problem happens again. Knowing this would help ensure that the engineers will be able to successfully replicate the problem, and act on it.

    Here's what I did when keep alive worked with 1.01.04:
    1. Downgrade to 1.00.09.
    2. Configure WAN settings (with keep alive selected)
    3. Upgrade back to 1.01.04.
    4. Tested it out (unplugged line cable and reconnected it). Keep-alive apparently works.

    If I turn off my router at this point and turned it back on, keep-alive will not work anymore. The problem should now be 100% reproducible (once your aware of the exception)
  46. wlgspotter

    wlgspotter LI Guru Member

    Thanks for the info/tip. After reading through your original post yeah I realised you mentioned it's not quite a viable solution, but hey you might be right it's perhaps something for the engineers to work on.

    When I did the downgrade and upgrade again the last time, I did blow away my configs (reset to default) prior to each firmware change as has been suggested/advised, hence my keep-alives never worked on 1.01.04...

    I'll find some time and give it a go and see if it works.

    Thanks again!
  47. virgo17

    virgo17 Network Guru Member

    I think it is possible that although the firmware of the router is being rolled forward, it might be that the portion of the operating system which controls disconnection detection may not be loaded (into memory?) until after a cold start. Thus the router, although having the firmware changed, does not fully implement it until power is removed and reconnected.

    Just my $2.

  48. wlgspotter

    wlgspotter LI Guru Member

    Hi everyone:

    I did some further tests, and found something weird seems to be happening...

    I was going to try DonJuancho's test on downgrading to 1.00.09, and upgrading to 1.01.04 again... However, before I tried (haven't downgraded yet, was already running 1.01.04 for 2 weeks now, but with connect on demand), I changed from Connect on Demand to Keep-alive 20 secs, let the router reboot itself, and then pulled out the phone line...

    Link went down as expected, took about 10 secs for both ADSL and Internet led lights to go out, then waited about 30 secs before plugging phone line in. After I plugged phone line in, the ADSL light came up, then the internet led turned red, my gateway status page refreshed with to WAN IP, then my internet light came back up upon successful PPPoA auth, internet light turned green, gateway status page refreshed with a new WAN IP, and hey presto my internet is back up.. And I DID NOTHING, other than to pull out phone jack and plug in again.

    Weird...? Well, I did power cycle the router and tried again. First time pulling out and plugging in did not work (as before).. but the 2nd time it worked..! Really weird and I can't make out what's going on... Still looked like some firmware trouble to me, but this latest discovery have left be stumped..! In any case I'm leaving it as keel alive 20 secs for now...
  49. wesmond

    wesmond LI Guru Member

    Hi guys,

    Woytekm has released version 6 of his modified firmware, which is built on the 1.01.04a GPL code - Linksys don't seem to have provided a compiled version of that.


    I've not tried it yet to see if it fixes any of our problems - will do later in the week if no-one beats me to it!

  50. zedzed

    zedzed LI Guru Member

    Hi, i own the router since few days.
    I have the problem of disconnetion and no reconnection too.
    So i downgraded with 1.00.09 and at least it auto-reconnects.
    But the real problem I have is: it disconnects a lot of times!
    And is not an adsl line problem, cause with the router i had before this one there were no disconnessions!
    Do you have the same problem?
    Do you think it's broken?

    Thanks in advance.
  51. DonJuancho

    DonJuancho LI Guru Member

    the problem has been fixed with a beta firmware, 1.01.5a. You can either wait for it to be officially released, or call Linksys support for it.
  52. zedzed

    zedzed LI Guru Member

    Hi I have received this firmware:


    Do you think yours is a newer beta? Cause your is 1.01.05a ?
  53. wesmond

    wesmond LI Guru Member

    1.01.04a fixes it too?

    Hi all,

    Woytekm's build 6, containing the Linksys 1.01.04a seems to work for me - I've had my router up and running now for 4 days without a drop. With 1.01.04 I could only manage an hour or two. At last...!

  54. sam_linksysinfo

    sam_linksysinfo LI Guru Member

    Hi.... I too have recently switched to Woytekm's firmware version 6 (many thanks to Woytekm) and so far, so good.

    Certainly much better than Linksys's original (why has it taken them so long to upgrade a firmware version that so obviously had problems?) and hopefully the latest reported update (v1.01.5a ?) will be generally available soon (I keep checking Linksys's site but it's not been posted yet :confused: )

    Thanks again to Woytekm :)
  55. DonJuancho

    DonJuancho LI Guru Member

    The image file that I have is of this size:
    3.62 MB (3,801,088 bytes)
  56. ReDFlaG

    ReDFlaG Network Guru Member

    some news for those who had the problems with pppd not reconnecting after the ppp session was disconnected:

    woytekm has released a new version of his firmware:
    experimental build 0.6.1a is containing pppd 2.4.4+rp-pppoe instead of linksys original 2.4.1-pppoe4. It may fix some problems with pppd not reconnecting after the ppp session was disconnected. You can try this image if you have some ppp related problems

    grab it here, and report if it fixes your issue:
  57. virgo17

    virgo17 Network Guru Member

  58. HiSpeed

    HiSpeed Network Guru Member

  59. ReDFlaG

    ReDFlaG Network Guru Member

    or mail the author wag200 [ at ] g m a i l . c o m to ask him to fix the link.
  60. virgo17

    virgo17 Network Guru Member

    Thank you. I have done.

  61. ReDFlaG

    ReDFlaG Network Guru Member

    link has been fixed, i had been able to download it today.
  62. TryOnNow

    TryOnNow LI Guru Member

    Same problem :(

    Same problem here. I tried 1.01.14 and also latest woytekm release (I haven't tried latest experimental release). Connection is so unstable that it is impossible to work. So i switched back to my old modem and use wag200g as bridge. Any suggestions?
  63. ReDFlaG

    ReDFlaG Network Guru Member

    try the experimental release, it is intented to fix your issue.
  64. TryOnNow

    TryOnNow LI Guru Member

    As i see experimental release will only fix reconnecting problems, but i have not reconnection problems - router successfully reconnects after lost of connection, but reconnects are too frequent.
  65. cwaterworth

    cwaterworth LI Guru Member

    Hi All,

    I'm in NZ (Telecom) and have a just got a WAG200 - it sucks! Its has fireware 10.01.04 and during peak hours (17:00ish to 22:00ish) it disconnects/reconnects so often its almost unusabe. outside peak times its rock solid. I think linksys have a compatibility issue with Telecom's Dslams? There seems to be alot of other kiwis with problems with the wag200. Linksys support have been as useful as a chocolate tea pot!
  66. wlgspotter

    wlgspotter LI Guru Member

    Hi cwaterworth:

    Do you know which Telecom exchange/DSLAM you're connected to? I'm connected to the Johnsonville (Wellington) exchange, which still uses the Nokia D50e DSLAMS, and have no problems with either frequent disconnects, or the reconnection problems (my earlier reconnection problems have been fixed with 1.01.05). I have a friend who is connected to the Lower Hutt exchange, running on the Alcatel ASAMs, and he has no disconnection issues either. I have tried both from peak and off peak times - in fact I usually use my router at home mostly during evening peak from 18:00 till 22:00 hours.

    For the record I have never have any disconnection problems at all on the WAG200G - only the odd (and odd means sometimes 1 disconnect in a couple of weeks!) even using the older firmware.. Could it be a faulty unit?..
  67. cwaterworth

    cwaterworth LI Guru Member

    I'm on the Devonport exchange, Auckland - no idea if its Nokia or Alcatel. I'm wondering if the WAG200 is over sensitive to increase in noise that could happen during peak hours? (PS, where can I get 10.01.05 - not sure which Annex i need, bought the unit in NZ)
  68. wlgspotter

    wlgspotter LI Guru Member

    1.01.05 is currently a beta and is being released only to some people who have contacted Linksys about the disconnect / reconnect problem. Suggest you drop them and email to obtain it. For WAG200G here in NZ you'll need the Annex A version.

    Good luck!
  69. ItalianJob

    ItalianJob LI Guru Member

    Firmware 1.01.05(01) beta (19/06/2007) : http://www.badongo.com/file/3684376
    Fixes known issues:
    - Remote PPTP Clients unable to connect to PPTP server behind the WAG200G
    - WAG200G - Keep Alive function for the PPPoA/PPPoE does not work.

    An older version :
    Firmware 1.01.05 beta (06/06/2007) : http://rapidshare.com/files/36755970/WAG200G-EU-AnnexA-ETSI-ML-1.01.05a.zip.html
    or http://www.adslnet.es/downloads/WAG200G-EU-AnnexA-ETSI-ML-1.01.05a.zip
  70. aurimas

    aurimas Guest

  71. cwaterworth

    cwaterworth LI Guru Member

    I've now tried 1.01.05 beta - no difference, it still disconnect/reconnects every few seconds during peak times. :( I'm going to have to take it back to the store and get something else. lifes to short to keep tring to fix it.
  72. TryOnNow

    TryOnNow LI Guru Member

  73. main

    main LI Guru Member

    i've tried the latest experimental firmware by woytekm, but there're still disconnections, just the behaviour of them is different: the internet light is getting red and hang up - so no autoconnection;

    below my router log:

    Sat, 2007-07-14 11:08:51 - Serial link appears to be disconnected.

    Sat, 2007-07-14 11:08:51 - Connect time 2548627.0 minutes.

    Sat, 2007-07-14 11:08:51 - Sent 131928828 bytes, received 329591771 bytes.

    Sat, 2007-07-14 11:08:57 - Connection terminated.

    Sat, 2007-07-14 11:08:57 - Modem hangup

    Sat, 2007-07-14 11:08:57 - Exit.
  74. woytekm

    woytekm LI Guru Member

    How long have you waited after the disconnection ? It can take up to 1 - 2 minutes for modem to connect again in case of disconnection ....

    Here are my 0.6.2a logs after manual disconnection of ADSL line:

    Sun, 2007-07-15 09:13:53 - No response to 3 echo-requests
    Sun, 2007-07-15 09:13:53 - Serial link appears to be disconnected.
    Sun, 2007-07-15 09:13:53 - Connect time 2549951.8 minutes.
    Sun, 2007-07-15 09:13:53 - Sent 26069358 bytes, received 68406092 bytes.
    Sun, 2007-07-15 09:13:59 - Connection terminated.
    Sun, 2007-07-15 09:13:59 - Modem hangup
    Sun, 2007-07-15 09:13:59 - Exit.
    --- here is the first try after 30 secs.
    Sun, 2007-07-15 09:14:31 - Plugin pppoa loaded.
    Sun, 2007-07-15 09:14:31 - PPPoATM plugin_init
    Sun, 2007-07-15 09:14:31 - PPPoATM setdevname_pppoatm - SUCCESS:0.35
    Sun, 2007-07-15 09:14:31 - pppd 2.4.4 started by root, uid 0
    Sun, 2007-07-15 09:14:31 - Using interface ppp0
    Sun, 2007-07-15 09:14:31 - Connect: ppp0 <--> 0.35
    Sun, 2007-07-15 09:14:37 - LCP terminated by peer
    Sun, 2007-07-15 09:14:40 - Connection terminated.
    Sun, 2007-07-15 09:14:40 - Modem hangup
    Sun, 2007-07-15 09:14:40 - Exit.
    ---- here is the next try - this time connection is established
    Sun, 2007-07-15 09:15:15 - Plugin pppoa loaded.
    Sun, 2007-07-15 09:15:15 - PPPoATM plugin_init
    Sun, 2007-07-15 09:15:15 - PPPoATM setdevname_pppoatm - SUCCESS:0.35
    Sun, 2007-07-15 09:15:15 - pppd 2.4.4 started by root, uid 0
    Sun, 2007-07-15 09:15:15 - Using interface ppp0
    Sun, 2007-07-15 09:15:15 - Connect: ppp0 <--> 0.35
    Sun, 2007-07-15 09:15:18 - CHAP authentication succeeded
    ... total time needed for succesfull reconnect was above 60 sec...
  75. TryOnNow

    TryOnNow LI Guru Member

    Where to find these logs? Because in admin panl i can see only many [outgoing]/[incoming] logs. (I'm using Linux).
  76. main

    main LI Guru Member

    hi woytekm & thanks for fast reply;
    after disconnection modem is trying to reconnect all the time, but it can't;
    next bad thing about your firmware is modem disconnections at strange moments, in case of 1.01.05a firmware & 1.00.09 only when someone is calling; now i'm checking 1.00.09 once again, because i think it's the most stable;
    if you want i can further investigate your firmware behaviour;

    logs: administration/reporting, it must be enabled, you have to click next page until you find the disconnection lines;
  77. woytekm

    woytekm LI Guru Member

    > after disconnection modem is trying to reconnect all the time, but it can't;

    Can you please paste here logs from this reconnection retries ?
  78. main

    main LI Guru Member

    i've loaded your firmware and checking it right now, but instead of using wifi i'm now connected by cable and first hours look very well; when i've a call there wasn't disconnection and the modem succesfully reconnected after manual adsl line disconnection;
    so maybe it's wireless fault?
  79. main

    main LI Guru Member

    unfortunately the same error on lan connection too; below log:

    Sun, 2007-07-15 15:42:54 - UDP Packet - Source:,12124 Destination:,4632 - [Outgoing]

    Sun, 2007-07-15 15:43:01 - No response to 3 echo-requests

    Sun, 2007-07-15 15:43:01 - Serial link appears to be disconnected.

    Sun, 2007-07-15 15:43:01 - Connect time 2.0 minutes.

    Sun, 2007-07-15 15:43:01 - Sent 48861 bytes, received 59408 bytes.

    Sun, 2007-07-15 15:43:07 - Connection terminated.

    Sun, 2007-07-15 15:43:07 - Modem hangup

    Sun, 2007-07-15 15:43:07 - Exit.

    Sun, 2007-07-15 15:43:29 - Plugin pppoa loaded.

    Sun, 2007-07-15 15:43:29 - PPPoATM plugin_init

    Sun, 2007-07-15 15:43:29 - PPPoATM setdevname_pppoatm - SUCCESS:0.35

    Sun, 2007-07-15 15:43:29 - pppd 2.4.4 started by root, uid 0

    Sun, 2007-07-15 15:43:29 - Using interface ppp0

    Sun, 2007-07-15 15:43:29 - Connect: ppp0 <--> 0.35

    Sun, 2007-07-15 15:43:59 - LCP: timeout sending Config-Requests

    Sun, 2007-07-15 15:43:59 - Connection terminated.

    Sun, 2007-07-15 15:43:59 - Modem hangup

    Sun, 2007-07-15 15:43:59 - Exit.

    Sun, 2007-07-15 15:44:24 - Plugin pppoa loaded.

    Sun, 2007-07-15 15:44:24 - PPPoATM plugin_init

    Sun, 2007-07-15 15:44:24 - PPPoATM setdevname_pppoatm - SUCCESS:0.35

    Sun, 2007-07-15 15:44:24 - pppd 2.4.4 started by root, uid 0

    Sun, 2007-07-15 15:44:24 - Using interface ppp0

    Sun, 2007-07-15 15:44:24 - Connect: ppp0 <--> 0.35

    Sun, 2007-07-15 15:44:54 - LCP: timeout sending Config-Requests

    Sun, 2007-07-15 15:44:54 - Connection terminated.

    Sun, 2007-07-15 15:44:54 - Modem hangup

    Sun, 2007-07-15 15:44:54 - Exit.

    and lines from plugin... to exit are repeating infinitely; now i will disable wlan on router and see is it getting any better;
  80. main

    main LI Guru Member

    after disabling wlan on router everything looks fine on woytekm firmware till now, so i think that wlan module makes all this mess;

    edit: just after sending this post, the modem have disconnected :/; log errors as same as previously;
  81. Radio-tech

    Radio-tech LI Guru Member

    Hi all just to confirm I'm in the UK and I have the same problem, no internet access at times all lights green, login to the router go to the status page hit the disconnect button then hit the connect button everything is then fine or if you physically remove the connection and reconnect, I'm also on Firmware Version: 1.01.04

    I have just spoken to Linksys support and a new firmware will be released in a few weeks, they will not send out any betas firmware’s at present because of this, when I asked about the said problem, I did not get a direct answer if the reconnecting problem has as been addressed
  82. woytekm

    woytekm LI Guru Member

    > Sun, 2007-07-15 15:44:54 - LCP: timeout sending Config-Requests

    It seems that there is some low level DSL-hang problem that won't be fixed by simply restarting pppd. I'll check what can be done about this. Simple soultion could be to automatically reboot the router if it can't connect after some given number of tries. Ofcourse if this problem will happen too often - it does not look like acceptable solution.
  83. virgo17

    virgo17 Network Guru Member

    There are a couple of links earlier in this thread where you can download the Linksys beta firmware. According to the text file supplied with them the lack of reconnect problem was one of the reasons for the new version. However, I can't guarantee that these text files accompanying the firmware were actually written by Linksys. I guess these are versions that people have been sent by Linksys. Use them at your own risk.

    I am also in the UK and had the same problems as you with the supplied firmware. I am now trying out version: 1.01.05 (01) beta, but it is too early to comment on whether the issue is fixed for me. It certainly reconnects when I pull out the DSL cable, but I am not convinced that this is the kind of failure that caused the lack of reconnection previously.

    Good luck.

  84. Radio-tech

    Radio-tech LI Guru Member

    Thanks virgo17 a little wile ago I was actually at my computer and I lost my internet connection, looked at the router all green, so again I hit the disconnect and reconnect button this time still the same done a soft boot still no good then selected hard boot this time it worked, so I am now wondering if it’s a time bomb for want of better terminology which locks up totally (freezes) this may have been a one off I will have to see if it happens again
  85. gsan

    gsan LI Guru Member

    I just changed linksys WAG200G problem and I faced a problem now.

    there are 2 pc + 1 laptop in my home network. the gateway ip is and the rest 3 computer ip are (LAN), (LAN) & (wireless). all the pc can shared the files to each others and connected to internet. but after long period non stop usage (normally within 48hours), all the pcs cannot connected to internet included cant access to but still can share files to each others. in order to let everything works back, I have to power off the modem and on it again. so got any solution?
  86. ItalianJob

    ItalianJob LI Guru Member

    Just for info, the source for 1.01.05 is uploaded here :

    I guess Woytekm is already working on it :biggrin:
  87. ItalianJob

    ItalianJob LI Guru Member

    The 1.01.05 final version is available on the linksys site.

    - Fixes issue with WAN connection not comming up after unplug/plug dsl cable back
    - Fixes issue with Setup Wizard security
    - Fixes issue with UI display on 120 DPI
    - Adds Brazilian-Portuguese language
    - Adds additional port mapping fields on Port Forwarding
    - Updates new Cisco Logo"

    File : WAG200Gv1-EU-AnnexA-ETSI-ML-v1[1].01.05a.zip
    Date : 07/11/2007

    The binary (.img) is different from the last 1.01.05 (01) beta :smile:
  88. ItalianJob

    ItalianJob LI Guru Member

    Can you believe it ? The 1.01.05 final release = the first 1.01.05 beta :frown: :eek:

    BTW, the true release date (06/06/2007) is given here :
  89. TryOnNow

    TryOnNow LI Guru Member

    Any download link?

    I always go to linksys.com site throw google.com search, and after entering wag200g it finds it only in Australian Linksys page, where freshest firmware is 04.
  90. virgo17

    virgo17 Network Guru Member

    It is quite hard to find. You need to set your country on the main Linksys page. This is the URL I used to get the UK version. This is a tinyurl, it expands to the full Linksys URL:


    Hope this helps.

  91. ItalianJob

    ItalianJob LI Guru Member

  92. Radio-tech

    Radio-tech LI Guru Member

    I have tried downloading the 1.01.05 file but whatever browser I use I get JavaScript: void (0) any one know why
  93. Radio-tech

    Radio-tech LI Guru Member

    Just got back on to Linksys and they emailed it to me while I was on the phone
  94. TryOnNow

    TryOnNow LI Guru Member

    I haven't tried it yet, so can you say me - did it fixed connection problems?
  95. Radio-tech

    Radio-tech LI Guru Member

    I would definitely up grade, it seems to of sorted my problem out.

    Tested for a while now and it will reconnect, but my thru put stops and the only way to restore the internet is by rebooting or pulling the line out for about 20 seconds and reconnecting, it always happens between 9pm an 10.30pm (in the UK) so this strange problem I put down to my ISP even though they say nothing is wrong?
  96. EviLBLuRz

    EviLBLuRz Guest

    ermmm..so what is the best solution? anybody has figure it out?
  97. NewK

    NewK LI Guru Member


    i have the same problem with the new 1.01.06, and 1.01.05 fw.

    but for me, the Internet light goes RED, and it doesn't reconnect.

    i've the keep alive option turned on, with 30 seconds reconect..

    but it can stay all night with red light turned on, and in the mornig when i turn on my pc i've got to restart router..

    the adsl status appears like this :
    DSL Status: Connected
    DSL Modulation Mode: MultiMode
    DSL Path Mode: Interleaved
    Downstream Rate: 0 kbps
    Upstream Rate: 0 kbps
    Downstream Margin: 2147483643 db
    Upstream Margin: 10 db
    Downstream Line Attenuation: 30 db
    Upstream Line Attenuation: 6 db
    Downstream Transmit Power: 12 db
    Upstream Transmit Power: 23 db

    am I doing something wrong?

    greetings from Portugal
  98. NewK

    NewK LI Guru Member

    can some body help me please?

    i'm almost sure i'm making something wrong..

  99. mstombs

    mstombs Network Guru Member

    Hi and :welcome:

    This value in your stats, shows that their is a physical problem with your connection, I suggest you check your local wiring and cables and filters on all phone devices etc

    It is probably trying to tell you -5dB, but there is a bug in the core Ti AR7 tiatm code that publishes the negative number as an unsigned integer.
  100. NewK

    NewK LI Guru Member


    thanks for the answer.. yes, i know that sometimes my connection is troubler, but when this happens , if I unplug the phone cable from the router and plug it again it works again.. I was just wondering if the router himself could do it without my intervention..

    thanks :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice