WAG354G firmware 1.01.54-EU is out.

Discussion in 'Linksys Official Firmware' started by gulp, Mar 2, 2006.

  1. gulp

    gulp Network Guru Member

    hi, a new firmware 1.01.54-EU is out on ftp://ftp.linksys.com/opensourcecode/wag354g/1.01.54-EU/ in sourcecode, anyone is able to do a binary of this release to update my router?
    i'm still not able to do tracert or play with ps2 with WAG354G, maybe this firmware can resolve this issues.
  2. OohAhh

    OohAhh Network Guru Member

    Not sure if this is going to be possible. The filename of the source code is WAG354GV2-EU_v1.01.54.tar.bz2. That seems to suggest that it's for a V2 of the WAG354G. Anyone know if there is such a thing or if one is due out soon?
  3. tarquel

    tarquel Network Guru Member

    yeah. Any improvements would be welcome I'd say.

    I'd hope the V2 means something different i.e. a whole new firmware or something, but I'd wager its for a newer router they'll be ringing out.

    Shame... :(

  4. gulp

    gulp Network Guru Member

    no one is able to compile this firmware?
    I'm not able to do it, i've tried but without luck :( under gentoo
  5. icest0rm

    icest0rm Network Guru Member

    very strange that in linksys beta site the binary appeared only for WAG354GV2-E1 Annex B device
  6. TazUk

    TazUk Network Guru Member

    Are you sure it's not the WAG354G-EU_AnnexA_ETSI_v1.01.05_004_code.zip firmware that was released at the end of last year?
  7. OohAhh

    OohAhh Network Guru Member

    The Annex is defined in the file src/cy_codepattern.mak. In this case it's set as "ADSL_TYPE=AnnexA".

    Just one annoying point is that the config filese are generated by a file called gen.pl. I assume this is a perl script, but it isn't in the tartball. Still since they haven't removed the unenabled options it should be possible to configure it by hand. Can't guarantee it'd work completely without some of the programmes being reconfigged too.
  8. OohAhh

    OohAhh Network Guru Member

    Yes. The file WAG354G-EU_v1.01.05.tar.bz2 expands to WAG354G-EU-v1_01_05-004 and the WAG354GV2-EU_v1.01.54.tar.bz2 tarball contains WAG354GV2-EU-v1_01_54-000.

    I haven't had a very detailed look, but the WAGV354V2 source has an extra driver under the ti_avalanche dir tree. It's called ti_apex and seems to have something to do with setting clock frequencies. Perhaps some kind of change to the wireless hardware? Anyone know what this bit of hardware, presumably TI Apex, is?
  9. icest0rm

    icest0rm Network Guru Member

  10. TazUk

    TazUk Network Guru Member

  11. OohAhh

    OohAhh Network Guru Member

  12. capthookb

    capthookb Network Guru Member

    Comparing the two /src/cy_conf.h files of the following tarballs
    i found out three differences. They have enabled:
    they added:
    and finally they added (but disabled) options:
  13. fra996

    fra996 Guest

    Hello Guys,
    i have the WAG354G 1.01.03 ANNEX A: i could i understand if it's V1 or V2?From serial number?!
    Should i flash it with 1.01.05 or could flash it with 1.01.54?
    Is it safe the upgrade? Anyone experienced the upgrade?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice