WAG354G firmware question and advice needed

Discussion in 'Linksys Official Firmware' started by tarquel, Sep 13, 2005.

  1. tarquel

    tarquel Network Guru Member

    Hi all

    Here is version 1.01.05 hosted by myself:


    Many thanks to lewer for sending me it :)

    I accept no responibility for any damage caused by use of this firmware. It has not been modified or altered in any way by myself and is, as was sent to me.

    Just so we are clear :)

    Previous initial post follows:

    Had my WAG354G (http://www1.linksys.com/international/product.asp?coid=6&ipid=764) for a month or so now.

    I'm pretty impressed with it so far EXCEPT it seems to die - especially the wifi aspect - after some heavy file transfering across my home network - i.e. shifting gig's of info about along with some heavy downloading too.

    Like everyone I guess, I have it running 24/7 as these things are meant to be "on" like that, so I'm wondering really if anyone has one and knows if there is any official or unofficial firmware updates for it?

    My current version is: 1.01.03, May 17 2005

    I notice on the FTP site that there is one firmware available but I dont want the languages/menu's to be in german (no thanks lol).

    Here's a link to the folder:


    and the file(s) are:


    (not sure of the dif between the first and second file)

    Any help and suggestions would be handy :)

  2. calum

    calum Network Guru Member

    Think you need to avoid this one... UK and most of Europe uses the Annex A system rather than Annex B, IIRC. I'm hoping for some new firmware soon so I can go online with my PS2 again :/
  3. wknock

    wknock Network Guru Member



    re firmware: I've spoken to linksys, and they've sent me a beta of 1.01.04 which I've installed. Unfortunately, the version they've sent was German, so now all the menus have changed! Hoping to get an English one soon though, will let you know how I get on.

  4. calum

    calum Network Guru Member

    Re: WAG354G

    Typical... I spoke to them yesterday and they told me there were no updates imminent :/ Don't suppose you've got a PS2 you could test it with to see if it solves the problems I've been having with that? :)
  5. RussellS

    RussellS Network Guru Member

    Hi there,

    I have just been emailed firmware 1.01.05 from Linksys support.

    It is AnnexA and language is English.

    If anyone wants it PM me with your email address.


  6. panosgremlin

    panosgremlin Guest

  7. ps999

    ps999 Network Guru Member

    When I had problems a month or so back, Linksys support sent me a link to Version 1.02.7 dated Oct 19 2004. Annex A UK

    It works fine but I still get the occasional drop out of wireless, particularly after the log shows lots of "2DNS NWRITEs"

    I can tell when it is going to start playing up when the WAG54G time stops advancing
  8. RussellS

    RussellS Network Guru Member


    ps999: This thread is about the WAG354g (not WAG54g). they are completely different beasts.

    panosgremlin: you've got mail


  9. ps999

    ps999 Network Guru Member

    Oops!! Sorry guys, misread the model number!!
  10. TazUk

    TazUk Network Guru Member

    Blame Linksys's great numbering system :roll:
  11. ratclj01

    ratclj01 Network Guru Member

  12. arubinst

    arubinst Network Guru Member

  13. tobas

    tobas Guest

  14. Kross

    Kross Guest

  15. ratclj01

    ratclj01 Network Guru Member

    bloody hell, how quite is this forum
  16. hugol

    hugol Network Guru Member

  17. ratclj01

    ratclj01 Network Guru Member

    anyone here, does anyone wana help anyone at all
  18. gueric

    gueric Guest


    I have this version but I still have problem with my connexion
    to Centralstation (PS2) to play with Socom.
    I opened the ports 6000 to 6999 and 10070 to 10080 TCP/UDP
    without success..

    I received it from the Lynksys support.


  19. arubinst

    arubinst Network Guru Member


    Could you please mail me the firmware? There is no way to get it from linksys support here in Switzerland!

  20. ratclj01

    ratclj01 Network Guru Member

    If you have then can you either host on a FTP site or email to us all?
  21. csdcom

    csdcom Network Guru Member

    WAG345G firmware

    Just keep on at them they will eventually send it to you it is available.

    I managed to get it, and will try to post it somewhere
  22. csdcom

    csdcom Network Guru Member


    anybody know how to get the firmware posted in this forum if so let me know and I will post the 1.01.05 firmware from Linksys for the WAG345G
  23. csdcom

    csdcom Network Guru Member

    Firmware 1.01.05

    For all those who asked for it I have emailed it to you
  24. ratclj01

    ratclj01 Network Guru Member

  25. tarquel

    tarquel Network Guru Member

    Completely forgot I started this thread lol *doh!*

    ratclj01 - i tried it but the archive is corrupted and doesnt extract.

    If someone can pm and send me it, i'll host it for everyone :)

    According to the readme of the german version, it only updates the help menus - doesnt mention any actual decent fixes.

    A bit late I know but the PS2 works fine with the WAG354G [1.01.03 my firmware is currently] - playing Time Splitters 3 online with no problems :)

  26. tarquel

    tarquel Network Guru Member

  27. lewer

    lewer Network Guru Member

    Linksys sent it me yesterday. PM me with your email and i'll try and get it to you.
    It fixes the ddns problem, also i was having a problem with remote management which is now fixed. The only thing that is still not working properly is uPnP.
  28. luckystroke

    luckystroke Guest

    please also send me the firmware

    Could you please send me the firmware version 1.5 eu also PLEASE :)

    Seeams we're all looking for the same...

  29. synapse

    synapse Guest

    Thanks mate!

    Just wanted to send a public thanks to Lewer for sending me the WAG354G firmware. Now means I have a functioning box that's not all in French and doesn't subsequently have to go back to the rubbish online retailer (Pixmania) I got it from!

    Good on yer mate! :thumb:
  30. lewer

    lewer Network Guru Member

    glad to be of assistance
  31. tarquel

    tarquel Network Guru Member

  32. skarvelas

    skarvelas Guest

  33. antman316

    antman316 Guest

    So how did you get your PS2 to work with WAG354G? What is your set up and what settings have you entered into the router? (minus username and password of course).

    I am having a hectic time trying to get mine to work. I've stuck it in the DMZ, forwarded all the ports mentioned here, and have been messing with the MTU setting as recommended by the Linksys Tech Support I spoke to today.

    It takes 15 mins for DNAS to authenticate. When I try to connect to Central Station, it immidiately says it cannot be contacted.

    I found this post on another forum which describes a similar problem, but the user seems to be able to figure out what the problem is.
  34. fonkypij

    fonkypij Guest

    Hi, could you send me your firmware version? Well i don't even know if I can downgrade though...
  35. tarquel

    tarquel Network Guru Member

    Hi all - and no problems with the new firmware [for me] so far...

    Could someone send myself and fonkypij v1.01.03 EU/EN version if you have it?

    Reason being it might be useful for peopl who have problems with the latest version - though I cant say whether you can downgrade or not :S

  36. MattM

    MattM Network Guru Member

    Just FYI, having a hell of a time getting any kind of answer about WPA2 support on the WAG354G.

    Seems that despite initial marketing material going out stating WPA2 support (and hence everyone selling these things quotes WPA2 support) - "It is possible that we will create a new firmware for the WAG354G that will work on WPA2 but as of the moment, we do not have any information when it will be released or if the engineers are in the processs of creating a new one."

    Also had notice from one engineer that "The firmware version 1.01.05 still does not support WPA2." - can anyone confirm this to be the case?

    And has anyone more skilled in the arts of code tinkering than I (which is pretty much the entire planet) had a stab at creating third party firmware for the WAG354G yet?
  37. marcooo

    marcooo Network Guru Member

    firmware WAG54G v1.2

    I have the fw 1.06.6 wich doesn't support wds. Could anyone send me one firmware which can support wds on my wag54g?
    I heard that the 1.02.9 does it...

  38. calum

    calum Network Guru Member

    Dunno, but if you find out, let me know. Still haven't got mine past the same DNAS problem, using the .05 firmware. Exact same settings worked fine on my old WRT54G, before it packed in :/
  39. tarquel

    tarquel Network Guru Member

    Re: firmware WAG54G v1.2

    We are on about the WAG354G - not the WAG54G! - here.

  40. joewalsh

    joewalsh Network Guru Member

    Someone mentioned this is for AnnexA, not B like the UK uses. What is the difference as my WAG354G came with A5 sheets covering regulations for Annex A and Annex B. Im confused!

    Bought and used in the UK. I'm hoping this may help me get true speeds on my router.
  41. papios

    papios Network Guru Member

    Please help me! I own a wag354g and upgraded to 1.01.05 but it changed the language to german so I tried to flash it back to 1.01.03.

    I found the firmware, downgraded to 1.01.03 but since then I can't upgrade my router.

    In addition, despite downgrading to 1.01.03 english, the language remains german.

    Please help me!! Thank you!
  42. Viper_74

    Viper_74 Network Guru Member

    I've read the firmware change:

    - Updated help pages and web GUI

    And if I understand correctly there's not much changed except for the looks.

    My 354G won't connect with my adsl provider (dsl connection won't keep up)
    I still have the 1.01.03 firmw but I don't think upgrading will help much. Is my linksys broken (just got it last week) or is there a problem with my ISP <-> Linksys that may be resolved with a later firmware upgrade
  43. Spiceworm

    Spiceworm Guest

    Official linksys firmware download ftp:


    I'm going to try the new WAG354G-EU_AnnexA_ETSI_v1.01.05_000_code.rar
    hoping my UPNP will keep working now.
  44. shoutje

    shoutje Network Guru Member

    Just upgraded with success, works fine! I only needed to use Explorer because with Safari it's not possible to get in contact with the modem. (401 Unauthorized Authorization required)

    Anyway version 1.01.05 works great, no problems at all.
  45. koert

    koert Guest

    hello all!

    I just try'd to upgrade the firmware to WAG354G-EU_AnnexA_ETSI_v1.01.05_000_code.bin ...

    When I do this through the webbased administration section I get the error: Upgrade has failed...

    Does anyone knows what the reason for this is?
    There still is activity over the network but I disconnected the gatway (adsl) and I disabled the wireless function before I tried it.

    Regards and thanks in advance,

    ps. I will keep on trying and when I have the solution, I will post it here again.
  46. simax

    simax Network Guru Member

    shoutje, did you notice any changes at all?

    On the .05 version documentation the only changes are the help files, apparently.

    Anyone running the latest firmware has noticed any change from the .03 version?

    Having WPA2 supported would be nice. On v.03 only clear, WEP and WPA are supported.

  47. shoutje

    shoutje Network Guru Member

    I didn't notice any changes, it's just easier to get into the menu thru Explorer.

    With the 'older' version I sometimes had to restart my computer to get in touch with the modem with Explorer.
  48. gulp

    gulp Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice