WAG354G internet problem

Discussion in 'Other Linksys Equipment' started by sammyAD, Jan 3, 2006.

  1. sammyAD

    sammyAD Network Guru Member

    I am using a WAG354G router with the newest 1.01.05 firmware (I reset the router to factory settings after upgrading firmware). It is wired to my PC and connected to a laptop via the wireless WPC54G card.

    It works fine for around half a day, then all of a sudden websites stop loading in both IE and FF, which tell me the sever cannot be found. The wierd thing is that the internet connection is still active and instant messaging applications and P2P software still work fine, it is only websites that refuse to work untill i do a hard reset on the router through the control panel. When the problem 1st happened only certain websites wouldn't load (google, yahoo etc) these couldn't be pinged, but other sites (such as somethingawful.com and i forget which others) would still load and let me ping them.

    I have tried disabling my software firewall and its made no difference. At the moment i have disabled all the security options in the router settings (IPeC, PPPoE, PPTP, L2TP passthough, the firewall, and blocking anonymous internet requests). It seems to be working better, except now sometimes some websites don't work the first time i try to access them and only load after i refresh the page telling me the server could not be found.

    The problem is affecting both the PC and laptop and it is seriously annoying having to reset the router every few hours. Is there anything i can do to make websites load properly all the time?

    I've tried enabling high priority HTTP QoS and changing the MTU setting, both make no diference.

    Any help is greatly appreciated!
  2. booly

    booly Network Guru Member

    It look like if you have no longer acces to you isp dns server
  3. sammyAD

    sammyAD Network Guru Member

    I don't understand how i can suddenly just lose access to the ISP DNS. I have the primary and secondary DNS addresses, is there any way i can manually put them in the router or something?
  4. yaboo

    yaboo Network Guru Member

    You can enter 3 static DNS addresses on the Setup page of the config program (the first page that opens after you log on). They do not necessarily have to be the addresses of your ISP DNS.

    By the way, maybe it would be good to ask your ISP too about the problems with DNS.
  5. sammyAD

    sammyAD Network Guru Member

    Thanks, ill add my ISP addresses. Is there anywhere i can get other free DNS server addresses that I could use?

    Wouldn't the problem have to be on my side since it resolves itself once I reset the router?
  6. sammyAD

    sammyAD Network Guru Member

    OK, it just happened again, and its really starting to bug me. Only a few websites would work, but the majority i tried wouldnt load (google, yahoo, bbc etc) however when i put in the IP address for google ( the site loaded up fine. Does this definatley confirm its a DNS issue?
  7. Daedelus

    Daedelus Network Guru Member

    Are you using a manually configured ip or dhcp ?

    I've just upgrade to 1.01.05 and made my wired connection a manually configured ip (it was using dhcp before). The dns I gave the adaptor was the address of the router - after about an hour dns resolution failed. Replacing the dns ip of the router with my isp's dns ip on the adaptor solved the problem. It's been fine now for over 9 hours.
  8. sammyAD

    sammyAD Network Guru Member

    I was having the problem with DHCP was enabled and disbaled. I have disabled it now, and put my ISP DNS on my network adapter - fingers crossed.

    I was having another live chat with linksys tech support and i was told that having a static IP might cause this, and so enabling DHCP may solve the problem. I have always been using static IP addresses set on the network adapter on each computer - even when i had DHCP enabled before. So, if putting my ISP DNS on my network adapter doesnt work, using DHCP to assign my computers IP addresses may be a solution for me ... i'll post back with results.
  9. icest0rm

    icest0rm Network Guru Member

    it's a WAG354G issue, if u use it as DNS after some time it will stop resolving...
    if you oput your ISP DNS, then all will be fine.
  10. sammyAD

    sammyAD Network Guru Member

    Been running for over 24 hours with no problems, looks like its done the trick. Thanks for everyones help!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice