WAG354G power light blinking

Discussion in 'Other Linksys Equipment' started by spwimy, Jan 23, 2007.

  1. spwimy

    spwimy Guest

    I'm trying to get a mates router working after he did a reset. The power light now blinks constantly and I am unable to connect to the routers setup page. I have tried the tftp utility to try an flash the bios but I can't connect.
    Any ideas?
  2. 4square

    4square LI Guru Member

    Have you tried using a static IP address on the PC?
    The manual says:
    16. The Power LED flashes continuously.
    The Power LED lights up when the device is first powered up. In the meantime, the system will boot up itself and check for proper operation. After finishing the checking procedure, the LED remains steady to show that the system is working fine. If the LED continues to flash after this time, the device is not working properly. Try
    to flash the firmware by assigning a static IP address to the computer, and then upgrade the firmware. Try using the following settings, IP Address: and Subnet Mask:
  3. pauldotcom

    pauldotcom LI Guru Member


    The WAG354G uses the PSPboot bootloader:


    It states that it waits for 3 seconds to load new firmware (however if the power light is blinking it should be waiting for new firmware). Try this:

    - Static IP address as stated above
    - Put a hub between your PC and the device so that the Ethernet adapter stays up
    - Make certain you start the TFTP transfer first, then power up the router
    - Run a continuous ping to in another Window (ping -t

    If that doesn't work, then you will need to use a JTAG cable to investigate further.

    Good luck!
  4. masterb

    masterb LI Guru Member

    hi, I had the same problem and I recovered my wag succesfully. In my case neither ping worked. However I have unbricked it!
    Beceause of this I have written a guide, but it is in italian. It is here:http://cyberstorm.altervista.org/2007/01/unbricking-wag354g.html
    Fast explanation:
    1)download a working fw
    2)rename it upgrade_code.bin
    3)start tftp, if you are in linux (best choice), first of starting it change the directory to the place where upgrade_code.bin is located.
    4)in tftp type the commands:
    5)be sure the router power is unplugged, and the ethernet port plugged.
    put upgrade_code.bin
    And immediately AFTER that plug the router supply. If it works youll see this:
    sent DATA <block=6666, 512 bytes>
    received ACK <block=6666>
    sent DATA <block=6667, 512 bytes>
    received ACK <block=6667>
    sent DATA <block=6668, 512 bytes>

    if it doesnt work, after typing "put upgrade_code.bin" wait 0-3secs, or first plug the router, then type the command.

    After the transfer when tftp is still accepting commands, DONT unplug the router, close tftp, go have a coffee, and if you are lucky, when you'll come back you'll have and unbricker router.
    good luck
  5. dhruvitdesai

    dhruvitdesai Guest

    Instead of using commandline for tftp u should use gui tftp app by linksys
    and make sure u choose your default firmware because australian and european firmware size are different ....because when i was trying to do debriking i tried almost everything for my wag54g v2....and then finnaly i got Australian firmware..and more thing make sure about timing when u plugin the power cord then immediatly approx after 3 sec u should click on upload button...
    Finaaly i solved my problem ...hope fully u all guys will succeed ...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice