WAG354G - problems.

Discussion in 'Other Linksys Equipment' started by yaboo, Dec 10, 2005.

  1. yaboo

    yaboo Network Guru Member

    Got my WAG354-EU alive but not kicking. The firmware is 1.01.03. The ISP is Polish TPSA Neostrada.

    The problems are:

    1. ADSL connection does not come back after disconnecting the AC adapter and connecting it again. Not crucial but disappointing. The connection status is keepalive, just in case.

    2. The CONNECT button in the STATUS menu is inactive even if the ADSL is dead, no matter what I am trying to do with the thing. Strange but true. This problem can be worked around (ADSL wakes up after adding fake changes on the initial management page) but this is not what one can expect, is it?

    3. The most annoying thing: the strength of the wireless signal and the speed are more then unstable, no matter how far the receiver is from the WAG. The former fluctuates between 63 and 12 (the receiver still in the same place, no movement) and the latter between 54 and 16Mbps. Only the G cards are present in the network and the wireless mode is also set to G-only. There is no conflict in wireless transmission channels, just in case. No external antenna.

    I have been using a cheap IO-DATA router bought in Japan for almost one year and had no problems with wireless or anything. Now it works as a bridge and extension of the WAG in my place in Poland. So I have two access points at home. No problems still. Any time I am close to the WAG which is connected straight to the ADSL, the problems with wireless transmision emerge.

    Any suggestions? New firmware? Where from?

    Thanks in advance.

  2. HiSpeed

    HiSpeed Network Guru Member


    My suggestion : get a refunding for this crap !
  3. yaboo

    yaboo Network Guru Member

    Good advice. I can also kick it or burn it, I guess.
    More constructive replies welcome...
  4. HiSpeed

    HiSpeed Network Guru Member

    Do you want to know the current number of 354 in RMA ?
  5. yaboo

    yaboo Network Guru Member

    That's nice. Thanks for your cooperation HiSpeed.
  6. vysocan

    vysocan Network Guru Member


    Try new firmware. At first sigth you cant see any changes, but it seems just more stable.
    If you have annex B I can send you newest beta, since Ive been lucky after 3 week of figthting with their support to get one. Annex A is on their ftp.
    Beside this, something is wrong with your unit. Mine was working straight out of box, with some ISP settings.
    Im using B, so I can tell how G behaves. Try different chanels or stop using encryption.
  7. yaboo

    yaboo Network Guru Member

    Re: firmware

    I have Annex A. Should you happen know any reliable source of firmware, please let me know. Y.
  8. vysocan

    vysocan Network Guru Member

  9. yaboo

    yaboo Network Guru Member


    I did try Google of course. It seems, however, that it is much easier to install a firmware that you get stuck with than to get rid of it. So this is why I was asking.

    The Linksys FTP site is the one I know of course but someone complained on the forum, as far as I can remember, that you get German language with the 1.01.05 version from there (in fact, there is a "DE" in its name, so anything can happen). Quite apart from it, Linksys is not a charity organisation, so there could be some more-easy-to-understand way of getting new firmware than guessing by file names, don't you think so?

    I also heard about the site from Poland that you mentioned. The content, however, was advertised elswhere as dangerous and not worth downloading, to say the least. It might have been a hoax but you never know.

    Thank you anyway.

    Does anyone else experience the same pesky problems with their WAG354G as I do? It is really annoying because it is hard to prove it to the reseller that the thing does not work perfectly and it is still not dead. And I am busy like hell, so sending the unit for a check and disconnecting from the net does not look like a nice way to go...
  10. vysocan

    vysocan Network Guru Member

    Well Im not a charity either, but I happen to have


    witch was sent to me by Linksys support. Havent try it, since I have annex B unit. Maybe you can give it a shot.
  11. vysocan

    vysocan Network Guru Member

    and BTW a funny story ... they sent me this firmare 3 times ... no matter that I've been telling them that I need annex B ... and they say its beta :thumb:
  12. yaboo

    yaboo Network Guru Member

    That could be nice. Thank you.

    I am not very eager to experiment with beta versions, however, if I get desperate some day, it may be good to have one. Is possible for you to make the firmware available somewhere at an anonymous FTP server or shoud we exchange it by SMTP?
  13. vysocan

    vysocan Network Guru Member

  14. yaboo

    yaboo Network Guru Member

    Got it! Will try to install, if I get desperate. Thanx a lot!
  15. yaboo

    yaboo Network Guru Member

    By the way. This thread looks like it's over but it may be not over yet.

    No one's got the problem with inactive "Connect" button with WAG354G?

    Can't believe it. Go on, tell me about it...
  16. icest0rm

    icest0rm Network Guru Member

    I've just bought a Linksys WAG354G with bundled a WUSB54G (special price 89 euros :cheering: ) and it came with fw 1.01.03....I had setup connect on request, this morning I've found it not connected and I've clicked on connect...then it connected ok...no probls here...
    now I will upgrade to 1.01.05 by Linksys
  17. yaboo

    yaboo Network Guru Member

    I've just bought a Linksys WAG354G with bundled a WUSB54G (special price 89 euros :cheering: ) and it came with fw 1.01.03....I had setup connect on request, this morning I've found it not connected and I've clicked on connect...then it connected ok...no probls here...
    now I will upgrade to 1.01.05 by Linksys[/quote]

    89 EUR is not a bad price, indeed :) Especially if you have the connect button active (I don't). I use Annex A, by the way, as I have already mentioned, so maybe this is the difference.

    I read your message and checked the official Linksys FTP server. Now I see that they already have the new 1.01.05 firmware in English dated December 19th which was not there before. If I only have time, I will try it and notify you of the results in near future. Should you have any comments after upgrading, please let me know.
  18. icest0rm

    icest0rm Network Guru Member

    yes...router was marked 124 Euros and USB adapter 54 Euros...special price all togheter 89 Euros and I sold my D-Link DI-624...now I'm really satisfied :thumbup:
    Connect buttons worked this morning when I found the router not connected (when I setup it yesterday evening I didn't have much time and I didn't noticed that I left it on "connect on request")...this morning I clicked on "Connect" and it gave me the page saying "connecting" (or something like that) and then when I refreshed it was connected...so all ok here...ah it's an Annex A also mine!

    yes m8, just upgraded all working perfectly...remote management working (was reported not to work), DDNS update working (was reported not to work)...what else was not working before?

    complete version is:

    Firmware Version 1.01.05
    - Fixed and updated help pages and other problems with web GUI
    - Fixed problem with LAN receiving WAN PADI packet
    - Fixed problems with SNMP
    - Fixed problems with Management password set to blank
    - Fixed problems with QoS input values
    - Fixed problems with VPN under Manual mode
    - Fixed problems with MTU not accepting some values in manual mode
    - Fixed problems with different messages showing when PPP disconnected for
    PPPoA and PPPoE
    - Fixed problems with selecting some time zones

    firmware's date on router is: 20 October 2005
    firmware's date on zipped package is: 05 December 2005

    give it a try! :rockon:
    it kept all my settings I had on 1.01.03! No need to setup again! (my D-Link didn't when upgrading)
  19. yaboo

    yaboo Network Guru Member

    I used one hour of Xmas afternoon and upgraded the router to the firmware version 1.01.05 English.

    The upgrade process was irritating. First, the thing reported that the upgrade has failed and ceased to respond to HTTP requests. I rebooted, wondering whether it would respond. It did, happily.

    Next I tried the quoted elswhere trick with renaming the bin file of the new firmware to 'code.bin' or any short name. I did not use, however, the tftp.exe to upgrade. Instead, I tried the usual HTTP interface. It succeeded.

    The first time after upgrade it booted, it connected with no problem. The "Connect" button in the Status menu appeared after pressing "Disconnect" and disconnecting (the thing says: "distonnecting" but I will not be so mean as to criticize the ortography).

    However, when I tried to reboot again, my WAG345G would not reconnect. Tried three times. Nothing. What is funny, the "Connect" button in the Status menu is grayed out.

    The only way to force the connection is to login to the HTTP interface and press "Save Settings" on the initial page. It reconnects. Then, it is possible to disconnect and connect again from the Status menu - the buttons are visible.

    Note that the PPPoA settings are set to 'Keep alive' and still it does not work after reboot. I have at least one more device that will request the connection to the Internet (Linksys VoIP Phone Adapter PAP2, that is) and the connection is not re-established. I connected that last week, when I already had problems with reconneting.

    This means that any power or ADSL failure, which sometimes happens, will require manual intervention. Maybe some of my ADSL settings are incorrect? Does anyone have any idea?
  20. icest0rm

    icest0rm Network Guru Member

    hi m8, no probl here :(
    really strange your probls...maybe try to "restore default settings" and apply again for upgrade.. :thumb:
  21. yaboo

    yaboo Network Guru Member

    I believe you experience no problems, icest0rm. I do, however. My Linksys works and I think that most of users could put up with the status quo, but if I want to setup an Internet server in my LAN, the gateway must reconnect automatically on each and every reset on power failure.

    Restore and setup again? That may be a solution... I thought about it before but did not try that actually.

    I'll try and send you a feedback in a couple of days. Thanx for simple though helpful ideas...
  22. yaboo

    yaboo Network Guru Member

    Better fast than never... :)

    Restored factory settings.

    Connected PC via RJ-45 and inserted the WAG345G Setup CD.

    Performed setup not changing any settings provided by Linksys.

    And now...

    The thing wakes up after being powered up and reconnects automatically with no problem at all. Checked three times. Something must have been wrong with the ADSL settings before.

    The wireless signal is still reported to be unstable but I found out in the meantime that it may be because of the third party Wi-Fi management software that came with my PC.

    Thanks for cooperation. This is, BTW, how human mind works. Real cowboys do not read intructions. Being lazy alone is harmless but if someone tells you on the forum to restore factory settings, you cannot resist :). And it still seems easier to write to the forum than to perform the simpliest operation by yourself. Hope this thread will be useful for another lazy guy... And that the positive condition of my WAG354G is not a temporary state...
  23. icest0rm

    icest0rm Network Guru Member

    :thumb: :thumb: :clap:
  24. vysocan

    vysocan Network Guru Member

    I would believe that reading is less tiresome than writing. ... At least for me.
    And about signal strength, having similar problems. Which Im blaming for my XP. They arent able to give up control over wifi.
  25. icest0rm

    icest0rm Network Guru Member

    what u mean m8?
  26. vysocan

    vysocan Network Guru Member


    I'm starting with linux, after some pause, and looking for simple solution how to solve problem. Asking people, googling, and the then the solution came with the package. Just read it throught. ... why ... like I didnt do it a dozen times before.
  27. yaboo

    yaboo Network Guru Member

    Well, it may definitely be easier to read than to write, provided there is anything to read... Anyway, it is nice to know that entering the default settings may often be the first at hand, if not the best, solution for a problem.

    Getting back to the signal strength. I wrote before that I have to wireless access points in my place, of which one is a non-Linksys, presicely, an IO-Data device (bought in Bic Camera, Tokyo, Japan but manufactured in China, of course). My Wi-Fi management software reports a stable signal from IO-Data, while the signal strength from Linksys drops and rises.

    The access points are on each floor of the building and they are both visible from every location but it is not possible to work continuously with the further one. Now I am at the 1st floor where the Linksys is located (not more than 1 meter from my notebook) and its signal strength oscilates between 50 and 60 while the throuput is reported as between 48 and 36 Mbps. The IO is a really tiny device adjusted to the Japanese paper walls, but its signal has the strength around 11 and remains stable, although it's quite far from me, on the ground floor. Sometimes, however, the Linksys signal strength drops down below IO which is very strange. I do not have time to research it but the software (of Japanese origin) may be the problem as well as Linksys itself. Anyway, I don't care anymore because I cannot see any significant drop in my connection parameters that would prevent me from working with my internal LAN and with the Internet. I do not use the XP Wi-Fi management interface because it looks as designed in order to annoy the user...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice