WAG354G + PS2 problems

Discussion in 'Other Linksys Equipment' started by calum, Sep 21, 2005.

  1. calum

    calum Network Guru Member

    Has anyone got a WAG354G working with their PS2? I'm using identical router settings to those I used to use on my WRT54G (WEP, SSID not
    broadcast, PS2 in DMZ etc.), but the DNAS authentication phase takes 15-20 mins when run with Sony's network diagnostic prog, and most games have long since timed out by then with the assumption that you have a bad connection.

    It doesn't work with a direct cable link from the PS2 to the router either. Any clues? Everything works fine otherwise. Since it's so new, maybe I'll just have to wait on new firmware...?
  2. play247

    play247 Guest

    ME too thank god


    It is so good to here that someone else has the same problem with their ps2 as I do it is so frustrating, that I cannot play my ps2 at all over the internet. Lets hope Linksys get there asses in gear and get a new firmware out sharpish.

    Later Mike
  3. calum

    calum Network Guru Member

    I read on another forum that somebody had been given a beta version of v1.01.04 to play with, but they weren't able to check if it resolved this particular problem unfortunately :/
  4. calum

    calum Network Guru Member

    Cool, Linksys have just sent me a beta of 1.01.05 to play with... unfortunately I've just packed away my PS2 for moving house, but I might just unpack it again to see if it solves the problem :)
  5. calum

    calum Network Guru Member

    I did, and it doesn't :sad:
  6. Ofloo

    Ofloo Network Guru Member

    why don't you get the latest beta and see what happens.. 1.01.15
  7. calum

    calum Network Guru Member

    That's for the 54g, not the 354g...
  8. Pyrotechnic

    Pyrotechnic Network Guru Member

    Looks like a lot of people are having the same problem.
    And so do I.

    First of all, just a little hint, always ask for a senior technician when you use the Linksys chat support.

    If you take a look at firmware 1.01.03, this will never work with a PS2 , cause the traceroute function does not work. It even looks like the WAG354G blocks al ICMP traffic, why on earth whould they do that? I dont no, is someone does, plz explain.

    So after upgrading to firmware 1.01.05, the traceroute seems to be working. My NAD diagnostics even says , Yeah you're good to go. Well, after trying 3 games I had still the same connection problems (very long DNAS auth).
    So I started to check the traceroute function again. And then a funny thing came up. Everytime I'd made a traceroute to with my Thomson modem or Linksys WAG54G it took 9 hops to reach the IP. But when I use the WAG354G there are 14 hops with response and then 16 with timeout.
    This could be one of the reasons why a ps2 will not be able to go online.

    I've been spending a lot of time chatting with Linksys support and spending a lot of money on phone calls to the Linksys headoffice.
    They even sent me back to the store change the WAG354G for a new one. Not once but four times. (call me stupid, I know)
    In the end they finaly edmitted there is a problem when connecting a PS2. They adviced me to buy an other type of adsl modem from a other brand. This is not the answer I wanted to hear! I've been working with linksys products for over 6 years and I do not want to use some B-grade Thomson modem or else.
    They could also tell me that there have been a lot of complaints regarding this problem. Why could'nt they say so earlyer? Would have saved me a lot of time and money.
    The good thing is, that they're working on a solution, but they don't know when it will be released.

    So it's a swopping thing for me now. Using the WAG354G for my network apps en swopping to the Tomsons when I want to play online.

    Note; sorry for any misspelled words, english is getting a bit rusty.
  9. calum

    calum Network Guru Member

    Hey, thanks for the information and the great analysis. Luckily I too can play swapsies and run a cable from my old ZyXEL modem to the PS2 when I want to play online, but of course that's highly inconvenient (especially now that I've moved from an apartment to a house, and my PS2 is downstairs, and my modem is upstairs...)

    Fingers crossed for an update this side of Christmas :/
  10. JudgeMasters

    JudgeMasters Guest

    Firmware 1.01.05

    Just got an response from Linksys Support to say that the WAG354G running firmware 1.01.05 still won't support tracerouting, I haven't upgraded yet so I don't know.

    Anyone got theirs running 1.01.05 and managed to connect to Central Station or any Sony Game servers (in europe)
  11. dontasciime

    dontasciime Network Guru Member

    What dns are you entering into the tcp/ip of your network card in windows for preferred DNS?
  12. OlegR

    OlegR Network Guru Member

    I have 1.01.05 running on my wag354g (annex B).

    If you give me an address to trace to I will post the result. Mail me directly on orudenko at xs4all.nl

    With 1.01.03 I was not able to do any tracerouting, with 1.01.05 all these problems are solved.

  13. englishpunk

    englishpunk Network Guru Member

    Just thought i'd pitch in with my experience so far.

    Running 1.01.05 and PS2 only works for non-Sony/EA games ( as per usual DNAS problem ), Linksys say it's not a firmware issue and will be sending me out a replacement unit ( i know ... ), however i thought people might be interested to hear that according to Linksys the issue does not occur for 9 out of 10 WAG354G and PS2 users ..... apparently !
  14. calum

    calum Network Guru Member

    Hmm... let us know how you get on with the replacement!
  15. Pyrotechnic

    Pyrotechnic Network Guru Member

    Yes, please keep us updated. :)

    The 9 out of 10 without problems sounds a bit rubbish to me.
    I'd treid 5 different WAG354G units, all with same problem but ok, we'll be waithing for your response.

    I've also just bought a WAG54Gv2, hopefully this one will allow me to play online with playstation.
  16. Easen

    Easen LI Guru Member

    After ready this thread I was disappointed to find that there was no solution for this problem. So i gave Linksys a ring, and I was in the mood to complain, etc, etc. But instead I got a friendly guy explaing what was happening, after and hour of resetting the router, we got it working!!

    The solution, listen closely.....

    Create a Port Range Forward, called it ps2, start port: 1, end port: 65535, and then the ip of the ps2 and enabled it.

    Thats it!

    For some reasons this works but the DMZ doesn't, :eek:. Must be a software fault.

    I hope this helps you all out,

    Kind Regards
    Marc Easen
    (marc at easen.co.uk)
  17. Pyrotechnic

    Pyrotechnic Network Guru Member

    Sorry, already tried it some weeks ago and now I've treid it again on your advice. no succes, still no online play with ps2. :cry:
  18. Easen

    Easen LI Guru Member

    Oh, what game are you trying to play? I was trying to play Fifa 06, and it works fine, but I have done some tests and it's fails to connect using the network access disc. So it maybe just EA games, ...... sorry.

    Kind Regards
    Marc Easen
  19. Pyrotechnic

    Pyrotechnic Network Guru Member

    Yes , that's correct. There are almost no problems when playing EA games like Fifa. But I'm trying to play games like Socom III and MGS Subsitence and they will not connect.

    Bought a WAG54G V2 and that one works fine for me now. Still a shame to kick the wag354 in the bin. Just a waste of money.
  20. Easen

    Easen LI Guru Member

    Does the WAG54G V2 have a built in modem, because if so I might do the same, as at the moment I only have Fifa which is an online game. & I was going to buy some more today.... Why do I have to buy a duff router, I knew it was too good to be true. Oh well.....
    Sh*t happens...

  21. mensa

    mensa Network Guru Member

    So you also can't play EA Games behind a WAG54G v2?

    You can play Fifa 06 online behind a WAG54G v2, but only if you are already registered for an Account at EA Games.
  22. englishpunk

    englishpunk Network Guru Member

    Well guess what, got a replacement back and it's still the same as before, what's worse though is their 2 day turnaround and delivery turned into 2 days before they even acknowledged they had it ( if you ship by tracked courier remember anyone who knows the tracking reference can see when it was delivered ! ), also the replacement was worn and scratched quite badly, so basically i just wasted over a week replacing my brand new router for one that looks like it's been jammed into an exceptionally tight space for several years, nice ! 8O

    Anyway, back to the drawing board i guess ....
  23. tarquel

    tarquel Network Guru Member

    still cant understand how u r having problems getting ur ps2 online with it....oh hang on, if u r on about the WAG54G then the topic starter [or if not, a mod] should change the title as the WAG354G is a completely different product].

    If its a WAG354G, then i've had no problems playing online using the PS2.

    Timesplitters 3 being one of the games.

  24. calum

    calum Network Guru Member

    As you'll see if you read the thread again, the problem is specifically with the WAG354G and games that authenticate via Sony's Central Station servers... most other games do work fine (TS3 presumably among them). Does your WAG354G pass the network diagnostics tests on the Network Access Disc? None of ours do (well, actually they do, but after a 15-20min delay that causes most games to time out), and that's where the problems start...
  25. donroberto

    donroberto LI Guru Member

    WAG354G and PS2

    Has anyone found an answer to this PS2 / WAG354G problem. I too have now tried everything possible?
  26. dontasciime

    dontasciime Network Guru Member

    Have you tried enabling upnp

    You must use dhcp though to get upnp to work on linksys 354g

    set up ps2 to dhcp if it allows it.

    Also tray and lockdown the mac addy of ps2 to the dhcp ip you choose

    set the dhcp to only assign 1 ip or max 2 like the range it will give out, IE - if it allows same number or - if it will not allow the 14-14

    also set primary dns to that of the routers IP ie
  27. donroberto

    donroberto LI Guru Member

    I havent no, but i will give it a try tonight. Does this resolve the DNAS time out issue. I can connect to the central station (although it takes a long long while) When I try and play say fifa or the hardware arena i get a -603 error (server time out) it will authenticate DNAS but by the on playing a game it takes far too long hence the time out from DNAS. Will you suggestion resolve this and have you managed to play your PS2 through a WAG354G?.
    I have so far.....

    -set my ps2 to have a static IP address
    -DMZ on this ip address
    -have tried port forwarding (before setting up DMZ) to every port possible.
    -updated firmware

    The odd thing is it is connecting to the central station but after 10 mins or so......

    I like the router in every other respect, got PDA and main machine working through it fine its just the PS2.
  28. dontasciime

    dontasciime Network Guru Member

    I have never tried to connect ps2 to online gaming, I just came across this post and thought i would comment.

    I use xbox live and that can be tricky with wag354g as well, well actually its easy to set up to use one xbox 360 online but trying to get 2 360 on 2 separate live accounts to connect to live thru linksys 354g is a bit of a problem, that is down to Microsoft's 1 port though, as you can only pass 1 port in this case port 3074 Per internal IP.
  29. englishpunk

    englishpunk Network Guru Member

    Right, an update from me ....

    Linksys you will remember replaced my new router with a refurb which still didn't work, so i RMA'ed that and now have a replacement, obviously a refurb again but hopefully it has more chance of working as they replaced my v1 with a v2, yet to be tested though due to time restraints.

    Also Linksys now refuse to reply to my case relating to this problem, which is different to the RMA's ( thank god ), last update i got after lots of e-mail hassle was to phone them ! I haven't phoned them ever ! Tried it, but was hanging on so long i gave up, so just hope the v2 works, i'll let you know :)
  30. englishpunk

    englishpunk Network Guru Member

    Guess what ....... ?

    No change, V2 doesn't work with Sony DNAS either, so 2 replacements later i am in exactly the same place as before, but with a cosmetic grade b router :(

    Chasing with Linksys to fix it as their support staff are still taking the preverbial, at least reply to my e-mails and acknowledge there is an issue with the WAG354G like Sony now do !
  31. jual_mahal1

    jual_mahal1 Guest

    Try to treat online gaming network as a normal LAN network

    I never have the chance to play online games before with my WAG354G Home Gateway (I've just bought it, though). But, I believe, it's something to do with your PC's TCP/IP configuration.

    I put a blog post on how to merge WLAN and LAN together:


    Maybe, you will have some ideas to start with.
  32. englishpunk

    englishpunk Network Guru Member

    I finally got an update from Linksys ( they're not ignoring me anymore ! ), they suggested trying a firmware they sent me ( 1.01.09 ), i pointed out as they RMA's my V1 with a V2 this was no good, they're thinking about it again ...

    If anyone would like the newer firmware i can upload it when i get home, i'll post a link here :)
  33. englishpunk

    englishpunk Network Guru Member

  34. Advis

    Advis Network Guru Member

    The 1.01.09 firmware only enables ADSL2+ reading from the changelog so unfortunatley it's unlikely to change anything. Try changing the MTU of the router from the automatic setting to 1452.
  35. iMad

    iMad Guest


    I was having trouble getting SOCOM 3 and other Central Station online PS2 games to connect using my WAG354G so I tried this workaround and it worked :smile: here is what I did:

    -Windows PC has direct connection to the internet using a USB DSL modem.
    -PC is wirelessly connected to the WAG354G using a WiFi adapter card.
    -PS2 is directly connected to the WAG354G using standard ethernet cable.
    -On the PC I enable Internet Connection Sharing to share the modem's internet connexion with the WiFi network. The TCP/IP settings of the WiFi adapter card become IP: Mask: (other fields empty).
    -On the PS2 I set the connection settings as follows: IP: Mask Gateway: DNS: (You can also use the automatic setting but you have to disable DHCP in the WAG354G because it will interfere with Windows DHCP service)

    That's all, consider disabling the firewall on your PC the first time you try this.
  36. calum

    calum Network Guru Member

  37. Pyrotechnic

    Pyrotechnic Network Guru Member

    Nope sorry Calum, I can't test it anymore. Got frustrated, trashed the WAG345 and bought meself a WAG200G-EU. No more online problems for me now.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice