WAG354G V1 Annex A Specific config

Discussion in 'Other Linksys Equipment' started by IIIFUADIII, Oct 25, 2007.


    IIIFUADIII LI Guru Member

    Hey guys,

    Ok, here's the deal. I've just switched providers to O2 as they have just released their 'Be' offering.

    Now, the way they authenticate connections is rather unusual. They do it by MAC address. They also don't have a username and password. However, I have worked my way around the username and password problem (I think!). The only issue now is that I need to change my routers MAC address to that of the O2 router. O2 seem to think this is possible and I seem to remember a previous revision of the WAG354G firmware allowed me to at least clone if not manually input it. I believe there used to be a hidden 'wanMAC.asp' page but this in now either not present or inaccessable.

    Is their anything I can do about this AND does anyone know where I can find an archive of previous WAG354G firmwares???

    Thank you for any useful input, it is very much appriciated!
  2. Toxic

    Toxic Administrator Staff Member


    IIIFUADIII LI Guru Member


    I appriciate the speedy response, thanks. I'm currently using revision 1.01.11 but the neptune354 rendition. However, I was on the Linksys release of 1.01.11 prior to this.

    I'll check out this post, thanks. Any further responses to this would be much appriciated.

    IIIFUADIII LI Guru Member

    Well it was worth a try. I wasn't able to find the MAC address within the cfg backup file. Any more suggestions?

    Getting rather annoyed with the Thompson box O2 provided. Ever since I've connected it I've been unable to host games nor connect to games my friends host.

    Keep the suggestions rolling. I'll keep hunting for an answer...there has to be one out there, somewhere!

    Thanks again!
  5. mstombs

    mstombs Network Guru Member

    The WAG354G is a Ti AR7 based board, so the MAC address will be stored in the PSPBoot/ADAM2 bootloader config environment.

    I assume Neptune has Telnet enabled?

    The env variables should be visible with

    cat /proc/ticfg/env

    The WAN MAC may be stored as HWA_3 or wan_mac, or similar - to change use style

    echo HWA_3 mynewmac > /proc/ticfg/env

    also possible to change via the bootloader SETENV command if you have access

    IIIFUADIII LI Guru Member

    Wow, now that's one hell of an answer. However, I have never used telnet before so wouldn't know where to begin. Is their a prefered client for it so I can fiddle around and see what I can achieve?

    The 'echo HWA_3 mynewmac > /proc/ticfg/env' - am I right to assume 'mynewmac' is where I enter the mac I wish to change it to?
  7. mstombs

    mstombs Network Guru Member

    I'm afraid you need to do a bit of googling:- the WAG354G is a Linux computer, Windows has a built in telnet client "start ->run ->telnet" assuming your router IP address is Username usually "root", password the same as the web screen login - usually defaults to "admin". There should be a more specific guide for your firmware somewhere, see also "ssh" and "putty" as alternative ways of connecting, if required...

    You are then logged in to the Linux OS using a "busybox" shell. From there you can use whatever Linux commands have been enabled - warning don't try writing to the flash mtdblocks! "cat" means type the contents of file, "ls" list the directory contents etc. etc!

    See if you can see what variable is currently used to store the MAC before attempting to overwrite, maybe HWA_0, and you may have an "nvram" command...!

    IIIFUADIII LI Guru Member

    This is extremely helpful thank you very much.

    I have also been in touch with Linksys with regard to this. My issue has been esculated so hopefully they will add it to the next firmware release. Only time will tell I guess. If I hear anything I shall post it here for reference.

    Thank you for all your help. If anything else occurs to anyone please post it. Much appriciated.

    IIIFUADIII LI Guru Member


    IIIFUADIII LI Guru Member

    Damn, I can only see the LAN MAC address but not the WAN. Still waiting for a response from Linksys...
  11. mstombs

    mstombs Network Guru Member

    Is there a "nvram show" or "nvram get HWA_3" command available to you. If its not stored in the bootloader environment it must be in nvram... You could also "grep" the sourcecode - may be quicker than...

    IIIFUADIII LI Guru Member

    Ok, I'll give these a go now. Fingers crossed! If I use the nvram command to view the WAN MAC how would I go about changing it?

    IIIFUADIII LI Guru Member

    Right, ok now we're getting somewhere. I didn't find the HWA_3 but I did find a couple of fields that may be of interest.


    Judging by the amount of blank (00:00:00:00:00:00) mac addresses in macclone_addr and 0's in macclone_enable it looks possible to put up to 8 mac addresses in. Do you think these are the fields I'm after and how do I go about putting my desired MAC in?

    I'm positively giddy at the prospect of this being the solution! Thanks for the help!
  14. mstombs

    mstombs Network Guru Member

    Well I have the AG241 source on my PC, and yes those variables are used in a web page called WanMAC.asp

    Yes there does seem to be 8 copies, but it looks like they refer to the 8 possible PVC connections

    with comment in the source code about usage:-

     * Example: 
     * macclone_enable = 0 or 1
     * macclone_addr = hwaddr0:hwaddr1:hwaddr2:hwaddr3:hwaddr4:hwaddr5  
     * macclone_enable = 1
     * macclone_addr = 00:01:02:03:04:05  
     * <% macclone_config("macclone_enable", 1); %> produces "checked" 
     * <% macclone_config("macclone_addr", 1); %> produces "01" 
    I would expect you to be able to use "nvram set var=value" to set the variables and "nvram commit" to save them.

    IIIFUADIII LI Guru Member

    Ok, I tried this to no avail. However, I'm not sure it's not working because of the MAC issue. I have to have a blank username and password too for my connection to work. I have managed to fool it by modding my own HTML page to stop it from making the check via javascript. Though I think there's an underlying script that stops the connection if these fields are blank. I say this because when I go to the status page the 'Connect' button is disabled.

    Do you have any ideas of how to overcome this? I'm rather confident that the MAC issue is solved.

    [more on the MAC issue]
    one this I've forgotten to mention. I found another set of variables:


    The lan one is populated by the LAN MAC address on the back of the router and the other 2 were blank. I populated the WAN one with the MAC address I wanted but it doesn't seem to have made a difference. I thought I mention this just in case it was of interest to anyone.
    [/more on the MAC issue]

    Once more, thanks for all your help.

    IIIFUADIII LI Guru Member

    Ok, you can pretty much completely discard my last post. I managed to get a username and password from my ISP. Entering the details still doesn't work. So, I went beck to telnet and had another good rummage through the nvram variables. I finally came across the one that hold the WAN MAC. It's called wan_def_hwaddr. I tried changing it the way I have come to recognise as the correct way:

    nvram set wan_def_hwaddr=[mac address]
    nvram commit

    Upon rebooting, I checked the variable just to be sure it had actually changed and stuck. Oddly enough, once I had rebooted the router the MAC that I entered was replaced by the old one.

    Can anyone explain why this is happening and if possible offer a suggestion of how I stop it from doing this and actually get my MAC to stick????

    I found the WanMAC.asp page but it wouldn't commit to the changes. Just seems like a dummy page that doesn't actually do anything, unfortunately!

    mstombs, I can't thank you enough for your help. I wouldn't have gotten this far without your help. Thanks!
  17. mstombs

    mstombs Network Guru Member


    IIIFUADIII LI Guru Member

    hhhmmmmm, I've just had a gander at the settings on the router provided by O2. It shows 2 connection types:


    Obviously, I'm using the O2_ADSL2plus. However, it shows the connection type as ETHoA. So, I googled ETHoA and found a few bits. One even refers to Wanadoo Netherlands:

    However, I'm pretty stuck an where to go with this now. I'm not even sure the WAG354G is capable of connecting with O2. If not, what Linksys router is?

    To andswer your questions mstombs:

    Yup, thats the page. Though I rang O2 and they had a username and password ready for me. The connection method is ETHoA which I have no idea how to go about setting up. Either way, I've checked through all the options available and none of the encapsulation methods allow me to clone a mac address.
    The wan_def_addr is equal to the wan mac on the back of the router and the lan_hwaddr was equal to the lan mac address. There's not very much in it. One has AF in the last block and the other AE so it was easy to check really. The wan_def_hwaddr was the only field I could find that was equal to the wan mac address.
  19. mstombs

    mstombs Network Guru Member

    Well it is possible to use another router: example I've helped here


    which is a Linksys modem running 3rd party firmware, in bridge mode to a WRT54GS router.

    seems to be using PPPoE full-bridge mode.

    PPPoE is PPP over Ethernet over ATM, not sure what it is called in your webscreen

    IIIFUADIII LI Guru Member

    Funnily enough this is exactly the same situation I am in. The ISP I've switched to is also O2. So, excellent, thank you VERY much buddy. You have been an immense help!
  21. masterb

    masterb LI Guru Member

    sorry to have read the post only now....
    The new neptune354 will have wan mac cloning web page enabled and working. Tested it and it works only using pppoe, I think because mac address is related to (PPPo)Ethernet protocol and not to (PPPo)ATM.
    I will release it soon, if you need it urgently tell me.

    IIIFUADIII LI Guru Member


    Thanks for responding. If you could let me know when this has been released that would be much appriciated. I don't need it urgently at the moment but it would be interesting to see if it solves my problem. I rekon I could get it to work with PPPoE. I'll give feedback on this thread when I try it out.

    Thank you very much!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice