WAG354G wholeflash

Discussion in 'Other Linksys Equipment' started by squeeish, May 14, 2012.

  1. squeeish

    squeeish Serious Server Member


    Does anyone have the wholeflash for the WAG354G Version 1 Annex A? I've been trying to get my unit up and running again. After reading the whole flash contents it seems the entire chip is empty. I've scoured the Internet for the PSPBoot file or anything like that to enable the router to at least output some serial data but to no avail.
  2. mstombs

    mstombs Network Guru Member

    Can't explain a completely blank flash chip - you should double check your JTAG setup!
    Not sure how close the WAG354G hardware is to WAG200G, which had adam2 bootloader - there are binaries of a pspboot conversion for a WAG200G on routertech.org (someone did try routertech firmware in the past, but had issues with switch drivers), alternatively there are pspboot binaries for various Acorp Ti AR7 routers around.
  3. squeeish

    squeeish Serious Server Member

    Thanks for the reply mstombs.

    I did double check (am using the same setup to JTAG my WRT54G). I'm using TJTAG from here:http://infodepot.wikia.com/wiki/TJTAG I'm able to detect the TI AR7 chip successfully but I had to manually select the flash memory setting: /fc:36 (AMD 29lv320DT 2Mx16 TopB...(4MB))

    I did a -backup:wholeflash and I got the attached file, which I opened in a hex editor and it was totally empty.

    Thanks for the tip on pspboot binaries... I will try to search around and see if I can flash them. I've very little knowledge on routers and compiling and stuff so I'm learning as I go.

    Attached Files:

  4. squeeish

    squeeish Serious Server Member

    Alright I just did a wholeflash of a WAG200G's wholeflash.bin to my WAG354G... but after the flash completed, there was nothing in the flash chip again! The flash memory must be dead... is there any way to resurrect this router now? All of these does not make economical sense but I'm just trying to learn :)
  5. mstombs

    mstombs Network Guru Member

    STOP - that's not a wholeflash backup, not even completely empty, and blank flash chips should come back as '1's! And WAG200G 128kB adam2 bootloader is not friendly!

    There's an extra connection to make for Ti AR7 14-pin J-TAG rather than WRT54G 12-pin (I've seen this in the wag200g guide recently, I needed it for ADSL2MUE), and the flash window address for Ti-AR7 is different than Broadcom chips so hopefully you haven't damaged yours yet! You have to use a custom window with Tornado's tjtag - or you can try a modded old version I have posted over on Routertech forums...
  6. squeeish

    squeeish Serious Server Member

    Ok it sounds like I've been doing everything wrong. Will you be willing to guide me through?

    The JTAG connection config I'm using is this:

    And I'm following the connections for buffered mode (I have the exact same Universal JTAG) from here: http://www.tiaowiki.com/w/Universal_JTAG_User_Manual_(Parallel)

    The output I get when I use tjtag's probeonly is this:

    Do you notice anything out of place?

    I also did a search on routertech forums for posts with regarding the WAG354G by your username but I couldn't find any files. Could you link me to them? Much appreciated! :)
  7. mstombs

    mstombs Network Guru Member

    I do have ones those adaptors, but never used it because the un-bufferred has worked for me so far, you are also using the closed-source paid for tjtag which I haven't yet needed! It appears you don't need the extra connection? My first experience of JTAG is documented here http://www.routertech.org/viewtopic.php?p=15417#p15417, my version of tjtag 3.01 which supported AR7 better than default here http://www.routertech.org/viewtopic.php?f=19&t=3732 (was also posted on dd-wrt forums)

    I'm surprised you have to manually select the flash chip - was going to suggest you force the window, but it does seem right maybe try

    /nodma /window:0x90000000 /start:0x90000000
    This is the thread I remember re someone getting RouterTech to nearly boot on a similar router


    I guess you know about a 3rd party firmware that is intended for use on your router - neptune354 http://cyberstorm.altervista.org/?p=12 with closed forums http://cyberstorm.altervista.org/phpBB3/viewforum.php?f=7

    They do have a guide for failed flashes without resorting to JTAG - assuming the bootloader is intact

  8. squeeish

    squeeish Serious Server Member

    I did use your modified version of tjtag but I was unable to detect any chip, I've no idea why :p

    How do I force the window? I've no idea what parameters to input to the tjtag program. Also, I don't know which file to use. I'm assuming my bootloader is completely gone because I do not get any output from serial when I power on the router (power LED stays red all the time, doesn't even blink).
  9. mstombs

    mstombs Network Guru Member

    Corrected format in post above - with possible command line for you to try with tjtag3.02

    Never tested my mod with the bufferred cable - it might be similar to /wiggler

    Did you get output from serial before problem (i.e. does your cable and 3.3V convertor work!).

    Have you tried a different PSU brick (obviously need same voltage!)
  10. mstombs

    mstombs Network Guru Member

    Not sure it is free can download versions to 2.05 of brjtag, and can see only see a reference to sourcecode for v1.9o
  11. squeeish

    squeeish Serious Server Member

    Hi, sorry for not replying the past few weeks, I've been busy with Diablo 3 ;)

    I was never able to get serial output from this router, but when I hookup my serial data setup to my WRT54G I do get serial output so I assume it's alright.

    I've also tried a different PSU to no avail.

    I will resume trying to repair this WAG354G once I get sick of Diablo 3.

    And yes, thanks for the link to the software! TJTAG was quite expensive for me... wish I discovered it before I bought both win7 and Linux versions.
  12. squeeish

    squeeish Serious Server Member

    Yeap, tried all the bitrates available and exchanged the TX/RX pins too. I've no idea how things became like this, one day it was working fine, the next day when I powered it on it just didn't work anymore.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice