Wag54G - 2 die in the same way on the same day?

Discussion in 'Other Linksys Equipment' started by jmbillings, Nov 3, 2006.

  1. jmbillings

    jmbillings Network Guru Member

    Mine gave up the ghost yesterday, ADSL still seemed OK according to the LED's, but none of the LAN ports would work - just flickered every now and again, and the PC connected would flicker between connected and not connected every couple of seconds.
    Left it off for a few hours, and then when turning it on, it did the normal bootup procedure but after all 4 lan ports flash, everything went out apart from the power LED which went red.

    I put it down to a dead box, but I just noticed someone else on Usenet with exactly the same problem on exactly the same day (02/11/2006).

    Anyone else? Any ideas before I bin it??
  2. zazata

    zazata LI Guru Member

    same here!! on the same date!!!! Thursday 2nd Nov 2006.

    is it actually dead? wireless works. it's just the 4 ethernet ports.
  3. zazata

    zazata LI Guru Member

    I just called Linksys technical support team and guess what? they solved the problem.


    Go to Device Management
    Highlight your network adapter (the one you use for LAN)
    Right click, then go to properties
    then go to the advanced tab
    on the property menu find Speed/Duplex
    change the value to 10 Half Duplex

    it works for me.
  4. MAS3

    MAS3 LI Guru Member

    I wouldn't call that a solution.
    More like a workaround.
    I realy don't know about the WAG54G's, but i hope they are supposed to be 100Mb devices.
    Putting them to 10Mb half duplex would be putting it in "limp mode".
    The device works, but just not the way it's supposed to do.

    To me this would be an acceptable workaround for time being, so to let the peeps @ linksys come up with a permanent solution.
    Ofcourse this could also be a hardware related defect that can be beyond linksys' responsibilities or influence.
  5. jmbillings

    jmbillings Network Guru Member

    Hmm, I use the LAN Port to join it to my wireless access point - which doesn't have options for configuring it's LAN interface.

    Hope the "solution" works for someone else though! I wonder why it would have happened on a certain day though...
  6. Toxic

    Toxic Administrator Staff Member

    can you confirm ALL lan ports are affected. do they all have clients attached to them? just wondering if you have had some trojan affect all your PCs.

    do you have surge protection on all your LAN devices?
  7. nealgs

    nealgs Network Guru Member

    hi all,

    do a search on these forums for this problem - mine (and another one I hav a VPN tunnel to) both died a couple of month back with the same issue. They are v1.2 devices coming upto about 2yrs old each, and all 4 ethernet ports died. Spoke to Tech Support (ha!) who "fixed" it using the above - set your NIC to 10Mb Half-duplex.

    Said that this isn't a fix, it's a 100Mb device and should work at 100Mb - I've RMA'd one of them (3yr warranty) and have been sent a WAG54GS - another piece of linksys crap (doesn't support Lan 2 Lan tunnels which the WAG54G did)

    So I RMA'd the WAG54GS and recieved a AG241 which does support L2L tunnels but which i'm currently having problems with trying to do.

    Logs don't show anything at all - no attempted connections or anything - I getting completey and utterly cheesed of with Linksys crap.

    The AG241 they sent me doesn't support wireless, so i'm awaiting for a WAP54G to arrive also to give me that functionality i'd originally purchased.

  8. jmbillings

    jmbillings Network Guru Member

    I was thinking of a AG241 - apparently needs fw updated to do the tunnels - but to be honest, I'm thinking a change of brand may be a refreshing change!

    To Simon - yeah, all ports affected, nothing on them except the wireless Access point, but I tried my notebook too. Other PC's are on wireless. Shouldn't be any trojans, my av and firewall aren't showing any unusual activity... surge protection - no, and I guess it's possible a spike could have wiped out the LAN ports, but to have not affected anything else seems a bit of a stretch - especially when others are having the same issues...
  9. nealgs

    nealgs Network Guru Member

    Get it RMA'd jmbillings - Linksys are aware of this issue - something to do with a 3.3v capacitor or something that drys out after time (a search in these forums will pick up more info on this)

  10. revs per min

    revs per min LI Guru Member

    This is a copy of info I put on Whirlpool in Australia. Yes the problem is capacitors. Loads of them. The heat is the issue.

    I got hold a WAG54G v1.2 which seems to be very similar (identical??) to the v1 at least in hardware.
    It had the same fault. Ethernet would not work at all. Reduce the ethernet speed to 10mbit it was then ok.
    I replaced several capacitors testing between each one. It was the 3 33uF 16v grouped near the switch chip, C113, 134, 136 that got it going. But I replaced all the physically bulging ones and more of the 33uF 16v in particular, C114, C141, C2
    Most of these measure about 15ohm on the ESR meter. They should be around 2ohm.

    I replaced C5, C24 with 470uf 10v low ESR. C10 doesn't need replacement as it is only a supply filter cap 470uF 35v. The only other one that measured really bad was C36 another 33uF. But it needs a low height one as it sits under the pcmcia card or leave enough leads to bend it over. Others I replaced were not significant to its operation. You could replace the lot but I doubt its worth it or needed. Make sure you have a supply of new caps before you start.

    The major problem is the 16v 33uF caps around the switch chip. In particular the three on the further side from power socket. NONE of the 16uF looks anything but brand new. These are very small caps and they tend not to look bad. Buy about 10 as there are lots to replace. They are standard electrolytic caps but make sure modern small ones. And 105deg rated.

    Even the ones that did bulge it was just slight bend on the tops, 2 x 1000uf 16v were bad and I replaced them. The third is probably also bad but they are paralleled up so replacing it wasn't essential. These are probably "dying gasp" which is so on power loss they maintain power for a second or so. It isn't essential that they are perfect.

    But I would replace the 470uF 16v next to the 2 inductors as these are low ESR for switchmode power. They have slight gold colour. Do buy low esr 105deg replacements (if possible) but only need 10v. One did not have any sign of damage, the other slightly bowed top. Both were equally bad. Very very bad. They should measure .05ohm and both were 7ohm. That means more than 100times their design ESR. This causes overload on the supply which generates more heat. BTW even the switch chip was getting very hot, and after replacing the caps I noticed it was much cooler. The input voltage being wrong causes it to draw more current and get hotter. Which then makes the caps worse.

    BTW for those who haven't done much soldering this is the technique I use. If you have surface mount solder suckers etc. don't bother reading. This is home method.

    The trick to the repair is a map pin. It takes a while to heat through the board and plated through hole. Much longer than single sided board.

    Add a little solder to original leads to speed heat transfer. Slowly rock the original ones out heating each lead in turn and wobbling it. Immediately use your map pin from the component side. Melt the solder and lightly press the map pin as far as it goes. Twist it to prevent solder hardening on it. Doesn't matter if it doesn't go through, as long as you clear the hole so the new component leads get a start.

    Trim the leads of the new one to the same length as the one removed and place it in the holes. Heat the solder again doing each lead in turn and rock replacement back in. Total time is 2-3 hours to replace about 15 capacitors, so don't rush. Although you only need to replace the 2x470uF and 3 33uf 16volt (perhaps all 6 in that area.) You can power it on after each replacement to see if it works if you don't want to do more than necessary. Be patient and inspect each one that you haven't shorted the leads. You need a decent fine iron say 1mm tip but lots of heat so 40W iron or soldering station.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice