WAG54G Ethernet Ports Not Connecting

Discussion in 'Other Linksys Equipment' started by obembsyahoo, Apr 13, 2006.

  1. obembsyahoo

    obembsyahoo Guest

    Hi Guys,
    I have a WAG54G v.1 (I think since it does not specify otherwise at the bottom of the equipment). Its been working fine for about year, all of a sudden all my Ethernet ports are no longer connecting. The PC's and printer are no longer accessible. Nothing has changed physically to warrant this problem.
    My wireless equipments are still connecting to the Internet, any ideas please? I need to print urgently, your help wil be appreciated.
  2. Switcher

    Switcher Guest

    Same problem...

    Hi @all,

    I've the same problem.
    I think it's a problem with the Current supply.
    When I connect a LAN- cable between two Ports (Crosslink), the LED's of the ports are blinking but when I conect a PC or switch, nothing happens. Only the LAN -Connection on the PC shows shortly a connect and then a disconnect.
  3. GSB1

    GSB1 Network Guru Member

    I have the same problem - can anyone help?

    Did you guys get yours working again?

    I can only work via wireless at the moment.

    This is the LAST straw - if I don't solve this quick the Linksys is going in the BIN and I going for a top line Draytec!
  4. StarrFire

    StarrFire LI Guru Member

    Re: Same problem...

    Yep here's another one. I've tried that and the port are blinking, but I don't get a connection with a PC. I've tried all ports and three different cables.
    I also only have wireless connection.
  5. StarrFire

    StarrFire LI Guru Member

    In this topic a tip is given to configure the network card on your PC for 10Mbit.
    I have tested this and all of a sudden I'm connected again.

    Anyone know of a firmware solution to this problem?
  6. StarrFire

    StarrFire LI Guru Member

    I've contacted Linksys support and they will exchange it for the same or a similar device. Since the WAG54G isn't in production anymore, it will be a newer (=better?) model with the same functionality.

  7. ilovedvds

    ilovedvds Network Guru Member

    Yes there are several people with similar issues, they offered me workarounds but i dont see the point if the unit is faulty.

    They have given me an RMA number just waiting for it to be picked up (my unit is nearly 2 yrs old)

    I am not gonna even unpack the new one, gonna sell it on and get something that works.

    I have realised just how bad my router was because now i have switched to my old Voyager 105 modem my connection is alot better - stable and faster.

    Oh well - live and learn.
  8. HungLO

    HungLO Guest

    I got the same problem; however, the 10Mbit trick worked.
  9. Neo_Giles24285

    Neo_Giles24285 LI Guru Member

    i've been working on the 10mb thing for a while but my routers finally gave up on me now so having to rma it :(
  10. leeroyleeroy

    leeroyleeroy Guest


    i have this problem too, its driving me crazy, wireless works fine, in fact never better.

    I have been on with technical support for 2 or 3 days, tried loads of firmware updates all to no avail (partly cause the firmware update never works).

    When i click the link for the tip on the 10MB thing, i cant seem to access that, can someone please provide a working link to that.

    I also understand that i can get the unit sent away using an RMA? Can someone tell me what an RMA is and how i go about getting one?
  11. HiSpeed

    HiSpeed Network Guru Member

  12. timcs

    timcs LI Guru Member

    I have the same problem with 2 Linksys models one is version v1 and the other is v1.2 .

    Both have the same symptons where the lan connection started dropping and after trying alsorts of things found that dropping the speed in XP to 10mbps did it work.

    I am currently in the throughs of commincating with Linksys support so I will keep in touch of what they say. I am not sure if these two are still under warranty though :confused:
  13. timcs

    timcs LI Guru Member

    Just and update on this - even though I bought my WAG54G back in 2004 they are still offerring a swap out as they cannot fix this through the suggestions they have given.

    Not bad eh for equipment that is that old to still cover it.
  14. thedaveyboy

    thedaveyboy Guest

    How to fix Ethernet Ports on Wag54G

    Hello, I like many others on the forum had the same problem, the culprit is a capacitor on the 3.3V power supply to the Ethernet port interface. This cap dries out and allows ripple on the 3.3V rail, this can cause the network connection to become slow, unstable, or stop working completely. It was a 16V 33uF on the units I repaired (I believe C92 - It's back together at this point) located near to the interface chip. Make sure you replace with a 105deg rated cap, and maybe increase the value a little.
    If you need any more details or need the repair doing, email me: dave (at) marell (dot) freeserve (dot) co (dot) uk. I have fixed 2 so far, now working perfectly. :)



    Edit: Hope the photo helps, please make sure you have the equipment and experience to change components on multilayer pcb's, to avoid disappointment , if you are at all unsure, seek professional help.

  15. HiSpeed

    HiSpeed Network Guru Member


    Great, could you put a picture here ?
  16. -BA-

    -BA- Network Guru Member

    This was my reply to someone who had a similar problem to myself on this same issue. Like one of the posters above my WAG54G has since gone to redlightsville and been RMAed. Just received a new WAG54GS from Linksys today. Is it worth even opening the box or should I just ebay it and get something else instead?

    Here is my post from other thread to at least get it working for now:

    "You might like to try this which is only a temporary solution in my opinion but was suggested to me by Linksys support. I had a problem where, out of the blue the router stopped properly responding to the network cards and I was constantly getting disconnection errors in system tray.

    Right click My Computer >>>> Manage >>>> Device Manager >>>> Expand Network Adaptors >>>> Right click on your network adaptor and select properties >>>> Advanced Tab >>>> Look for a property called Media Type or similar.

    You should find that this property is currently set to AutoSense. Basically this version of the router seems to go t**s up with its auto sensing of the duplex speed of the connected network adaptors. Try setting it to something like 10Mbps Half Duplex and you may find that the router picks up the machine again. Do this with all machines connected to the router.

    I say it is a temp measure as I feel that any product where you have to do a "workaround" to get it to work is not working as it was intended and should therefore be RMAed. I have only delayed on this as it means being without my router for the period of time that it is back with Linksys. I have a v1.2 and would prefer it be changed to a v2 but trying to find the right time to RMA it.

    Hope this may be of help for you.


    Once again hope this may be of some use.

    BA :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice