WAG54G Ethernet Ports Not Working

Discussion in 'Other Linksys Equipment' started by JSMACE, Jul 12, 2006.


    JSMACE LI Guru Member

    I have a WAG54G (v1.2) with firmware 1.01.9. Like many others I have had problems with intermittant internet access using the wireless connection, these were solved for me by assigning a static IP address. Whenever I had problems with the wireless connection I could always connect to the WAG54G via ethernet cable. Today I tried to add a Maxtor 300GB Shared Storage device to a ethernet port at the rear of the WAG54G but couldn't access the NAS drive. I figured there must be a software problem preventing me from seeing this on the network(any suggestions?) but as I went through my trouble shooting I found out I could not connect anything to the ethernet ports, no green lights showed up indicating activity. I tried using the command line IPCONFIG /ALL and the message was that the media was disconnected. I proved the NIC was working by using a cross-over cable between my two laptops and transferring files. I then rang Linksys Tech Support and couldn't get an answer I understood from them - they obviously had their trouble shooting check list and would'nt deviate from it. The one interesting thing they did was to get me to plug a normal (not cross-over) ethernet cable into ports 1 and 2 of the WAG54G and tell them what the lights did. the green LED came on steady for a few seconds and then flashed green continuously, but the tech could'nt tell me what this meant. They have issued me with a Return Merchandise Authorisation, which is nice since the WAG54G is 2 years old, but still I don't know what is wrong. I have tried two laptops into the WAG54G and both could not connect.
    Can anyone assist with trouble shooting the ethernet ports? Is there a way to test each port? Has anyone connected a NAS to the WAG54G and are there any tips or tricks or settings I should be aware of?
    In case it matters my main PC is a Dell Inspiron 5150, Wndows XP Pro Service Pack 2.
  2. nealgs

    nealgs Network Guru Member

    Hi JSMace,

    Join the club :( - my WAG54G v1.2 at home has been having exactly the same issues. connections dropping on the ethernet port meaning around 8 devices connection one minute, then dropping the next.

    I've tried different cables, NICs etc, and eventually rang Linksys support, who went through a number of tests, and then we proceeded to reset the device back to default (luckily the firmware version i'm on 1.02.7 supports config backup)

    this appeared to fix it, but i've just come back from holiday and the same thing is happening again, but worse.

    Called Support again, who got my previous call info up and we went through the same procedure as last time, with them at one point configuring my NIC card to 10Mb/Half duplex (which does appear to work) and expecting me to believe that that was the problem - pah!

    Anyways, results is that i'm now getting a replacement WAG54GS from them once i get the RMa info and courier email.

    The wierd thing is, is that the WAG54G v1.2 that we use at our local nursery has also started to do exactly the same thing. I've upgraded the firmware on it to v1.02.7 and saved the config, then reset the device to factory and restored the settings from the config file.

    Still doesn't work. The only way I can get a stable connection is to configure the NIC's to 10Mb/Half Duplex nothing else works properly or is stable enough.


    So it looks like there could be a failure period built it them or something.

  3. Neo_Giles24285

    Neo_Giles24285 LI Guru Member

    the ethernet controller burns out on these models (WAG54G V1.2) after so long and the ports can only be used under 10mbps full. as your NAS will not be able to have the ports set to 10mbps sadly there's nothing you can do but rma your router.

    i will also have to do this at some point but its finding the time to send it off for a replacement.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice