WAG54G Internet connection pauses

Discussion in 'Other Linksys Equipment' started by Pagemakers, Nov 25, 2004.

  1. Pagemakers

    Pagemakers Network Guru Member

    Every hour or so my internet connection pauses for about a minute or two and none of the PC's connected to the router can download web pages. They are "unavailable".

    The ADSL light on the front of the device is still illuminated and the status page on the router shows "connected".

    Without my intervention the internet connection starts to work again.

    When the connection pauses I look in the router firewall log and I see: "Ceiling for number of connections reached, dropping packet".

    I have scanned all PC's for viruses and spyware and everything is clean..

    Linksys support have been useless to say the least!

    I have even purchased a new WAG54G today and that does the same thing.

    I have upgraded the software to 1.02.7

    As a test I turned off the router's firewall this morning and it has worked perfectly ever since. But obviously I would prefer the firewall on even though I am using XP SR2 with the Window's firewall turned on.

    Connected to the router I have 3xPC's wired, a wireless laptop and 2 wireless music players.

    What could be up? I'm baffled.
  2. mdrandall

    mdrandall Network Guru Member

    At last, I thought I was the only one. I have exactly the same problem although you have progressed further. I have not yet looked at the log file nor disabled the firewall as I have been suspicious of my ISP (Pipex).

    I have tried all the versions of firmware with no success. However, this router used to work great when I bought it last year (used at a different house). At that time it had firmware 1.01.16 so my next move is to restore the firmware back to that and try again.

    I'll let you know
  3. lordt

    lordt Guest

    Same problem!

    I hanve exactly the same problem!
    It seems to be not very common... but we have!
    Any suggestions?

    Under my wag54g there are a PC and a Laptop... for the first month I use the linksys firewall...in otder to change something I decided to set a fixed IP for the PC and to put it in the DMZ... the problem persists!

    My wag has in this moment the problem... here it is my firewal log (2pages of the same messages):
    Possible Port Scan or Flooding(TCP) Attack, Ceiling for number of connections reached,
    2004-12-02 06:33:43 135/TCP from xxx.xxx.xxx.xxx to xxx.xxx.xxx.xxx Possible Port Scan or Flooding(TCP) Attack.
  4. Pagemakers

    Pagemakers Network Guru Member

    I have spoken to tech support a dozen times and thay have been totally useless.

    Now I use my WAG45G with the firewall off and the Windows firewall on. It works fine, but not ideal!
  5. Pagemakers

    Pagemakers Network Guru Member

    Well I have hard-reset my router and turned the firewall back on. I'll let you know if the pausing continues.
  6. clarkey

    clarkey Network Guru Member

    i have this same problem with my wag54g apart from i have to turn the router off and on to get it to work on the net again.

    im getting a replacement from the shop i bought it from on saturday
    i hope this works
  7. Pagemakers

    Pagemakers Network Guru Member

    It not a faulty router. I bought a new one and I have found it to be a bug in the firewall. Turn it off and it works fine.
  8. clarkey

    clarkey Network Guru Member

    but wont that be a ploblem

    i have norton net security and sp2

    will turning the firewall off be ok?
  9. Pagemakers

    Pagemakers Network Guru Member

    Well I just use the Norton and windows firewall and all has been well for the past weeks.
  10. clarkey

    clarkey Network Guru Member

    ive turned off the routers firewall and net not stoped once yet :D

    so hopefully this would have fixed it

    thanks for your help
  11. steverae

    steverae Guest

    I too have the exact same problem.. thought it was to do with my new laptop being 54g and my old laptop being 11g so i dropped the connection speed down but it didn't help.

    I found that the network stays alive but the connection to the internet drops so i simply remotely connect to the pc linked to the wag via the cable and log into the router then disconnect and reconnect the internet connection via the status page and this then works..... for a while again

    i'll check my logs and see if i get the same messages as you guys and also disable the firewall and see what happens, i'm running firmware 1.02.07 btw.

  12. ozzyntex

    ozzyntex Guest


    Not posted here before, just wanted to say I have been having this problem for ages now but it seems that clearing the log of the error reports cures the problem - perhaps the log gets full and this has the effect of stopping any new connections, existing connections (irc, msn, vpn etc) continue to work its only new connections (which happen constantly while web browsing) that cause problems

  13. I have also been having this problem for the last few months. Initially my router worked fine then in just started disconnecting. I swapped routers with a friend to check whether it was my isp. I had no problems using their draytek, but they also had no problems with the wag54g. I got my router back today and about half an hour after coming online i lose the connection!!!! Is anyone else using bt because we thought the details you put into the router might be incorrect. I have now turned the firewall off to see if that helps thanks!!!
  14. DKNY2000

    DKNY2000 Network Guru Member

    I hanve exactly the same problem!
    It seems to be not very common... but we have!
    Any suggestions?
  15. linksysonline

    linksysonline Network Guru Member

    Did you try shutting off the firewall?
  16. Toxic

    Toxic Administrator Staff Member

    try keeping your firewall enabled in the WAG54G but disable Block WAN requests. see if that helps.
  17. DIqbal

    DIqbal Network Guru Member

    Guyz...! I also have the same problem and its driving me crazy... :( Does it has to do anything with Kazaa? or any other P2P software?
  18. Millsy

    Millsy Network Guru Member

    I have exactly the same problem. However I found that just logging into the router and then logging out allows internet access again. I do this via wireless on what ever machine I'm using at the time. :?
  19. DIqbal

    DIqbal Network Guru Member

    Seems like many of us are having the same problem... can we do something to resolve this problem? I guess we need to sort it out.... but how...? this is the question...
  20. hijglander

    hijglander Network Guru Member

    I've had this problem with my old Zyxel modem.... Only not every hour, but just randomly. Anyway that's what I thought.

    Aparently my disconnecting from the internet was at the same time my phone rang. After re-arranging the ADSL-splitter (don't know if you guys have one, or even call it the same. But is is used for "splitting" the phone and the ADSL signal) like it should have been the internet connection never dropped again.

    I'm sure most of you have checked your splitter but it doesn't hurt to check it again, right?

    Hope this helps...


  21. vmaxdragon

    vmaxdragon Network Guru Member

    I'm have the same problem.
    Linksys have said on the resellerhotline the hardwareversion 1.2 have a bug. After an another call to the customerhotline Linksys replace the WAG, but not to the hardwareversion 2.0 as the resellerhotline told.

    If so many users have the same problem, why is there no help from Linksys.
    I think after this experiences Linksys isn't a good choice. Problems could be at all hardware. But the service must be ok.
  22. boyimace

    boyimace Guest

    Same problem loosing internet connection randomly

    Guys had the exact same problem, i was checking my connection from wall to router and then hunting for spyware basically anything that could be causing the dropped internet connection (but still connected - as per my wag4g)

    Have just turned off the firewall and turned on xpsp2 firewall and hope this stops this stupid problem, cheers for the info people.
  23. pricer

    pricer Network Guru Member

    WAG54G User:

    ok, i've only had dropout issues since BT upgraded the line to 2MB - have upgraded firmware, done the full reset configuration and turned off firewall (and many other things too), but it just won't remain stable. I've redone the procedure again, someone on another forum says it took a few days to settle down, which is what i'm going to give it (forgot to unplug all the connections first time round), but this is a horrible experience!!! It's the same for everyone on the router too:

    2xPC via LAN
    1xPC via Wireless
    1xMac via Wireless
  24. DIqbal

    DIqbal Network Guru Member

    Well if you guys are using Kazaa or any other filesharing then try removing it for two three days and then check the connection. Hopefully it will resolve the problem... Since i remove the kazaa in one of my machine Thanks God i don't have the connection dropping problems any more.....

    Good Luck :)

    P.S. Let us know if anyone tried and it solved the problem?
  25. Wicked1983

    Wicked1983 Network Guru Member

    Hi, I've a similar problem like this but I can't understand if it's the same!many times happen that Internet connection seems go down for about one minute (wireless activity don't go down) but seems that there is a few timeout with server. I see that messenger auto-disconnect and reconnect, skype do the same. on emule i see the Upload and Download speed going down to "0" and after few seconds they go up to normal values. Web pages are "unavailable". The router/gateway don't have any kind of error. the led are all green, the log don't give me any error and firewall log give this error: "Invalid TCP packet received, dropping packet" that is normal (or I believe it is!)I want to try to use your suggestions like turn off the firewall (but i prefer to keep it on) or to turn off onli the WAN request. if anyone have the same problem please contact me, we could try to solve problem together.

    The same problem (the internet connection go down) I've noticed that happened when one other wireless device connect with router/gateway. for example, my desktop is connect to the WAG and there are sonme download or transfer by P2P program. when I turn on my Laptop to use web or internet just after the wifi connection with WAG is complete the internet connection (both on Desktop and Laptop) is down for a few seconds (or one minute) and so all go up ...
    anyone have any idea?
    i use 1.02.9 ANNEX A firmware...
    i'll try to disunable the Block WAN Request in firewall section.
    if anyone have some other ideas please contact me!
    sorry for my english!
    Bye bye!
  26. DevilWAH

    DevilWAH Network Guru Member

    ok i found running bittorrent p2p causes big problems with the router.

    dropping the MTU on all 3 of my computers really helped. as did quitting the fire wall.

    now with the beta firm ware i have the fire wall back up. and no more hanging
  27. ripcurl

    ripcurl Network Guru Member

    me too

    I also have the same problem

    My device keeps connecting and reconnecting to our network
  28. booly

    booly Network Guru Member

    I also have the same problem since my line was changed form 512K to max bandwith.

    Since there, I frequently have internet connection problems :
    * DSL connection reset
    * DSL connection pause
    * No DNS (impossible to get web page, but emule is still OK)
    * WAG refuse to connect
    * connection speed is not stable 1500 to 2400K, depending of days
  29. Xander

    Xander Network Guru Member

    sorry about reviving an old topic like this but i found this topic on google and just wanted to know if any of the above posters did in the end find out the problem. i can also honestly say that the linksys team could not help me in one slight bit.

    ive cleared the firewalls logs as some one suggested to see if this works. i dont like turning off the firewall or do any other major changes like port forwarding becuase this for some reason reboots my connecingtion and as my connection is PPPoe then i will be assigned a new ip, not something i wish to have.

    i noticed a couple of you said you would turn on the SP2 Xp firewall. i would also recomend a 3rd party firewall for more security becuase the SP2 firewall is a bit dodgy i think 0_o

    zone alarm is a very good free firewall.
  30. gregorian

    gregorian Network Guru Member

    i am having the same problem with WRT54G. .

    last week the internet cutoff thingy happened maybe once every 12hours. i merely had to cold reboot for the router and everything went back to normal. then the frequency of this problem increased to 3 times a day.

    this evening it occured twice. i got sick of it and prompty flashed to ddwrt (from original linksys). hope i dont get this nonsense anymore. firewall btw does nothing for me. i turned it off the moment i could access the

    and i still have the problem. everytime it occurs, i do a ping for the router (the above IP) and i get a string of 1ms followed by timeouts every 10 seconds. the timeouts (>4096ms) are the causes of the browsers not loading the page. otherwise there is still a semblance of connectivity so i can reboot the router through HTTP.

    and the problem remains unsolved. btw tech support sucks. they never seem to know what is happening. this applies to many hardware companies.
  31. MikeWUK

    MikeWUK Guest

    WAG54G, v1.2, ADSL. Got sent new firmware, still got exactly the same problem. It happens occasionally. Everything Internet is 'gone'. althouh I've still got the conencted light, and IP addresses on all my machines. I have to power-cycle the WAG54G.

    when it works, it works fine, it's not the MTU, it's not hte ISP, and everything else configured is vanilla.

    If I find I have to turn the firewall off to fix this, then I'm going toask Linksys directly for a different box and money back. Otherwise Trading Standards are going to ge this - it's no fit for purpose.
  32. booly

    booly Network Guru Member

    I still have the same problem with a V1 WAG.
    I give up trying to get any help form linksys support.
  33. bardie

    bardie Guest

    After reading some great magazine reviews about this product, I advised the company I work for to purchase a WAG54G Wireless Router Modem in November (Firmware Version 1.01.6) and have been having problems with it on and off since then. The problem is that every day it disconnects from the web/email/im - usually in the afternoon or after a few hours use, BUT I can still listen to the radio using RealPlayer ( rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/live/r1_dsat_g2.ra ) - so it isn't the BT broadband connection. Wireless and wired LAN still works fine.

    I updated the firmware (from the Linksys website) using WAG54GV2-EU_AnnexA_ETSI_v1.00.19_001_code.bin -- this made me loose my Admin screens but I rarely lost the web/email/im but I would loose the RealPlayer Radio connection after a few hours. So that was ok until I needed to change the passwords and needed the Admin pages.

    I recently did a full reset - back to the factory settings because I needed to access the Admin screen for general maintenance. So back to the web/email/im loosing connection every afternoon!

    After my (clueless) manager getting on at me to "sort out the f*****g internet", I found this forum. There is a lot of people hacked off with Linksys over this connection issue and I still haven't had a reply to the email I sent to them about this problem.

    I have checked the Linksys website again for the latest firmware and that webpage is not working (surprise surprise!!!). Although since then I have found info & links to their FTP site on this forum.

    I found a link for a beta version http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=5835&highlight=wag54g+firmware Reportedly one or two problems. But I'm gonna try it and hopefully it will sort out my connection issues.
  34. Ofloo

    Ofloo Network Guru Member

    i have the same problem with v2 when are they gone fix this i don't see turning off the firewall as an option, it should work end of story this bug is also in beta firmware, ..

    the internet times out for a minute then it comes back on.. first i thought it to be my isp .. but .. it wasn't

    bought this darn router cause my fucking dlink router realy sucked and thought of doing a good investment with buying a linksys apparently dlink isn't the only company with crappy firmware, well at least it is an improvement if you compare it to dlink.. but still
  35. wislam

    wislam Guest


    Read this for a possible fix to this problem: -


    He basically suggests turning off the UPnP feature.

    I no longer have the 'Ceiling for number of connections reached, dropping packet' problem. I realised that the router doesn't require a reboot when it starts dropping packets, but rather simply requires you to login to the web interface which also fixes it, temporarily.

    Thus, not only have I disabled support for UPnP but also left a browser window open on the 'Status' page of the router, which refreshes itself after 1 minute.

    This has solved the problem.

    Waheed Islam
  36. 7ttman

    7ttman Network Guru Member

    your intermitent problems - the answer

    OK guys..... that's exactly the symptoms I had.

    Looked everywhere.... blamed everything except the wiring.

    Now I'm almost 99% certain that all your problems are a result of the telephone cabling within your house.

    Like some, I was working fine at 512mb then BT upgraded me and I also switched ISP's.

    1mb and 2mb require a much better quality line. It's all to do with the signal to noise ratio (SNR) which you could measure if you have a separate modem.

    So to fix your problems....

    1. go directly to the MASTER BT socket in your house.
    2. disconnect everything
    3. plug the ADSL filter directly into the internal socket in the master
    4. run just your internet connection
    5. verify that you have a continuous and uninterrupted service
    6. one by one connect "things", so that you can check uninterrupted service, because, the "thing" you connect last will be the "thing" which is causing the degraduation of signal quality. It could be a phone, it could be an extensiuon line/socket, it could be a poor ADSL FILTER.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice