WAG54G - new computers joining the network kick others off

Discussion in 'Other Linksys Equipment' started by erpman, Nov 2, 2005.

  1. erpman

    erpman Network Guru Member

    hi all,

    i'm having a problem (one of many, actually...) with my WAG54G Wireless ADSL router (running firmware 1.02.5, in the uk).

    my problem is that when a new computer joins the network it causes all other computers currently connected to disconnect.

    there are currently three devices that connect to the network - my mac, my housemate's windows pc, and an xbox. all connect wirelessly, and all cause the above problem upon joining the network (ie. when they boot up).

    i use WEP encryption and MAC filtering (permit specified) as security.

    does anyone know what causes this problem? and more importantly, does anyone know how to fix it? have i simply got some configuration wrong, or is it more serious than that?

    thanks in advance for any help,

  2. Petertje

    Petertje Network Guru Member

    Did you setup DHCP or do you use static IP addresses?
  3. erpman

    erpman Network Guru Member

    i'm using DHCP. well, the router definitely has DHCP enabled, and my mac is definitely using it, but i can't be sure about the pc or the xbox so i'll check those tonight -- could this be the problem?

    thanks for replying,

  4. Petertje

    Petertje Network Guru Member

    Not sure about that, but I think I saw a similar problem when switching from DHCP to fixed addresses.
  5. erpman

    erpman Network Guru Member

    sorry for the delayed reply. finally got round to checking this last night and, yes, both the pc and the mac do use DHCP. (i'll leave the xbox out of the equation for now as it's not used very often anyway).
  6. HiSpeed

    HiSpeed Network Guru Member


    With 1.02.5 the DHCP server doesn't work correctly !
    It must be disabled...

    If you need DHCP serveur, you have to use 1.02.9 at least !
  7. erpman

    erpman Network Guru Member

    oh really? that's unfortunate because i tried both 1.02.7 and 1.02.9 and with both of those i couldn't even connect to the router wirelessly! (the ethernet connection worked, but not the wireless).

    incidentally, is there a firmware higher than 1.02.9 that i could try? because that was the newest i could find when i looked a few weeks ago.

    maybe i should just disable DHCP, but the thing is my housemate is on holiday and i don't particularly want to risk messing his PC up whilst he's away...
  8. HiSpeed

    HiSpeed Network Guru Member

    See what I wrote here !
  9. erpman

    erpman Network Guru Member

    thanks, that is quite useful, however it doesn't really help with the problem that i can't get a wireless connection at all using either 1.02.7 or 1.02.9. do you have any idea why this might be? could the "good parameters" you speak of possibly fix the problem? and what are these so-called good parameters?

    thanks for helping,

  10. HiSpeed

    HiSpeed Network Guru Member

    On my Wag 1.2 with 1.02.7 :
    I don't use DHCP server, all the addresses are statics.
    I don't use Single Port Forwarding only Port Range
    I disabled UPnP
    I don't use Mixed wireless, only 802.11g
    The wireless parameters are :
    Beacon Interval : 50
    Fragmentation Threshold : 2304
    RTS Threshold : 2304
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice