WAG54G - Upgrade and WiFi problems

Discussion in 'Other Linksys Equipment' started by bencope, Dec 27, 2004.

  1. bencope

    bencope Network Guru Member

    Hi there. This is my first post.

    I live in the UK and am running a WAG54G, which is connected via a cable to my desktop PC. This works (worked) fine.

    I also have a laptop with WiFi capability. I could not get the laptop to connect to the internet. However, it did connect to my wireless network (at 48Mbps) but when I went to get a web page, it came up with page cannot be displayed. I could not even connect to (the Linksys admin page).

    I read this forum and thought that firmware might be an issue. So I just downloaded the latest version Annex A.

    I logged into my admin page and tried to upgrade. It got through half of the upgrade process, when it bombed out. Leaving me with a blank page.

    The internet seems to be working ok, although maybe a little slower than before. However, I can't login to it won't even load the page, let alone let me login...

    All I want to be able to do is sort out the WAG54G so it's running fine and capable of letting my laptop connect over WiFi.

    Can you please help me out / walk me through what I have to do to get it sorted?

  2. bencope

    bencope Network Guru Member

    Any ideas?
    Am I making sense?
    Do I need to add any extra info?

    Can anyone tell me why my WAG54G crashes during a firmware upgrade, am I doing it right?
  3. komUnec8

    komUnec8 Network Guru Member

    It sounds to me like an addressing problem, but lets eliminate a few possibilities first.

    Presumablyyou did the upgrade (was that to v1.02.7?) from a PC that was hard-wired to the WAG54G (recommended)? Did you do a hard reset before and after (very much recopmmended)?

    Since you have Annex A, I presume you have an ADSL WAN connection?

    Is the IP address of your PC assigned by DHCP from the WAG54G? Or have you got it static and it's maybe not on the same network after the reload as it was before?

    With regard to your initial problem with your wireless connected PC, it's hard to tell without more details, but you could check that the PC has managed to get a 192.168.1.x address. (It may not be getting one from the WAG's DHCP server function. If not, try reconnecting, or try 'repairing' the connection under Win XP. If this still fails, try setting a static IP, then ping the WAG (make sure Block Anonymous Internet Requests is NOT ticked on the Security/Firewall page).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice