WAG54G V2: can't upload to any FTP

Discussion in 'Other Linksys Equipment' started by Rancio, Mar 7, 2005.

  1. Rancio

    Rancio Network Guru Member

    Hi all,
    It seems that my WAG54G V2 firm 1.00.19 can't upload anything to any FTP server. I just plug my good old Zyxel 643 and everything is OK.
    Is someone having the same problem? Could you try to upload something to an FTP?
  2. hijglander

    hijglander Network Guru Member

    Give us a hint pls.... Which program do you use to upload to an ftp site?

    And check the standard ftp ports.... the WAG54G is using NAT and therefor might not forward the ports 20 and 21.
    The Zyxel, I presume, is used in bridge mode and has only one RJ-45 port? If so it is probably not using NAT and will pass any port to your PC.

    How to enable ports in your WAG54G can be found in the manual.


  3. Rancio

    Rancio Network Guru Member

    I use CuteFTp, DOS command line... it doesn't matter. Don't work.
    Is not a port problem either. I'm a client, not a server, I don't need port forwarding...
    Did you try to upload something? Maybe my unit has a problem...
  4. hijglander

    hijglander Network Guru Member

    My internet connection should be up some time today, I'll try to upload and will post my findings.

    By the way, I too own a WAG54G v2.
  5. hijglander

    hijglander Network Guru Member

    Unfortunatly no internet connection yet.....
    As soon as it starts working, I'll test the upload to an ftp-server.
  6. Rancio

    Rancio Network Guru Member

    Thanks. BTW, i have returned it to the shop. I will buy a Zyxel 660HW...
  7. hijglander

    hijglander Network Guru Member

    Goodluck with your new Zyxell....

    I managed to test the ftp upload with my WAG54G v2...
    It actually did the job without any trouble. I didn't change any of the standard ports.

    I connected to : ftp://ftp.demon.nl using the commandline ftp program.


  8. Rancio

    Rancio Network Guru Member

    Thanks hijglander!
    I supose my Linksys had a problem, maybe I just had to get another unit...

    (No Zyxel. I will try a Belkin, spanish stores have limited choices.)
  9. Rancio

    Rancio Network Guru Member

    Hi again, tried another WAG54G V2 aand I have the same problem... WTF!!

    Wait a moment! ms-dos FTp works!? Why not CuteFTP?

    Edit 2:
    Is the combination of FTP + Outpost Firewall that doesn't work.
    Someone is using another software firewall?

    No... seems its random. Now Works/ Now doesn't...

    Definitely is the combination of FTP + Outpost Firewall that doesn't work. With outpost unistalled everything goes. It's a shame, because Outpost is a good firewall...
  10. CaltorStorm

    CaltorStorm LI Guru Member

    WAG54Gv2 = Dodgy Model

    I realise this is an old topic but just wanted to give some feedback here.

    I too had the FTP upload problem with my WAG54G v2 so I upgraded the firmware to 1.02.00. However this caused my ps2 (Playstation 2) to stop working online which it did before. I then tried various other firmware versions none of which would allow my playstation to work online. I therefore contacted Linksys via Livechat on their website and after explaining the full situation to the engineer they have agreed to replace the router. I think that the WAG54G v2 is fatally flawed. Not sure if it is the hardware or the firmware but I don't think it is possible to get everything working on that model. :wall: As that model is now end of life the replacement router will hopefully be a more stable model that actually has a firmware that works.
  11. Bartjuh

    Bartjuh LI Guru Member

    It's not only the WAG54G that has this problem. Also my RVS4000 has the same problem, and it's driving me totally crazy!
  12. CaltorStorm

    CaltorStorm LI Guru Member

    If it's still in warranty just keep sending it back. When my replacement came back and it was faulty too (albeit a different fault) they eventually sent me a WAG200G. Superb router. Great reviews and rock solid. No FTP problems and even my PS2 works.
  13. SKyo

    SKyo LI Guru Member

    I also have problems with WAG354G wireless ADSL router. I cant connect via FTP and Im sure Im not redirecting any FTP port. Also, I cannot access through HTTPS, so I cannot connect to MSN or GMail. Any solution?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice