WAG54G V2 damaged firmware

Discussion in 'Other Linksys Equipment' started by pokettuk, Jan 8, 2006.

  1. pokettuk

    pokettuk Network Guru Member

    Hello everybody,

    This is my question:

    when I switch on my WAG54G V2, First the power led is burning red for one second and after this it starts blinking green and stay's blinking greed (it looks like the firmware is damaged after a firmware update). The WAG54G is not reachable, also ping brings nothing.
    is there a possibility to repair this, I already tried the reset button (hold it for 10 seconds, hold it for 30 seconds), but it's not going back to the default settings.
  2. booly

    booly Network Guru Member

    What didi you do to get into this situation ?
    Bad upgrading ??

    did you try tftp ?
  3. pokettuk

    pokettuk Network Guru Member

    Hello booly,

    Thanks for you replay.

    Yes, problems starting after an upgrade of the firmware, why: I don't know. as far as I know nothing went wrong during upgrading.

    Yes, without any result (I have tftp version 1.255).

    What I don't understand is: when I read the troubleshooting part of the manual, it says about de green blinking power led you shoult go back to default settings by pressing the resetbutton for more than 10 seconds, but in my situation, it brings nothing.
  4. Stux

    Stux Guest

    I have experienced exactly the same problem with a new WAG54Gv2.

    Basically i logged into it, changed its IP to After that I couldn't log into it, so I powered it down, powered up... boots up with a flashing green led...

    manual says to firmware update it, but you can't login, or ping it. Tried a reset... no difference.

    So eventually I followed these instructions to do a TFTP.exe firmware update. http://minitutorials.com/forums/index.php?showtopic=184&st=0&#entry3970

    The trick is, I found that the box would ping/tftp only for a few seconds after booting up, so to upgrade it I basically turn it off, on, then hit "Upgrade" sometimes it works.

    Now, after it does work, I have a different problem, namely the box now powers up with a red light, blinks green for a while and goes red again.

    The good thing is it can ping and tftp upgrade while red, but not connect to the webserver.

    I think this maybe a lemon...

    next step is to call linksys
  5. pokettuk

    pokettuk Network Guru Member

    Lo Stux,

    Thanks for your replay :thumb:
    Sorry for my late responce, I'm verry often out of the country.
    I will give it a try. I always say, When your not shoot you always miss :D

    I know, but that's my last option. The helpdesk in the netherlands is very bad (almost not reachable)
  6. pokettuk

    pokettuk Network Guru Member

    Lo Stux,

    Wouw it works :cheering: :cheering: :cheering:

    Just one tip, after you upgraded the firmware, push the resetbutton for more than 30 seconds, to go back to factorysettings. Than it works.

    Thank :thumbup: :cheer: :drinking: :rofl:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice