WAG54G v2 firmware upgrade problem?

Discussion in 'Other Linksys Equipment' started by Wingedwraith, Sep 13, 2005.

  1. Wingedwraith

    Wingedwraith Network Guru Member


    My father just bought one of these units as a replacement for a faulty Belkin and apart from a few minor connection issues with 1.00.19 eventually got it working on PPPoA. They suggested upgrading to the latest beta firmware 1.01.15 which I tried to talk him through over the phone, problem is each time he tried it the progress bar would get to about 75% then go back to the start, it tries about three times and eventually comes up with 'Firmware Upgrade Failed' message. :( We tried a different download of the firmware to ensure it wasn't corrupted but each time there were no extraction CRC problems so one assumes that was ok.

    We then tried it with 1.01.05 and although it reported it as failed again it actually worked and it seems to be running fine.

    My question is what are the main differences between x.05 and x.15 and has anyone experienced this upgrade problem? I have switched on remote upgrade as was going to try putting .15 on again from here however I won't if it potentially 'doorstops' his router as he is about 14000 miles from me at the moment.

    Any help would be appreciated.

  2. Ofloo

    Ofloo Network Guru Member

    i had the same thing but after retrying again it was solved .. try resetting your router and try again
  3. rewt_gr

    rewt_gr Network Guru Member

    I think that u always have to reset the router to factory defaults before flashing.And not save the config and load it again after the flash.It don't work properly sometimes.
  4. HiSpeed

    HiSpeed Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice