WAG54G + xbox 360 = hangs router

Discussion in 'Other Linksys Equipment' started by JJ80, Dec 29, 2005.

  1. JJ80

    JJ80 Network Guru Member

    I guess somebody had to ask this.

    Ok after a year of trouble free WAG54G (well after the initial hell that was configuring it) it now hangs without a clear reason since the first day I got the 360.

    Wireless loses connection and lan ports cant access the internet. Only way to get the DSL running again is to power off the router and back on.

    This might happen once a day or once every two days.

    Also the 360 gets disconnected from xbox live while downloading demos. I might have to reconnet several times during a 500MB demo download.

    I have 64bit wap if im not mistaken, firewall off (on makes no difference) and the firmware is annex a 1.02.7_03 or filename WAG54G_AnnexA_ETSI_v1.02.7_03_code.bin

    Any ideas?

    And I'd like to know how to disable NAT so that my computer and the xbox gets a REAL IP from the ISP DHCP instead of the NATted ones the linksys hands out. If I disable NAT from the menus all connectsions drop and cant fetch the real wan IP from the ISP.

    And I noticed an Xbox part in the special rules section that I do not remember adding.

    If I cant get this to work now I'll go for a Buffalo router as those have been stellar at work so far. 8months without a single need to reset them.

  2. booly

    booly Network Guru Member

    Put the WAG in bridge mode, or use the DHCP relay
  3. JJ80

    JJ80 Network Guru Member


    "Bridged mode only" got rid of the NAT and I think reduced my ping on the PC from 21 to 10ms (like ping myispdomain.com).

    360 got through a 600MB demo download in one go for the first time ever and I had BF2 idling (periodically moving the guy) on a 32player server on the PC and all seems to go fine.

    Here's hoping it doesnt crash again. If it doesnt for about four days it should be fine.
  4. JJ80

    JJ80 Network Guru Member

    Almost a week now without a crash. I wont say it yet but bridged mode only might have solved it.
  5. JJ80

    JJ80 Network Guru Member

    Ok been working fine in bridge mode since then but now a new issue:

    Tried to configure the wireless MAC table to accept a fujitsu siemens laptop with an Intel b wlan inbuilt adapter and the adapter couldnt even see the ssid broadcast name! Saw a bunch (3) of other SSIDs from the neighbors and a hotel nearby, but not the linksys 1m away.. :rofl:

    I checked the MAC address four or five times and made sure the ipconfig /all entry I was looking at was the wireless adapter and not the others.

    Then we plugged in a nokia 211D pcmcia GRPS/GSM/WLAN b adapter and it saw the ssid but could only connect if the router was set from Mixed mode to 802.11b only. So now I lost the 54mbit option but at least the devices can still connect.

    What a horrible POS this router is, cannot operate in mixed mode, cannot negotiate with a quality Intel wireless adapter (that works fine with a buffalo router) etc. :thumbdown:

    It has come very close to being thrown to the trash several times now, but through my patience I've managed to get it working, just barely.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice