WAG54GS Firmware Query

Discussion in 'Linksys Official Firmware' started by macman81, Dec 18, 2006.

  1. macman81

    macman81 Guest

    I'm running a WAG54GS ADSL Wireless Gateway with firmware version .06. A newer version is available (version .12) on the Linksys site.
    I've never done a firmware upgrade before. If I do so, will I lose all the router settings and have to restart again from the factory defaults?
  2. deejeedave

    deejeedave LI Guru Member

    i tried the firmware but didn't work, upgrade failed although i have the right product !
  3. hellraid

    hellraid LI Guru Member

    I did the upgrade from version 06 to 12 without any problems. Even all my settings remained in the modem. (but just to be on the safe side, you could backup you're config before you begin)
  4. n_casquinha

    n_casquinha LI Guru Member

    Hello, so it seems to be a general problem on the wag54gs router...
    Well i have just updated mine!It was a nightmare but it is pretty easy!
    I have created a small webpage with all you need!
    I have given my computer a static ip ( and then i hard reseted the router in the small button in the back for about 10-20 secs.
    After finishing the hard reset, i just ran the utility and puff magic :) just wait until it reboots again and all red light blinking disappear and when it looks normal IT IS DONE! you have just upgrade to 1.00.08A...
    wan't even better news!???afterwards i upgraded to 1.00.12 from the inside of internet explorer and using only the router gui interface!!!!!amazing what a litle firmware can do!Sorry for my english but i'm from Portugal!!! lol
    hope it helps!
  5. skid7j

    skid7j LI Guru Member

    There is a general problem with the WAG54GS with firmware upgrading.

    You must update the firmware one step at a time using the firmware update page on the router

    Before updating, hard reset your router (put a pin in the back for 10 sec)

    Follow the list below which has been proven to work, starting from whichever version you currently have. DO NOT miss out any versions or you may run into problems. Remember to hard reset first and reboot between versions to ensure it goes without a hitch.

    • Hard Reset the router
    • Upgrade to 1.00.02
    • Reboot the router
    • Upgrade to 1.00.06
    • Reboot the router
    • Upgrade to 1.00.08
    • Reboot the router
    • Upgrade to 1.00.12
    • Reboot the router
    • Upgrade to 1.01.00
    • Reboot the router
    • Upgrade to 1.01.01

    To find the firmware files either email linksys or google them.
  6. trebor2510

    trebor2510 Guest

    Hi there. Any idea from where I can download firmware version 1.00.08? Linksys now only seem to have onwards... :frown:
  7. artemite

    artemite Guest

    There is a link just above in this thread for that: http://www.linksys.no.sapo.pt

    I found this utility doesn't work on my Dell notebook running XP SP2, crashing out with an error "report = 0" after hitting the update button. I also had trouble finding the router because I was connected to it over wired ethernet but using the wireless to get internet while I figured this problem out. The utility asks you which network adapter to search for the router on, but I don't think this was entirely reliable. I had much more luck just disabling the wireless while I tried the utility.

    I ran the upgrade utility successfully on a Windows 2000 Toshiba notebook.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice