WAG54GS firmware update problem

Discussion in 'Other Linksys Equipment' started by Honziiiiik, Jan 4, 2007.

  1. Honziiiiik

    Honziiiiik LI Guru Member


    I Cant update this modem throu the web site, not even throu the tftp utility. I put correct IP, put the file and tried non pass, default (admin) and nothing helps. Any ideas where i am doing misteake? THX a LOT for any help!!!
  2. HiSpeed

    HiSpeed Network Guru Member

    Which version are you trying to install ?
    With WAG54GS an intermediate version is sometime required !
  3. Honziiiiik

    Honziiiiik LI Guru Member

    I Tried a LOT! Any makes the same. Aneex A, Annex B, doesnt matter. Really dont know how to update, and i dont know i am so stupid.
  4. n_casquinha

    n_casquinha LI Guru Member

    Hello, so it seems to be a general problem on the wag54gs router...
    Well i have just updated mine!It was a nightmare but it is pretty easy!
    I have downloaded from
    from the EU folder, that is for annex A, the
    and it was only with that utility, that i was able to pass from 1.00.06 to 1.00.08A ...
    I have given my computer a static ip ( and then i hard reseted the router in the small button in the back for about 10-20 secs.
    After finishing the hard reset, i just ran the utility and puff magic :) just wait until it reboots again and all red light blinking disappear and when it looks normal IT IS DONE! you have just upgrade to 1.00.08A...
    wan't even better news!???afterwards i upgraded to 1.00.12 from the inside of internet explorer and using only the router gui interface!!!!!amazing what a litle firmware can do!Sorry for my english but i'm from Portugal!!! lol
    hope it helps! By the Way to access the links, in 19/1/2007...
    USER: linksys Password: beta559
    Any doubt don't hesitate to e-mail ncasquinha@sapo.pt or just add me to your msn!
    I'll help anyway i can, even sending the files of course!
  5. skid7j

    skid7j LI Guru Member

    There is a general problem with the WAG54GS with firmware upgrading.

    You must update the firmware one step at a time using the firmware update page on the router

    Before updating, hard reset your router (put a pin in the back for 10 sec)

    Follow the list below which has been proven to work, starting from whichever version you currently have. DO NOT miss out any versions or you may run into problems. Remember to hard reset first and reboot between versions to ensure it goes without a hitch.

    • Hard Reset the router
    • Upgrade to 1.00.02
    • Reboot the router
    • Upgrade to 1.00.06
    • Reboot the router
    • Upgrade to 1.00.08
    • Reboot the router
    • Upgrade to 1.00.12
    • Reboot the router
    • Upgrade to 1.01.00
    • Reboot the router
    • Upgrade to 1.01.01

    To find the firmware files either email linksys or google them.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice