WAN DHCP not working??

Discussion in 'Tomato Firmware' started by hei209, Dec 15, 2006.

  1. hei209

    hei209 Network Guru Member

    Hi everyone

    I have flashed my WRT54G (v2) from Thibor 15c to Tomato 1.01 with nvram cleared before and after upgrade.

    Everything seems to be running great, but the WAN cant get an IP by DHCP from my ISP. I can get an IP from the ISP with direct connection.

    Flashing back to Thibor gives me the same result, any clue please?
  2. GeeTek

    GeeTek Guest

    Try hooking your computer directly to the ISP modem to see if the ISP modem is even giving out addresses.
  3. luckman212

    luckman212 LI Guru Member

    try clone PC mac address in tomato?
  4. GeeTek

    GeeTek Guest

    No, I did not read your original post very well. You already said you do get an address when connected directly. My cable modem must have the power disconnected for about 10 minutes for it to forget the MAC address it was servicing.
  5. snwbdr

    snwbdr Network Guru Member

    I had this problem when I first switched from Thibor to Tomato. I had power cycled my modem and was connected to the router through a wired connection. Now it saw my Lan card MAC and not my WLan card MAC address. Try cloning with wired or wireless connection, whatever the opposite was not working for you. Make sure you got the right mac addresses in the right place in Advanced>MAC Address. Try swithing the WAN port and the Wireless Interface MAC Adresses
  6. hei209

    hei209 Network Guru Member

    Hi everyone

    I tried all the methods mentioned above and NONE of them work……

    After struggling for a long while, I managed to get my WAN IP through DHCP by flashing back to the ORIGINAL linksys firmware.

    In order to confirm where the problem is, I did some tests by flashing different firrmwares:

    Original firmware upgraded from Thibor 15c -> able to get IP
    Original firmware upgraded from Tomato 1.01 -> able to get IP
    Thibor 15c upgraded from Original firmware -> able to get IP
    Thibor 15c upgraded from Tomato 1.01 -> NOT able to get IP
    Tomato 1.01 upgraded from Original firmware -> NOT able to get IP
    Tomato 1.01 upgraded from Thibor 15c -> NOT able to get IP

    From the above test, I must say either Tomato 1.01 has a bug on the WAN DHCP or it doesn’t like my WRT54G v2……..
    I have switched back to thibor at the moment and is waiting for someone to help….
  7. dadaniel

    dadaniel Network Guru Member

    have you send a mail to jon?
  8. hei209

    hei209 Network Guru Member

    Is it the one stated on the polarcloud website?
  9. GeeTek

    GeeTek Guest

    Yes, that is it.
    I have 1.01.0918 loaded and running. No problem obtaining WAN IP by DHCP from Motorola speed stream cable modem. Router is a Buffalo WHR-G54S. Do you have an alternate radio to try it on ? It sounds like a hardware fault to me. Your RAM memory may have failed in places, and different firmwares may be using different memory locations for the DHCP function. If it were a Tomato firmware bug, it would seem that there would be more folks with the problem. I have a V3, and am planning on some heavy playing tomorrow. I'll certainly let you know if I have the same problem with Wan Obtain that you describe.
  10. JensG

    JensG Network Guru Member

    I friend of mine just upgraded his WRT54GL to Tomato, and it took some minutes for his router to get the IP from his ISP.
    He uses DSL, and has a static IP assigned with DHCP.

    I have dynamic IP via cable and a Motorola Surfboard modem, and I get my IP instantly.
  11. hei209

    hei209 Network Guru Member

    I see what you mean, a hardware failure rather than a bug seems more sensible to me.

    Is there a way to check whether it is a hardware failure?

    Btw, I am using a Terayon cable modem.
  12. GeeTek

    GeeTek Guest

    There is probably a linux command that you can use to test all addressble memory. I don't know anything about linux, so maybe someone else will know a way to test RAM.
  13. snwbdr

    snwbdr Network Guru Member

    I had a problem with the WMM under advanced>wireless that would not let me connect to the internet wirelessly. Try disabling that. Also Clear the nvram from the original firmware(Linksys). I have had problems where thibor had been not working properly, he told me too flash back to the original firmware and reset the router. Then upgrade to Tomato and only change the wan port mac address. Make note of it in your current setup where you have an ip assigned. Don't play around with any other settings. Even the wireless mac on the same page. Leave on default. Try to connect wireless and wired. You might have to renew your ip addresses on your computer too. ipconfig/release then ipconfig/renew on XP. What is your internet provider & other details too. You never know. If it is a hardware issue you might have seen something else go wrong too, not just the DHCP on Tomato. Try downloading a brand new code bin from the Tomato homepage as yours might be bunk. It doesn't make sense to me that you can get an ip from Thibor and the official firmware but not Tomato.
  14. hei209

    hei209 Network Guru Member

    Hello all

    First, special thanks to GeeTek for sending me older versions of Tomato firmware, can I have other versions as well??

    Downgrading to version 0.3 and 0.8 both enable the wrt to obtain an IP over DHCP.

    I ve talked to a linksys technical staff in my home country and he told me there is a compatibility issue on WRT54 v5 with Terayon cable modem, while certain versions of firmware can obtain an IP by DHCP, some don’t. I am not sure does it apply to my wrt54g version 2 .
  15. hei209

    hei209 Network Guru Member

    Ok, I flashed my wrt with different tomatoes and found that the latest version that is working in my case is v0.9. This seems to be sensible for me because there is a fix over DHCP in v1.00. I ve emailed Jon and will see how things go on.
  16. pen_sq

    pen_sq LI Guru Member

    I have the same problem too, with Cox Cable in RI. I took a packet capture and saw a fairly similar response between Tomato and my old Belkin router. Tomato just doesn't seem to understand the address response packet (same for any other Linksys fimware that I've tried).
  17. hei209

    hei209 Network Guru Member

    Jon emailed a new tomato to me, Version 1.01.0921, and it works for me by making some changes! He is really a nice guy and responds quickly!

    Btw, anyone who has the same problem with me can leave me your email, I can send you a copy to try.

    Thanks all again.
  18. GeeTek

    GeeTek Guest

    A few reminders ;

    1 - Donate (again, more.) The work continues, so should the pay. Jon is working hard to make nice firmware for us.

    2 - Post Tomato links all over the Internet. More people need to know about Tomato.

    3 - Update your avatar with a Tomato picture.

    Life is better because of Tomato !
  19. attackpup

    attackpup Guest

    Same problem

    I had that same problem a few days ago. I fixed it eventually but not sure how other than flashing back to linksys firmware, still not getting an ip, hitting release/renew over and over quickly until it finally got one, flashing back to tomato and everything stayed working. I PM'ed you to get that firmware update in case this happens again!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice