Wan renew resets dnsmasq

Discussion in 'Tomato Firmware' started by HVACengi, Oct 31, 2009.

  1. HVACengi

    HVACengi Network Guru Member

    First off: I love Tomato. I've been running it in some version for a long time, and it is simply awesome. Flexible, stable, useful.

    I run a WRT54G router behind a 2wire adsl router (with a public IP and set as a DMZ). The WAN IP lease is only ten minutes long. I've noticed an issue where a file download is interrupted when the lease is renewed.

    At first I thought that it was because the router was not able to renew properly, which resulted in loosing the lease and then getting a "new" identical lease right away. To test this, I manually invoked the "dhcpc-renew" command every 8 minutes from the scheduler, with the same results. I can also observe the same behavior if I click the renew link in the Tomato web interface while a download is going on. Looking at the router log from wallwatcher, dnsmasq is being restarted every time the WAN IP is renewed. From what I can tell from some other posts, dnsmasq shouldn't need to be restarted every time the WAN ip is renewed, and certainly not every 10 minutes.

    Is there a way to change this behavior for dnsmasq?

    I have observed this behavior in both versions 1.25 and 1.26(beta).

    The most prominent way for me to observe the issue is in PlayOn (a UPnP media server that transcodes videos from Hulu), where the download stream would die seemingly randomly. I can also reproduce the problem with a file download in Internet Explorer 8.

    Any help that you might offer would be really appreciated!
  2. krux01

    krux01 LI Guru Member

    Please let me know if you figure this out. I am experiencing a similar problem. Thanks
  3. mstombs

    mstombs Network Guru Member

  4. HVACengi

    HVACengi Network Guru Member

    Wow, thanks mstombs! It looks like that worked. I just set it up remotely from work, so I'll have to run a more intensive check when I get home.

    I never even thought of it being a firewall issue. I just searched for "dnsmasq" and didn't find anything that looked helpful, thinking it had to be an issue with the LAN side DHCP.

    For the record, and for krux01, all that I did was add this line to my firewall script, and then rebooted:

    iptables -I INPUT -p udp --sport 67 --dport 68 -j ACCEPT

    I'll mess around with it latter this evening, and look at implementing the "interface" option that mstombs talks about in the other thread, and report back.

    Thanks again!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice