WAP54G 802.1x WPA Radius slow

Discussion in 'Other Linksys Equipment' started by n4dsl, Nov 28, 2005.

  1. n4dsl

    n4dsl Guest

    I am currently implementing 802.1x with IAS/Windows Radius server.
    I have been able to make it work, but had a concern with the amount of time it takes to authenticate. Has anyone else had any experience with this?
    I am using WPA Radius with AES, and have tried TKIP also.

    It takes around 20-40 seconds to validate identity when booting up.
    If I look at the log on IAS server, it shows user validated twice, around 20-40 seconds apart. Is the Linksys not receiving the first packet and waits for second?

    If I change encryption to WEP radius, it really goes fast, just a few seconds. What is different about WEP, is WPA just naturally slower with 802.1x?

    I have updated to latest firmware revision.
  2. late1983

    late1983 Guest

    I also have this issue connecting with WPA Radius on my WAP54G with the latest firmware to date (v3.04) and FreeRadius with TTLS on Linux.
    Have tried to adjust the advanced wireless settings so maybe packet flow goes smoother, but it didn't work out.

    With an ethereal session it looks like the access point is not receiving the Radius packets because the server is resending them.

    Using an Cisco Aironet accesspoint with same settings (WPA Radius) i have no issues, so i think this problem is Linksys related.

    Can somebody please explain what is happening here?
    Many thanks in advance
  3. Stinksys

    Stinksys Network Guru Member

    I've been testing this the past week and here's what I've come up with:

    Linksys, WPA/Radius, Microsoft wireless client: SLOW (then drops connections a bunch). Useless.

    Linksys, WPA/Radius, Intel wireless client (for my card): FAST

    Cisco 1232: FAST with everything.

    This is all authencating to Cisco ACS 3.3.

    Interesting to note that the WAP54G apparenly does NOT support WPA2/Enterprise. Yet it supports PSK just fine. Sup with that?? BTW, WPA with AES, is NOT WPA2. Tho it does "work" here, just without the WPA2 enchancements.
  4. swatts

    swatts Guest

    I am using a WRT54G with WPA2 Enterprise to a Juniper Steel Belted RADIUS with an RSA ACE backend.

    What I am seeing is multiple attempts from the same user on the RSA ACE server. This has the effect of locking the User out :-(

    The issue seems to be that the Linksys AP resends the same credentials up to 3 times at periods of 30 seconds,.

    If the Linksys does not get a sucessful or unsucessful login confirmation back from the RADIUS within 30 seconds (or possibly less) it resends the authentication request. This is a real problm, and there is no way to tune number of request or time between requests on the Linksys.

    I see this behaviour with a number of laptop clients, Intel ProSet V9, v10 and Juniper Odessey client.

  5. sammyjr

    sammyjr Guest

    I had the same problem with my WAP54G. It was extremely slow when clients connected with both the Windows and the Intel supplicants and with Freeradius and IAS back ends. I ended up buying a Netgear WAG102 and everything works as fast as expected.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice