WAP54G V2 Dead after firmware upgrade + solution

Discussion in 'Other Linksys Equipment' started by kudoma, Mar 3, 2005.

  1. kudoma

    kudoma Network Guru Member

    Hello all,

    I am distressed, I have a WAP54g V2 access point that I recently loaded MustDie_1.08_r2.trx to and I seem to have killed it. I used the http interface to do it. I set the ap to allow me to upload it and it said it completed and was successful.

    I tried getting an interface though http first and I tried these ip addresses

    Nether worked so I hooked up the ap to my rougher to see if it pulled anything from DHCP but no activity was logged.

    I downloaded the new application from linksys’s FTP and tried to find it with it hooked directly up to the ap, though the rougher, and both of these with dhcp on as well as setting my ip to a static with subnet mask

    I tried to reset it many times and holding it down for up to 60 sec. with no change in leds or improved response.

    I looked up the trick of shorting the flash pins to get it to accept a new flash. But being version 2 of the AP, I did not find any information on how to do this to the flash chip or even where the chip is. But It looks like it is the one marked ic42s164006t.

    I decided to check and see if there was any response when it first booted.

    I ran ping continuously with a fast timeout so I wouldn’t miss anything.
    I never got a response from either of these ip addresses

    right now its just sitting there with the power light steady and the link light blinks every so often. The activity light is completely out and stays out.

    I’m thinking the only other thing that I might be able to do, is set up a serial connection to it and try uploading firmware that way. But I wouldn’t be sure how to do this for my version of the AP. I read other instructions already.

    Please, if anyone has any insight on what I can do besides chuck it off a tall building and grind the remains into a powder, later to set it on fire in an incinerator and have a local dog defecate on it, please post :)

    Ohh and if anyone needs a photo of the PCB I can scan one in for you. Thanks.
  2. kudoma

    kudoma Network Guru Member


    Ok well that was a tricky one.

    For those of you with the same hardware and problem, this might be useful.

    The WAP54G V2 has the flash chip on the back of the PCB so you have to unscrew it from its base. Its clearly marked Intel flash… (duh oops)

    The 15 and 16th pins are tricky. The actual chip, while it does have two dots on two of the corners, neither one signifies the first pin… odd.

    The first pin is marked by a white dot on the board itself. Its on the side facing away from the leds and toward the rest of the PCB board, not the edge. Count the pins, there also marked in fives by the lines.

    Set up you computer to have a static ip address of


    Either use dos or linux.

    In dos

    Ping –t –w 100

    It will try to refresh after waiting 100 milliseconds so you get a higher resolution response.

    Short pins 15 and 16 and then plug the unit in.
    It should start responding.

    Hit CTRL+C to exit the ping


    tftp -i PUT c:\place_where_your_file_is.trx

    It should load up.

    You might want to do a reset by holding down the reset button to get it up and working again.

    When I held mine down the lights blinked and indicated it reset, that was a very good sine for me. You have to give it a few seconds to get up and going, then you should be fine.

    Well I tried loading the MustDie though this technique but it didn’t work, I guess the file I got or the version I got was bad or not for my AP. I will try a different one now.

    See ya


    I downloaded the MustDie from this site and was revision 1 and it worked like a dream. I’m beginning to think that revision 2 is ether false or not for this AP. I don’t remember where I got it from, but after I had trouble I came here.

    Thank you everyone for your useful information on this site. Without it I would be lost.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice