WDS active - DHCP on the WLAN Interface

Discussion in 'Sveasoft Firmware' started by nate, Aug 13, 2004.

  1. nate

    nate Guest


    i just have set up 2 WRT54G with WDS active.
    I followed the instructions on the bottom of this thread:

    WDS working - NO dhcp on the WLan interfaces and i can connect with a Wlan-Client, BUT i can't access the Net.
    I don't get an IP and even if i assign one manualy - no access to the network

    I tried to use the subnet feature:
    Same sh**

    so i came up with 2 questions:
    - Is it possible to connect WLan Clients to the WDS-routers ?
    - Is it possible to use WDS and hvae DHCP on Wlan interface ?

    If an answer is yes:
    Anybody knows how it works ?

  2. Couledouce

    Couledouce Network Guru Member

    Yes, the idea is that you can connect your wireless client to either the WRT with the internet connection directly or to the repeater WRT, depending on which SSID you use on the wireless client.

    The WDS provides the network connectivity between the 2 WRTs and one of them provides the DHCP server which allocates the IP addresses for the network.

    Now if it doesn't work, to state the obvious, something is not setup right. Have you checked the "Status/Router", "Status/Local Network", and "Status/Wireless" menus on each router to see that the router, DHCP server, and WDS all appear setup correctly?
    Can you access the internet with a wireless client connected directly to the WRT with internet connection?

    Maybe you can copy and paste the text from each of these menus into the post and somebody will recognise what is missing in the setup?
  3. Flick

    Flick Network Guru Member

    I'm having a similar problem, am using the same release version. I've got a DHCP server running on my network, so have disabled it in the router.

    When I plug my laptop into one of the router ports it picks up an address from the DHCP server machine just fine and off I go. However, when I connect via the wireless card it doesn't pick up an address. It connects and I show a solid signal, but it won't pull an IP address. Even hard coding one in doesn't work, I still can't get anywhere.

    Any ideas?


  4. Flick

    Flick Network Guru Member

  5. Toxic

    Toxic Administrator Staff Member

    have you tried assigning a static ip from the dhcpd in administration from the satori firmware?

    this should work.

    format: IP MAC Hostname
  6. Flick

    Flick Network Guru Member

    Ok, that got me connected and limping along, thanks! It'll work until I get the root problem worked out.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice