WDS and Thibor 201105

Discussion in 'HyperWRT Firmware' started by bigrig, Nov 29, 2005.

  1. bigrig

    bigrig Network Guru Member

    Okay, can somebody please give me a hand...

    I had two WRT54GS's (v1.1) connected with WDS, by running HyperWRT and a startup script to enable WDS. But I've had problems with my WAN connection dropping out, so I decided to see if an updated firmware would help out.

    Flashed both routers with Thibors HyperWRT, dated 201105. And now... I forget what the hell I'm doing... :unsure:

    Do I want Router A set as AP and Router B set for WDS? Or both for WDS? Do I need to set up Advanced Routing on Router B so it knows where to go? Do I need to mess with the Bridge Restrict stuff?

    Help! :jester: Thanks,

  2. bigrig

    bigrig Network Guru Member

    Okay...after reading a post by Gerds2001 in the WDS thread, here's where I'm at:

    I was trying to use WPA2-TKIP with no success. After reading Gerd's post, I set both to WDS-AP, WEP encryption, and bridge restricted to their wireless MAC addresses. All seems to be working now, without any script entries. I guess WEP is all we can use with WRT54GS?? :cry:

  3. Thibor

    Thibor Super Moderator Staff Member Member

    that's not the case, i use WPA-AES with my wds link. take note of the WPA, not WPA2(it doesn't work with wds)
  4. bigrig

    bigrig Network Guru Member

    Aha, WPA, not WPA2. Okay, I'll give that a shot, thanks for the quick reply!! :thumb:

  5. bigrig

    bigrig Network Guru Member

    Thibor -

    Man, I tried, but I couldn't get them talking to each other using WPA. I tried WPA Personal with both AES and TKIP, and the routers wouldn't connect. Going back to WEP they connect no problem.

    I see from your sig you have a GS1.0 as wds, and your 1.1 with WET and Client mode...are you sure two 1.1's will connect with WPA and WDS? I think it should...that's what I had before using HyperWRT 2.1.b1.

    Thanks for any advice!

  6. zaphod

    zaphod Network Guru Member

    hi bigrig,

    got 2 WRT54GS running with latest thibor release (2011) and linked with WDS using WPA Personal.

    after updating the firmware its really important that you reset both routers to their defaults the best way is:

    - telnet to each router
    erase nvram; reboot

    now they got default values.

    now set the wireless channel, the ssid and the security to wpa-personal with aes on both routers. reboot both routers

    after the routers back again, set the wireless mode to wds-ap on the first router, set the bridge restrict to enabled and enter the wlan-mac-adress from the second router under the remote-bridges-tab.

    enter following in startup-script:

    /usr/sbin/wl wds mac:from:second:router

    reboot the first router.

    same procedure on the second router, with mac-adress from first router.

    after rebooting the second and waiting a few minutes you should be able to ping the second router from the first one...

    also disable dhcp-server and firewall on the second router. (first router is the one connecting to the internet)

    hope this helps to figure your problem out...


  7. milko7

    milko7 Guest

    I have two routers WRT54GS V4 and WRT54GL both with same Thibor's FW 20112005 in WDS-AP configuration. Everything works fine with WEP security. With WPA-AES works only as long as there is no reboot of routers. After reboot there is no connection without manual intervention. I followed your instructions in previous post. Do you have any other hint.
  8. scotkb

    scotkb Network Guru Member

    I too have been working on this (Thibor 20112005) WDS with WPA. I have tried many things and I think I have a stable config that is working (still works after reboots, seems to have adequate speed, etc).

    WRT54GSv1.0 router A
    "normal setup" after erase nvram, reboot, restore factory defaults. This is the one that connects to the internet, serves DHCP, etc.

    WRT54GSv4.0 router B
    "normal setup" after erase nvram, reboot, restore factory defaults.
    This one is the extension.

    I have them both set the same channel, same SSID, etc. I select WDS-AP, G only and WPA-personal with AES. I also added "wl wds the:eek:ther:router:mac" in each startup script. This last one seems to stablize the WDS after reboots. It may have something to do with the "bridge restrict" disabling after each reboot, I'm not sure.

    I think the difference for me was selecting "G Only" and WPA personal (I had tried the WPA2 settings without success).

    Good luck and Merry Christmas!
  9. bigrig

    bigrig Network Guru Member

    Hmmm, I'll have to give the startup script a try. Thanks for the tips, guys! :rockon:

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice