WDS on Thibor's 081005 HyperWRT with WPA?

Discussion in 'HyperWRT Firmware' started by e-razor, Oct 13, 2005.

  1. e-razor

    e-razor Network Guru Member

    Hi there,

    I've been trying to make my WRT54GS with Thibor's 081005 HyperWRT v2.1b1 to join in a WDS link made up of 2 Airport Express (AX). I tried to make it run both as a remote base station and as a main base station. I was unsuccessful with both set-up's. The AX link run WPA security (the most recent AX firmware 6.2 employs WPA2, but it's flaky). I managed to make WDS to work without any security whatsoever with the 170905 release. I was hoping that someone could peace together i nice pedagogic howto on WDS and Thibor's latest release.


  2. Thibor

    Thibor Super Moderator Staff Member Member

    wpa2 with wds doesn't work, at least i have never had it working. wpa(aes) and wpa(tkip) i have had working and currently use. wds setup is straight forward between wrt's, i'm not sure about the apple units.
  3. e-razor

    e-razor Network Guru Member

    Hi The_Real_Thibor

    WPA2 and WDS did work on my set of Airport Express, but since the v6.2 was flaky I decided to downgrade and I had to settle with WPA security. I only tried WPA TKIP, since i bricked the router using a Sveasoft release sometime last year when I selected AES. I actually bricked it 3 times, and it's only thanks to Voidmans instructions that it didn't end up in the recycle bin. It's been on the shelf since then. I really don't need it any more, but being able to include it in the WDS chain would at least excuse the expense. Your firmware is really cool. But it seems to hot to handle, at least for me. If you could describe how to set up WDS with WPA, I'd really appreciate it and I guess I won't be the only one.

    Thanx in advance,

  4. Thibor

    Thibor Super Moderator Staff Member Member

    ok, i'm working on the assumption that your airport express units work via lazywds(they'll connect to wds capable unit without configuration). on your wrt set the SSID and channel to the same as the ap's. set Mode to AP(wds + Wireless Repeater Mode) or WDS(WDS only). then enable WDS and save settings
    re-enter wireless basic and enable Bridge Restrict if you want lazywds off, and enter the wireless mac addresses of your ap's. then go to Wireless security and configure it to be the same as the ap's. that's all i've done to get it going. I have found encrypted wds to be a bit sensitive though, if you play with the settings the wds link falls over until wrt is rebooted, a legacy of linksys's code i think.
  5. e-razor

    e-razor Network Guru Member

    Hi The_Real_Thibor

    I bricked WRT54GS again. This time when I increased the power one notch and if I'm not mistaken, this is why I bricked it before. I give up on it. I just (thanks again to Voidman) restored it with the latest official firmware. My WRT54GS almost seems sensitive to touch or loud voices. Maybe it's flaky in one way or another (CGN1, v1.0). I never had any problems with the original firmware though, not that it stayed original for very long.

    I wish all of you the best of luck.

  6. Thibor

    Thibor Super Moderator Staff Member Member

    i have a v1.0 as a test unit, i'll take a look at increasing the power to see if mine bricks
  7. e-razor

    e-razor Network Guru Member

    Hi The_Real_Thibor

    After all this milage I couldn't resist giving your 141005 GS firmware a go. I configured the router the same way as when it last bricked, waiting with the power increase to last. It didn't brick! The funny thing is that even though it initially showed an increase of power from 50% to 67% is that after I committed the changes it came back to 50%. It seems as if the WRT54GS hardware version CGN1 or v1.0 is a kind of its own and doesn't take kindly to power increase. Am I the only one with this experience?

    Thanx again The_Real_Thibor and the rest of you that made this HyperWRT experience happen!

  8. Toxic

    Toxic Administrator Staff Member

    141005 was broke use 151005 from downloads section
  9. e-razor

    e-razor Network Guru Member

    Thanx Toxic,

    With the 151005 it does accept a power increase and I took it to a blistering 100% and it's still alive and cooking. It's warm to the touch, but not warmer than usual. Placed next to my Airport Express on different channels (1 & 11) about 5m (16ft) away with two walls to penetrate where I have my computer the WRT54GS produces a signal strength equal to the Airport Express. The disadvantage of the Airport Express is that it's orientation is determined by the power outlet.


    Thanx Thibor,

  10. timmy33

    timmy33 LI Guru Member

    help with WPA on WDS

    Hi thibor, not to sure if this is still active as i relaise this is an old post/ thread. but here goes anyway.

    I have a wrt54gs with thibor v15c firmware, and a apple express with firmware version 6.3.

    I am having trouble getting WDS with wpa (tkip) to work (between airport express and wrt54gs), i have got WDS and WEP to work but as wep is not very strong i would like to have wpa going.
    I have got wpa going as security without WDS functioning between the wrt54gs and the airport express (and the rest of the wireless network)
    I have heard of it working in other posts but i have failed, is because of the firmware on the wrt54gs or something else?

    I am quite technically clued up.

    thanks for the help in advance
    :) :) :biggrin:
  11. Thibor

    Thibor Super Moderator Staff Member Member

    i can't really give you any advise regarding wds with an express as i don't have one. all i can tell you is that it does work as others have posted that it does. try aes instead of tkip as a starter and be patient when they are trying to talk to each other.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice