WDS with 2 WRT54GS V4 and problems with firmware-upgrade

Discussion in 'Cisco/Linksys Wireless Routers' started by philet, Jan 17, 2006.

  1. philet

    philet Network Guru Member


    I bought two WRT54GS V4 (after bringing back two WRT54G V5 :() and want to set up the following network:

    ---- Wired
    ~~ Wireless

    ISP -- WRT54GS#1 ~~~~~~WRT54GS#2 -- Desktop PC

    And an additional Laptop with wireless connection. (possibly to router #1)

    I've tried to do it with "Hyperwrt GS Thibor-12", but could not bring it working. Then I saw in
    this manual and in this thread that I would not need Thibor. But after trying to change the firmware to "HyperWRT 2.1b1" both router crashed. I had to de-brick them. OK, it was my fault, I forgot to do the factory reset :(.
    Then I tried to go from the firmware loaded while de-bricking the router (WRT54GSV4_1.05.4_DE_code_fw.bin) to "dd-wrt.v23_generic.bin" and then to "HyperWRT 2.1b1". But my router crashed again :eek:. After two evenings of try and error I don't want to de-brick my routers again... Right now they run with "WRT54GSV4_1.05.4_DE_code_fw.bin".

    So if anybody out there can give me some information about how I can set up the desired configuration with a firmware running on WRT54GS V4 (and how I get them running without crashing the router again) I would be really happy!! :)

    Thanks in advance.
  2. 4EverGreen

    4EverGreen Network Guru Member

    Why don't you try DD-WRT ? :thumb:

    I also have 2 x WRT54GS v4 with DD-WRT v23 final and they're WDS connected problems free ! :)
  3. scotkb

    scotkb Network Guru Member

    ..and I am running WRT54GS (v1 main, v4 remote) WDS-AP, WPA personal, speedbooster, problem free using Thibor12. so it is really your choice about which firmware you use. very important to use the nvram erase, reboot, restore factory defaults when doing the firmware changes. A leftover nvram setting or unset nvram setting can cause untold hours of frustration.
  4. philet

    philet Network Guru Member

    That was what I was trying to do using Thibor12. Is it the firmware you can download on this page? And is it just "ThiBor 12" (the lowest download) or combined with "Hyperwrt2.1b1"? I think I took the combined one, and could not bring it to work.
    And to clear the nvram, I have to do it connecting via telnet to the router?

  5. philet

    philet Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice