Weird connectivity with wan side

Discussion in 'Tomato Firmware' started by roadkill, Feb 4, 2007.

  1. roadkill

    roadkill Super Moderator Staff Member Member

    I just installed Tomato 1.04 on my WRT54GL 1.1 I like it so far very much...:biggrin:
    this is my config
    wan side
    pptp to dsl modem (dsl modem address
    router address
    I can't reach from inside the network I need to manually change my ip address.
    it worked at start and then I guess I did something and it stopped...
    this seems a little puzzling how come the router dials the modem?
    anyone got a clue?
  2. digitalgeek

    digitalgeek Network Guru Member

    You could consider changing you router IP to (or something like that)

    This will put you lan on the same subnet as your modem.
  3. roadkill

    roadkill Super Moderator Staff Member Member

    after I reset the NVRAM it does work like it should and I can access my modem and all...
    I tried changing it back to the same subnet - no go
    I think what cause the problem in the first place is that
    I changed the router ip to 10.x.x.x and then changed it back to 192.168.x.x
    could be missing a line on the routing table... because when it was 10.x.x.x
    it needed no translation from one subnet to the other...

    Destination Gateway Subnet Mask Metric Interface * 0 ppp0 * 0 br0 (LAN) * 0 vlan1 (WAN) * 0 lo
    default 0 ppp0

    where is the external ip address

    I can just reset the router but I configured QOS and Port Forward rules already I hate to do it again for something that small...

    I found the source of the problem:
    when I dial using (PPTP /PPPoE) I lose connectivity to my modem this
    because of the dynamic routing table update if I had an option to use
    pptp with dhcp this should not happen (I think)
    other firmwares got DHCP on/off under type of dial so I guess this goes into the wishlist... :biggrin:
  4. PaulH225

    PaulH225 Network Guru Member

    The problem is more to do with NAT/routing than DHCP. When your PPTP/PPPoE interface is down everything out the WAN interface (vlan1) is NAT'd to the WAN address of the router ( BUT, when your PPTP/PPPoE interface is up, the default route switches to ppp0 as does the NAT. So anything sent out the vlan1 interface is sent with its source address as 192.168.x.x which your modem will have no route to send replies to.

    Easiest solution (if you can do it) is to add a static route on the modem with a gateway of That was the modem can see your LAN and you will be able access your modem's web interface.

    Another method is a little trickier, you need to add a few rules to your firewall (using ipchains/iptables) on the WRT to translate the source address of any packets destined for the modem's IP address to the router's WAN IP address.

    Hope that helps,

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice