Weird LAN ports malfunction

Discussion in 'Cisco/Linksys Wireless Routers' started by penkert, Nov 14, 2005.

  1. penkert

    penkert Network Guru Member


    After a bad firmware flash (DD-WRT v23 Beta2 11/11/05) I had to debrick my WRT54G v1.1 using the pins 15 & 16 method. Now my LAN ports are not working correctly anymore. Connecting wirelessly, however, is no problem. The LAN problem exists with DHCP turned on and off and static and dynamic IPs on the client side. I have tried flahing several other firmwares wirelessly since then (resetting the router to default settings every time), but the problem persists. The only way I get a ping from the router through its LAN ports is by putting the router into failsafe mode first, shortening pins 15 and 16 on bootup.

    It doesn't look like a real hardware problem to me since the LAN ports seem to be working all right in failsafe mode. On the other hand it can't be a pure software problem either with all those different firmwares I tried, can it? Strange...

    Does anybody have an idea what might be the problem here?

    Thank you very much!
  2. poky

    poky Network Guru Member

    I have a same problem today after I upgraded the hyperWRT
    the wireless part seems fine, but the LAN part, lights on, but won't get any DHCP ip, even tried to asign a static, won't ping to the router either, and the WAN is down too.
    Tried any reset but no luck.
    Mine's wrt54g v1.1
  3. penkert

    penkert Network Guru Member

    Interestingly enough after a few days of being powered down and yet another wireless firmware flash my LAN ports seem to be working fine again. Frankly, this development is even more bizzar to me than the one I described above. Is there anybody who has an explanation for this behavior? Right now, I feel a little reluctant towards flashing test firmwares onto my routers. I was aware that this might brick the router but I thought debricking would almost always be possible, thus restoring the router to its full glory...
  4. penkert

    penkert Network Guru Member

    All right, I found the problem and just wanted to let people know how to solve it in case they are having similar experiences. Apperently, the DD-WRT firmware left a bunch of stuff in the NVRAM that corrupted the other firmwares. Here's a thread in which BeHappy describes how to revive a WRT that's stuck in such a state:

    A big THANK YOU goes out to BeHappy!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice