Weird wireless problems on WRT54GL with Tomato

Discussion in 'Tomato Firmware' started by stonefury, Jan 31, 2012.

  1. stonefury

    stonefury Networkin' Nut Member

    I see a lot of threads on WRT54G routers, but I don't see the same set of symptoms described.

    -The wireless connection will work for awhile, but randomly fail with pages suddenly failing to load. This has become more frequent and now seems to happen a few times a day.

    -The weird part is, the computer will show that the wireless is still connected, and the webpages will eventually load if I keep refreshing them.

    -The reason I say it's a wireless problem and not an internet problem is that behaves the same way; failing to load until I refresh the page over and over.

    -If I disconnect from the network I will still see its signal, but trying to reconnect hangs for a long time. Eventually a box pops up asking for the password, which is remembered, but clicking OK causes another long attempt to connect which ends again in the password prompt.

    -Power cycling is sometimes enough to fix it for awhile. Other times power cycling doesn't help, and I have to do a hard reset or flash the firmware again before I can connect. Then it works fine for awhile until this all starts again.

    I've tried changing wireless channels, and going back to the previous version of Tomato firmware, neither made any difference. I also tried a suggestion I found in another thread to go into advanced wireless settings and decrease beacon interval from 100 to 50, reduce fragmentation threshold by 40, and reduce RTS threshold by 40. Not sure if this is good advice, but it didn't have any effect on this problem.

    Anyone understand advanced wireless settings well enough to know how to troubleshoot this? Is it just a sign that the router is going bad, should I try a different firmware like DD-WRT?
  2. bl00513

    bl00513 Networkin' Nut Member

    I've had more that one of the WRT series routers do the same thing. Each time it happened the router died shortly after. As you mentioned a reset usually fixes for a couple of days, but then it's back to the same thing. Also, my wired connections were usually fine, so I'm thinking you guys might be in the same boat here. Hopefully this isn't the case for you guys, but from my experience this is often what's happening.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice