WET54G Connection Problems

Discussion in 'Other Linksys Equipment' started by Trekker39, Feb 12, 2006.

  1. Trekker39

    Trekker39 Network Guru Member

    I cannot get my WET54G Bridge to connect with Linux. It works fine with XP. I think the problem is that it is not getting an IP address from my WRT54GX router. It had been working before but I bought the newest Linksys Router, the WRT54GX router and it has not been working since.

    I have tried using the reset button on the bridge and have reconfigured all the settings to use DHCP from the router. I have also gone into the web interface, making sure DHCP is enabled and that the ssid is the correct name. I have also tried using other distros like Simply Mepis, Ubunut, Kubuntu, SuSe, Kanotix, and now Madriva. Mandriva does recognize the ethernet port as a SiS900 10/10 LAN but when I tell it to connect, it doesn't get an IP address.

    I am relatively a newbie to the linux world but this was working before.

    One more thing, I have also tried putting the older router back in place but the problem remains.

    Any ideas or suggestions?
  2. dkggpeters

    dkggpeters Network Guru Member

    The joys of getting Linksys devices to connect to their own. My biggeest problems on my network is getting the Linksys devices to connect and stay connected. Enough of that.

    I also have a WRT54GX (Ver 1) and 2 WET54G's (Ver 3) up and running.

    Do you have MAC address filtering on? This has caught me more than once. If you do turn it off to see if you can connect then add the MAC address and turn back on.

    You mentioned trying to connect with Linux. Are you connecting a DVR? If so, what USB2 to Ethernet adpter are you using? I could not get USBM200 to connect and have had great success with Netgear FA120.

    I have also noticed the following and keep in mind I am still tinkering since I have only had mine for a couple of weeks:

    When my WRT54GX was set on auto channel the bridges would be in scanning mode and connections would be intermintent. I changed the channel to 11 which resolved this problem.

    Set CTS to enable. Without CTS (Advanced wireless settings) the bridges would light up light no tomorrow.

    For security, I am running WPA/WPA2 EAS. I noticed with this if I set the group interval key to 7200 seconds the bridges will stay up for about 5 to 6 days. When I had set at 600 seconds they would only stay up for a day. I have experimented with different settings and isolated this one to time that the bridge would staty up. Mine still drop after about 6 days which I am working on to resolve.

    I also run WPA/WPA2 EAS because my Linksys print servers only hold a connection with this security. They drop using TKIP and AES is better anyways and all my other devices accept it.

    I also have immediate ACK set to enable and 802.11e QoS set to disable although I do not know if we had any impact on the connection or not.

    Provide more information on what you are connecting to and I would be more than happy to share all my settings that I am using on both the WRT54GX and WET54G if it will help you.

    Feel free to PM me and I will respond.

    What version of WET54G do you have? If version 3 check if you firmware is the latest which is 1.08. Also check that your AP has the latest firmware version.

  3. Trekker39

    Trekker39 Network Guru Member

    Sorry this is late....very very busy.

    I PM'd you after your response but haven't seen your reply.

    I have the same version of the WET54G. My goal is to have the bridge connect my LAN port to receive the wireless signal from my WRT54GX. I also want to learn linux and before switching to the new router, it was working correctly. I don't have any kind of dvr plugged into it.

    I have gone back into the web interface of the bridge and reset all of the settings as you suggested. Still have the same problem.

    I do not use any of the security since I am in an isolated, rural area. I don't have to worry about that aspect.

    Please, any more suggestions, comments and ideas are welcomed.

    PS. It is true that the bridge doesn't get an IP address? Someone sent that to me and it doesn't seem right.
  4. wister

    wister Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice