WET54GS5 v4.85 2004-08-17

Discussion in 'Linksys Official Firmware' started by jdepew, Jan 11, 2005.

  1. jdepew

    jdepew Administrator Staff Member Member


    WET54GS5 Release Notes
    Linksys, A division of Cisco Systems Inc.
    Version 4.85 4/1/2004

    1.) Change the default regular domain to US
    2.) Disable CPU port when booting to prevent CPU hanging caused by packets looping at boot time

    Version 4.84 3/29/2004

    1.) Remove telnet server ( debug support) for formal release

    Version 4.83 3/29/2004

    1.) Remove unneeded programs in f/w
    2.) Fixed cannot connect to device problem if loop detected under STP enabled
    3.) Fixed WEP pages error under adhoc mode

    Version 4.81 3/24/2004

    1.) Modify switch's access list to disable button while adding new entry
    2.) Fixed default route not deleted when set router to caused by buggy /bin/route, might need further debug on /bin/route

    Version 4.8 3/19/2004

    1.) Fixed setup wizard cannot detect our device after 30 minutes problem

    Version 4.7 3/15/2004

    1.) Updated help pages
    2.) Hunglin fix 802.1x problem and fixed port1 backdoor
    3.) Fixed [force port vid] bug
    4.) Fixed SNMP trap daemon will crash when plug in all interfaces problem
    5.) Added more check to web page for valid range and value

    Version 4.6 3/5/2004

    1.) Updated help pages

    Version 4.5 3/4/2004

    1.) Now generate 4 different WEP 128bit keys

    Version 4.4 3/4/2004

    1.) Change default username to admin instead of NULL and check username
    2.) Fixed 802.1x mac clone problem
    3.) Add close button to security window

    Version 4.3 3/2/2004

    1.) Fixed the "access list cannot delete when there is only one entry left" problem
    2.) Added range check for STP
    3.) Changed default QOS priority to high for non-wireless port

    Version 4.2 3/1/2004

    1.) Fixed setup wizard cannot detect the WET54GS5 issue

    Version 4.1 2/25/2004

    1.) Changed QOS default to disable storm filtering
    2.) Changed access list to old way, I tried to enhance performance in previous version but did not work

    Version 4.0 2/24/2004

    1.) Fixed SNMP and RMON web page problem
    2.) Added backdoor for 802.1x and access list on port 1
    3.) Change to gzip and remove boot delay added to work around HW problem, since it's already fixed

    Version 3.9 2/23/2004

    1.) add swutil 32,33 for setting Wireless Profile
    2.) GUI setting will trigger set_prismoid(DOT11_OID_PROFILES)
    3.) add b-only mode back

    Version 3.8 2/22/2004

    1.) remove boot delay but still use slower bzip2
    2.) merge with Hunglin's new security GUI and WPA fix
    3.) will not show buglist on GUI anymore

    Version 3.7 2/20/2004

    1.) fixed a lot of GUI based on Chris's feedback
    2.) fixed STP big packet problem using Onno's new MVC
    3.) fixed the mac address entering by checking there are 6 ":" check stp path cost or priority if they are in valid range

    Version 3.6 2/17/2004

    1.) Fixed ATU age timer setting problem
    2.) change to a smaller boot delay around 8 second
    power led will blink during upgrade
    3.) fixed 8021xrun bring up problem
    4.) kill 8021xrun, sysd and snmptraplog during upgrade
  2. Buggssy

    Buggssy Guest

    WET54GS5 WPA connectivity issue

    I purchased the WET54GS5 and it came with the v4.85 firmware out of the box. I am connecting to a WRV54G with WPA-PSK enabled. I can make a connection just fine with the bridge; however, it will not stay connected any longer that about 5 minutes. If I power cycle the bridge it will reconnect fine and work for about another 5 minutes or so. I have noticed that when it is not functioning properly it shows under the Wireless Status page that it is "scanning." There are many posts on the web about this issue and they all seem to be stating a WPA bug in the unit. I would rate this issue as a Status 2 since the wireless it is basically not functioning with WPA.

    Does anyone know if Linksys is aware of the problem and if they are going to fix it? If not, is there a third-party firmware available for the WET54GS5 and does it fix the problem? I would appreciate any response or help. I'm using the bridge on a different floor of my home and I need to expansion to support multiple systems for work.

    Thanks in advance,

  3. skydiver

    skydiver Guest

    What's happening is that the WET54GS5 is not reauthenticating when the WPA-PSK key renewal time is met. This time is set in your AP or router.

    I spent about 2hrs on the phone with Linksys this week, explaining the problem to each level of tech up to their 'senior tech.' The 'senior tech' at least had somewhat of a clue what I was talking about, but said that it was the first she head of it, and she opened a 'case id' up for it. She said that they'd have to do a test in their lab, and that they'd get back with me.

    I did a bit of searching today via Google, and I see that this problem (WPA-PSK) has been known since 08/2004.

    I also found a few more bugs... like certain characters in a WPA-PSK won't work on the WET54GS5, but they'll work on the WRT54G and WAP54G. I didn't even bring this up to Linksys.. took me long enough to get it through their skulls about the reauthentication problem.

    I'm not holding my breath. If they'd fix the firmware, this would be a kickass bridge.

  4. le_Chat

    le_Chat Network Guru Member

    WPA-PSK is finally fixed in firmware 4.91 !!!

    OK So Linksys finally fixed WPA !!!!

    We all know that WPA is irremediably broken in 4.85 as it can't stay connected for more than a few minutes. They fixed it in 4.90 (which was distributed as a beta only) but 4.90 had other issues.

    Now the real scoop is that it's FIXED in 4.91. Specifically "v.4.91, March 03, 2005"

    I've been running 4.91 for 2 days now with WPA-PSA TKIP with a 600 seconds (the minimum) key renewal interval and it works great.

    I have a WRT54G as access point and a Thinkpad on the network - all interact fine with the WET54GS5 now !!

    So all of you WET54GS5 users... go upgrade !!!

  5. nubby76

    nubby76 Network Guru Member

    4.9.1 upgrade question

    After upgrading the wet54gs5 to the 4.9.1 fw, I noticed that the unit's power light now always is blinking (meaning diag). It never goes solid. Not sure why, anyone else seeing this? Doesn't appear to affect wireless functionality, so the fw seems to fix the problems described by the fix readme. Just a minor annoyance, or sign of a new problem...?
  6. Silberfuchs

    Silberfuchs Network Guru Member

    I just tried the new firmware because I also had trouble using WPA PSK - but now it works fine. The power LED is also working as it should.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice