WGA54G configured with Belkin Pre-N router

Discussion in 'Other Linksys Equipment' started by donanddawn, Feb 4, 2005.

  1. donanddawn

    donanddawn Network Guru Member

    Hello. I bought a pair of the WGA54G to provide wireless G to my TiVos by a connection to a USB200M USB2.0 ether net adapter (as suggested by people on TiVo forums). However, I cannot get the game adapter to talk to my wireless network properly. I have turned off MAC filtering and WEP. I have disabled the Windows firewall. Based on some other suggestions, I connected the adapter to my router via ethernet for the configuration. While in the web-based configuration tool for the router, the tool sees the wireless network and connects to it. I see activity flashes on the wireless G light on the adapter. However, when I remove the ethernet and restart the adapter, it is no longer accessible via wireless. I cannot ping it. And if I connect the adapter to another computer, that computer does not have wireless access. The router uses an IP range of 192.168.2.xxx, so I set my adapter to

    Any suggestions are greatly appreciated. I am now on something like hour 7 trying to get this working :(
  2. helsten2

    helsten2 Network Guru Member

    I have the same problem trying to connect to a Linksys WRT54GS AP. No way! Have tried to switch off WAP and MAC filtering. NOP. With and without gateway. NOP.

    Found in another forum that this was actually a firmware problem on 1.10. If you are running 1.06 you should be OK. However, there is no way to 'go back' if you already upgraded (Linksys has removed 1.06 from their ftp server) ....

    Some people have been able to connect if they were running both the game adapter and the AP in mixed mode (didn't work for me , though).

    Any help is appreciated.

    Does anybody have a link to firmware 1.06?
  3. Doc

    Doc Network Guru Member

    Bit of a long shot, but have you thought about trying some sort of file-sharing program lto look for it?

    I know, I know. Unlikely, but you might be in luck...
  4. nubby76

    nubby76 Network Guru Member

    I chatted with one of the Linksys support techs and this is what they say:

    Dacanay, Dondi: Okay. I checked with our Escalation team if the previous firmware (1.06) is still available and unfortunately its not. What they told me was that to tell you to reflash the 1.10 firmware. After reflashing is complete, press and hold the reset button for 1 minute and then power it down for 30 seconds (pull the power from the device). Then turn it back on and reconfigure it and try again.
    Dacanay, Dondi: If it doesn't work, Linksys we'll replace it which has the older firmware.

    It was also noted that 1.06 should work with Xbox Live - 1.10 FW doesn't necessarily have to be applied to get you up on Xbox Live.
  5. donanddawn

    donanddawn Network Guru Member

    Got it working, but with different bridges

    Thanks for the info!!!

    I spent 7-8 hours (till 3am) with the Linksys game adapters and my Belkin Pre-N router and I never did get it working. I called Linksys support and I had tried everything they suggested. Their final suggestion was to return the game adapters to the retailer.

    I then ordered a pair of the SMC2870W wireless bridges, which I got cheaper than the Linksys adapters. They configured with no issues and I was able to get my first TiVo connected via DHCP (the Linksys adapter apparently required a static IP). Early testing of transferring a movie looks like the speed is greatly improved from my wireless B setup.

    I did have an issue that I want to share in case it might help others. I could not get the adapter to pick up the wireless network after I pulled out the ethernet cable that was connected to the computer for configuration. It kept dropping the connection. Then, by fluke, I removed the other end of that cable from the computer, and the adapter picked up the wireless signal again. I cannot explain it, and it may be unrelated, but that seemed to the the turning point. That may also be what stopped my Linksys adapters from working.

    I think I am set now. I can finally transfer movies with solid performance, and I can upgrade the security to WPA.
  6. ivtu

    ivtu Network Guru Member

    Maybe a hint

    When you configure your WGA54G with i.e. one Workstation or Laptop you might have two Network connections active on it. The first one (LAN-1) for the cable to which the WGA54G is physically connected, the second one (LAN-2) for the PCMCIA Wlan Card or PCI Wlan Card in your computer.
    Mostly windows can't switch dynamicly between these two connections. When both connections are activated and you get data through LAN-1 for the first configuration of the WGA54G, you have to disable LAN-1 afterwards (and often reboot your computer) to get a wireless conection to your device. Otherwise windows will still try to connect via LAN-1, even if the cable has disconnected and won't use the LAN-2 connection, even if it's active.
    On my Laptop I have also two Lan ports, but every time I work with it, only the one I need is active, the other one is deactivated. No problems with cable and cableless connection to the WGA54G still now ;-)
    Hope this may help you a bit...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice