WGA54G New Firmware Problem [FIX]

Discussion in 'Other Linksys Equipment' started by Pajap, Apr 9, 2005.

  1. Pajap

    Pajap Network Guru Member

    There seems to be some sort of problem with the new firmware for this device (v1.10). Stupidly I applied it to all3 of my devices without checking it worked and I am now left with3 non-functioning devices. Linksys support sucks! Had 3 seperate phone conversations with them today. They promised to send me the original firmware. Waited a while and it never arrive and so called them back and was told they do not have it. How can theynot have their own firmware? Why lie to me and say they are going to send it? They suggest I send them back to the supplier for a refund, wtf?
    The set-up program works, the browser interface works. Well, as far as the wired connection. The wireless keeps showing connected, then disconnected..... About a 40:1 ratio in favour of disconnected.
    Connect it to an xbox or KISS DVD Player and nothing. Was working flawlessly before the upgrade but I thought I would get me some xbox configuration support. Big mistake!

    Does anyone have any version of this firmware other than 1.10 they could post please?

  2. Pajap

    Pajap Network Guru Member

    Jeesh. Are Linksys support staff the most incompetent in the world?
    Four times they have now sent me links to the most recent firmare for the WGA54G even though I keep telling them it is broken and I only want the original firmware. Each time it is obviously a copy and paste from the last.
    Twice they send me links to the firmware for the WAG54G.
    I guess they must pay in peanuts because all their employees are monkeys!
    I swear I will never buy Linksys or Cisco kit again!
  3. oopsibrokeit

    oopsibrokeit Network Guru Member

    ftp site...

    try ftp.linksys.com and go searching for the appropriate stuff.

    linksys support is monkeys, but then thats what we are here for!!

    it's also worth installing netstumbler on one of your wireless clients to see if there is excessive noise on your signal.
  4. Pajap

    Pajap Network Guru Member

    Re: ftp site...

    This is what Linksys keep telling me and the firmware is not available there. And no disrespect but I am not new to the networking/computer hardware game so this is obviously the first thing I did. I have been doing network and hardware/software support for a great many years.
    I just spent over an hour on the phone to them (again!) and they are full of it. They reckon (John ID19522) that the firmware is not available. Apparently it was provided to them by a third-party and they are not allowed to use it anymore. Seems obvous to me they do not give a crap about supporting this product. I know if they give me back the original firmware it will all work again but they refuse and reckon they have no copies of it anywhere. Well this is obviously bull.
    I suppose the only option to me now is to RMA the piles of crap and hope the ones they send me have not been upgraded by some other poor sod!
  5. oopsibrokeit

    oopsibrokeit Network Guru Member

    seeing as how i've already insulted your intelligence once (I'm sorry, about that btw!)

    i'm possibly going to do it again. (because some people never learn) i've seen a problem very similar to your posted on another site, and it came down to them having open wep set at one end and shared key at the other.

    I now fully expect you to have tried that and be ready to pound my brains to a pulp for insulting your intelligence again. I'm sorry!!

    i am trying to find a copy of the firmware, and i think i have a friend who has one of the first version of that unit, which had v1.06 or 7 firmware. he reckons he's got the 1.08 binary somewhere which I think is the one you want.
  6. Pajap

    Pajap Network Guru Member

    Your not insulting my intellignce. But no, there is not misconfiguration issue. Sorry if I sounded curt t but after trying to get some sense out of Linksys support this weeeknd, I am pretty short fused. Apologies to you.
    I am 100% certain there is an issue with the firmware. It is the same with all 3 units and all 3 units were previously working before the upgrade (and working very well). I have tried every possible combination of holding in the reset button while powering up, powering down and while powered up. I have tried resetting in every way possible. I have flashed them several times and have even tried the US firmware (at Linksys supports suggestion). I even sent Linksys some screenshots. One taken with a unit showing disconnected, the other taken a few seconds later with the unit showing connected. It shows connected to the correct ssid but is showing as connected on channel 6 when wireless network is running on channnel 13 (at the time the screenshots were taken. I have also tried every other channel), which is also evident in the same screen shot. In the screenshot where it shows connected on the next refresh of the page it showed disconnected. Sometimes it will stay connected for up to 5 minutes before dropping the connection. All these times are when they are connected directly to my PC. Connect them to a device and nothing. I have tried no wep, 64-bit wep, 128-bit wep. I have tried 54g only and I have tried mixed. I have tried open system and shared key. Each time ensuring that all devices on the network were configured correctly and identical. I have several wap54g's also and a few pci cards. Everything connects with no problems. I am currently using the waps in place of the wga54g's and this is working flawlessly. I only wanted the wga54g's as they are considerably smaller than the waps and don't look qiuite so ugly on dispaly in the living room areas. Believe me there is no problem with the set-up or the steps I have taken to get these things working _again_.
    Now if you could get me some older firmare I would be _very_ grateful to you :) Thanks.
  7. Pajap

    Pajap Network Guru Member

    It Works :)

    I have persevered with contacting Linksys and have finally got a result. It got escalated through the channles and they have just emailed me the original firmware (US version though).
    I flashed one of my wgs54g's and it was all working straight away. Absolutely brilliant. I feel a bit guilty for calling them monkeys now but it did take several emails (including ones to the CEO of Linksys and Cisco) and about 4+ hours on the phone in total before it was resolved. At least we know they do listen if you pester them enough :)

    I have just emailed them back asking if it is OK to give this firware to others (I am guessing it is) or whether they will make it available on their site.
    So if anyone else have wga54g's that do not work (after a firmware update), watch this space!
  8. eminem2pac420

    eminem2pac420 Network Guru Member

    Papaj, can you help me out? I have the same problem as you. If you got it to work, could you tell me how you did it? Linksys sent me the firmware, but I couldn't get it to upload. Is there another way to "force" flash the original firmware?
  9. loccs

    loccs Guest

    WGA54G trashware

    If any body could send me the old firmware I would appriciate it. I have called linksys and they say they don't have it anymore. Pajap or eminem2pac420 please help.
  10. FlashPoint

    FlashPoint Network Guru Member

    It IS a firmware problem, which has been documented for some time now. Unfortunately, Linksys has never released a fixed firmware, and continues to NOT have the original 1.06 firmware available.

    The new 1.10 firmware breaks the Wireless Network Mode.

    Change the setting in your router's AND game adapter's configuration from G-Only to Mixed Mode and it will work.

    It'll be somewhat slower speed, but it will at least work.

  11. eminem2pac420

    eminem2pac420 Network Guru Member

    I would post the original firmware, but the max limit seems to be 128k. (firmware is 500+) So, if anybody wants it, I can email it to them. Contact me at
    eminem2pac420@hotmail.com Let me know in the subject what it's about.

    I should tell you that the original firmware did nothing for me, and my adapter remains non-functional. It seems to begin uploading, and then quickly quits out of it. If anyone knows how to force the upload, let me know asap.....I'm thinking about exchanging it with Linksys, but it will cost shipping. Doesn't this kind of thing qualify as a scam?
  12. eminem2pac420

    eminem2pac420 Network Guru Member

    ok, ive been getting crazy emails from people having the same problem that I had. What I had to do, and what I advise anyone with this problem, is to file a complaint with the BBB. It might sound like overkill, but Linksys' actions are unacceptable on all levels.

    Well, after countless emails to tech support, all they did was dick me around, and they'll most likely do the same to you. One time, they even sent me this unreleased firmware (it was like 3. something), that was under development for the adapter. That still did nothing, so they told me to file a rma which I had to pay shipping for.

    This kind of pissed me off because all I did was download an "update" from Linksys and it completely broke my adapter. So, I filed a complaint and some "special" guy contacted me, and after countless emails with him asking about free shipping, and what not, I ended up having to pay shipping and guess what they send me back? A refurb with the same problem causing firmware, that somebody else with the same problem sent it in, and for some reason, a Linksys technician finds nothing wrong with it.

    After that, they sent me a shipping label, and shipped me a brand new one after I demanded it. I sold that piece of shit, while I still could get decent $ for it. The whole Linksys thing took about 3-4 months of bullshit, and ended up with me losing about $10 for shipping.

    Coincidently, I had a problem with the Microsoft notebook wireless mouse receiver and I guess it was a well known problem like the Linksys thing. All it took was one email, a phone call, and fax, and they sent me a brand new mouse. Took less than two weeks from email, to brand new mouse in my hand. I didn't even have to ship in the old one. I just scanned the serials and faxed that in. That was one of the best service I ever got from a company.
  13. eminem2pac420

    eminem2pac420 Network Guru Member

    i see im still getting emails from people asking about the firmwares. None of them worked.....the original ones they sent me wasn't even the right extension.



    his name is jeff clevidence and he should be very familiar with this problem, so if everybody can bombard him with emails telling him how much this product sucks, it'll make me very happy.

    thanks and have a nice day...

    p.s. make sure they send u a brand new one instead of their normal refurb. refurbs are hard to sell.
  14. noname101

    noname101 Network Guru Member

  15. noname101

    noname101 Network Guru Member

    Here's how to get it to work:
    Download old firmware here.
    Now do the following:
    Load the new firmware.
    After thats done reset it:
    1] Press and hold the reset button for 30 sec.
    2] Unplug the power keep holding down the reset button for another 30 sec.
    3] Then, plug back the power keep holding down the reset button for 30sec.
    4] Release the reset button.
    5] Unplug it again and plug it back in

    Now reconfigure it after you get all settings right try clicking connect. If it doesn't work then unplug it and plug it back in. May need to unplug it and plug it back in more then once.

    If the above doesn't work try reseting your firmware this way
    Click start run then type in cmd then type in:
    tftp -i PUT wga54g_1.06_US_code.img

    With that ftp command you may need to specify the mode. Not using windows right now so I don't know.
    For linux you'd do:
    tftp -m binary -c put wga54g_1.06_US_code.img
  16. DRLive123

    DRLive123 Guest

    I'm sorry to bump an old thread, but I am new here and I am having the same problem, looking for the old firmware. The post above me had a link to it, but the link no longer works. Does anybody have this that they could send me?

    Thank You.
  17. cityhunter

    cityhunter Guest

    Can some please post the original firmware again, or pm me with a link.

  18. neoroony

    neoroony Guest

    make this a sticky!

    excellent work people, sorted my nightmare right out.

  19. Cashkeith

    Cashkeith LI Guru Member

    bump this thread helped me so much can u guys plz sticky this
  20. Toxic

    Toxic Administrator Staff Member

    ok nps
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice