What version of bios can I use for my WRT54GS v4?

Discussion in 'Cisco/Linksys Wireless Routers' started by enkrypt3d, Dec 29, 2005.

  1. enkrypt3d

    enkrypt3d Network Guru Member

    I've searched these forums and I've found nothing of much use for me. The downloads section for my router has only 2 of them and I've tried both which both have failed.


    I have tried every single one of these bios's and none work. What happens is this:

    (Btw using firefox or IE makes no difference in this issue)

    Also it makes no difference if i'm trying to upgrade it over HTTPS or HTTP. Both show same symptom.

    I have the router reset to defauts by holding down the button in the back. My PC is on a static IP of and the router is a of course...

    I browse for the *.bin file and click upgrade...... goes about this far:


    And goes to an "Upgrade are failed!" In perfect grammar mind you ;)

    Then I've let it sit there for a bit and click continue then the progress bar goes all the way to 100%


    Then a pop up windows says again "Upgrade are failed!"

    Yea like I didnt hear you the first time?

    The only thing that does work is the latest linksys firmware...

    Am I going to have to downgrade this to get Hyper or some other bios on here?

  2. enkrypt3d

    enkrypt3d Network Guru Member

    Come on guys give me some info here... I only see 3 available files for the WRT54GS Why is this? None of these work! Please help!
  3. sniffs

    sniffs Network Guru Member

    You arent doing this wirelessly are you? :p
  4. enkrypt3d

    enkrypt3d Network Guru Member

    No I am plugged directly into the router and have disabled wireless access to the management to the router.

    Do I have to downgrade to an older version of the linksys firmware then program it?

    Doing this over the web based manager doesnt seem to work... trying to get TFTP to work but not having any luck finding out how to do that .......

    from the windows command prompt i type:

    tftp -i put c:\wrtgs.bin and it keeps saying it doesnt like that command...... uhg!

    And what happened to all the firmwares that used to be available for this router!?!? This is the reason I bought this router because of the ability of hacking it...... but it seems linksys has put a stop to that... :(
  5. swinn

    swinn Network Guru Member

    Did you try HyperWRT Thibor 12? It now uses the v4 firmware and should upgrade with no problems. Before you would have to upgrade using DD-WRT mini generic and then upgrade to HyperWRT.

  6. enkrypt3d

    enkrypt3d Network Guru Member

    Can you pls link me to both of these you are talking about? ive tried what you're talking about and it doesnt work.......maybe im missing something? Do I have to use TFTP? Because doing it thru the web part never has worked for me
  7. 4EverGreen

    4EverGreen Network Guru Member

  8. dicion

    dicion Network Guru Member

    and yes, also try downgrading the linksys firmware before updating. I've heard reports that the newest firmware wont let you flash any third party firmware??? :???: :???:
  9. enkrypt3d

    enkrypt3d Network Guru Member

    where can I find the older firmwares from Linksys? The one's on their website only offer the latest :(
  10. enkrypt3d

    enkrypt3d Network Guru Member

    Ok so which one is the mini generic one??

    dd-wrt.v16 <DIR> 1 item 25-07-05
    dd-wrt.v17 <DIR> 1 item 25-07-05
    dd-wrt.v18 <DIR> 1 item 25-07-05
    dd-wrt.v19 <DIR> 1 item 25-07-05
    dd-wrt.v20 <DIR> 1 item 25-07-05
    dd-wrt.v21 <DIR> 4 items 25-07-05
    dd-wrt.v22 <DIR> 9 items 21-09-05
  11. swinn

    swinn Network Guru Member

    Click on dd-wrt.v23 and you'll see it. It's called dd-wrt.v23.mini.zip

  12. MattLL

    MattLL Network Guru Member

  13. madhatter

    madhatter Network Guru Member

    Does this mean that i don't have to use dd mini to flash my WRT54GS Ver4 first.

    Can i now just flash from stock linksys ver4 firmware to Thibor 12.
  14. Thibor

    Thibor Super Moderator Staff Member Member

    no, even though my latest is based on the v4 codebase, i have had to keep certain files from the older codebase so that v1-3 still works. flash dd-wrt mini generic onto your router, and from there flash my latest, that will do it. there is a guide on Hyperwrt.org's forum(step-by-step)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice