Who has got Wii to work?

Discussion in 'Tomato Firmware' started by davidw89, Jun 16, 2008.

  1. davidw89

    davidw89 Addicted to LI Member

    If you have got Wii to work PLEASE post your settings..

    I have tried:
    No password
    WPA2 AEO (or something)

    keeps getting 51331/51330 errors

    I have switched to channel 1/11 and still not working.

    I am guessing there's something to do with firewall/mac filtering. So iam asking you guys how do i put WIi's mac filter address into Tomato and how do i disable ALL firewall blocking TCP ports and how do i allow Wii access to all my UDp (DMZ). I am having trouble setting up Wii for DMZ too..

    oh yes i am using the latest version of tomato v1.19
  2. davidw89

    davidw89 Addicted to LI Member

    Oh yes my DHCP is disabled on the Buffalo (Tomato 1.19) because i need to connect it to my modem (which also has wireless but disabled), aka i have to set the same subnet/local ip address in order to get both the modem working with the buffalo.

  3. xcooling

    xcooling LI Guru Member

    wrt54g v3 + tomato mod 1.19

    Wii working 100% (WPA2 personal Encryption: TKIP/AES)
    Wireless Mode: Access Point

    Been working with all versions of tamato i have used over the last 7 months
  4. aspoon

    aspoon LI Guru Member

    I've had no problems with my Wii connecting to my Tomato running on the good ol' wrt54g, and that's with WEP enabled.

    Perhaps you should start with the basics -- reset your advanced wireless settings to default, no security, and start from there. If that works, try moving onto more secure settings.

    Just for the sake of testing, maybe place them in the same room and turn off your other devices that may interfere with it. (your 2.4GHz cordless phone, for example) I'm not sure if it helps, but make sure your directional antenna are not pointing at your Wii -- transmission is best at right-angle to your directional antenna.
  5. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Working here. WPA Personal, dhcp but do have the Wii assigned via static dhcp. It works when it back of house and accessing via wireless AP, in front room when accessing via slave wds router.
  6. GhaladReam

    GhaladReam Network Guru Member

    Wii working great, it's never had a problem for me.

    WPA2 Personal Mixed AES/TKIP, Channel 10.
  7. dvd-guy

    dvd-guy Guest

    Try mixed mode. Earlier Wii units had old wireless chips, so they don't operate in G only mode.
  8. 4char

    4char Network Guru Member

    I'm setting router to G only with WPA/WPA2 Personal (TKIP/AES) and it works fine with Wii. Try setting the Preamble to long.
  9. dvd-guy

    dvd-guy Guest

    Mine also works with G only, but several reports from when the Wii was introduced suggest setting the mode to Mixed. Even on the Wii website, the FAQ says to use mixed mode.
  10. xcooling

    xcooling LI Guru Member

    I run mine with no problems in mixed mode.

    Does ur Wii have 3.1 firmware ?
  11. ng12345

    ng12345 LI Guru Member

    why did you disable dhcp?

    you can set the router's wan ip without disabling dhcp on the lan

    also, if you did disable dhcp did you make sure to give your wii a static ip (in the wii menu).
  12. erwall

    erwall LI Guru Member

    Got my Wii on w/no problems on the first try on an access point that's WDS'd to my main router. Both are Buffalo WHR-G54S's, WPA, AES, G Only, Channel 8. Haven't had a single connection problem in 6 months.
  13. njeske

    njeske Network Guru Member

    my wii works for me. WPA2 Personal w/ AES encryption. the wii finds the network, connects just fine, and gets an IP via DHCP. no issues to report at all.
  14. ndoggac

    ndoggac Network Guru Member

    What DHCP are you talking about being disabled? There's external DHCP to acquire the WAN port address from the modem, and then there's internal LAN DHCP to provide local clients with an address. If you have LAN DHCP turned off, and trying to acquire an address on the Wii, it will not work. Try setting a static IP, Gateway, Subnet and DNS in the Wii.

    I have long preamble set, channel 11, G only, WPA2 with AES encryption. Also make sure your wireless filter is disabled, or if it is enabled, add your Wii's MAC address to it....double check this setting to make sure you're not blocking clients in the list instead of allowing them.
  15. TexasFlood

    TexasFlood Network Guru Member

    All my wireless stuff is set to default (including long preamble) except SSID, security to WPA Personal + AES, Access point + WDS with some WDS links defined.

    My primary LAN router has DHCP enabled and you need this unless you're setting static IP/GW/Subnet/DNS on the Wii.

    I have read a variety of stories about early units only connecting in 802.11b or 802.11b/802.11g mixed mode. Mine originally would not connect in 802.11g-only mode originally but does now after multiple updates.

    If you haven't updated you Wii (and you probably haven't if you can't get connected), try mixed mode or maybe even try 802.11b. Once you get connected then you can update and all modes should work.
  16. sjc80

    sjc80 Addicted to LI Member

    I've been using my Wii (bought on launch day) with WPA2 PSK and AES running in mixed mode on channel 3. While I've been experiencing random router reboots (still haven't isolated the problem), the Wii connects fine.

    If I remember correctly, WiiConnect24 also had to be enabled to connect to the Internet.

    If you've disabled DHCP, then (as was indicated by other members) you must assign IP address (eg,, subnet mask (eg,, gateway address (eg,, and DNS server addresses (check your router's config) manually.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice