Why has transmission stopped working?

Discussion in 'Tomato Firmware' started by Bird333, Dec 15, 2013.

  1. Bird333

    Bird333 Network Guru Member

    As far as I know I haven't done anything. It doesn't start when the router boots and I can't get it to start manually. This is the entware version of transmission not the built in transmission. I am running Shibby 114 on a Asus RT-N66R. This is the S88transmission script that should start transmission.
    ARGS="-g /opt/etc/transmission"
    . /opt/etc/init.d/rc.func
    This is the log from router startup/reboot
    Dec 14 20:49:36 RT-N66R user.notice 0: Started transmission-daemon from .
    This is the log when I manually try to start it
    Dec 15 07:14:18 RT-N66R user.notice 0: Failed to start transmission-daemon from .
    Last edited: Dec 15, 2013
  2. leandroong

    leandroong LI Guru Member

    Tomato FW does not obey entware init script, located on /opt/etc/init.d. Padavan FW does.
    What I can suggest, use Shibby bittorrernt client GUI to manage your transmission optware. Put all configuration there and enable it.
  3. Bird333

    Bird333 Network Guru Member

    You don't understand. This was working fine with Tomato but now has stopped working.
  4. koitsu

    koitsu Network Guru Member

    @Bird333 do you have Entware installed at all? You could opkg install strace and then do strace -o /tmp/out -f transmission {flags and arguments to transmission} and provide the /tmp/out file here, it might shed some light on what the thing is doing/failing on. If it's an application that uses kernel threads, however, I probably can't debug it.

    I should note that any kind of firmware upgrade can in fact result in kernel ABI semantic changes or system library (ex. libc) semantic changes, which can make third-party programs behave oddly.

    If transmission comes with the TomatoUSB firmware you're using, then yeah, the firmware maintainer needs to figure out what's broken/help you.
  5. Bird333

    Bird333 Network Guru Member

    Yes I have entware installed. It is entware's transmission I was using. I'll try your suggestion.
  6. Bird333

    Bird333 Network Guru Member

    I am finally getting back around to this. I tried to install 'strace' but I couldn't so I ran an 'update'. After I ran the update it seemed that 'strace' wasn't even available. I think something is wrong because the list of available entware packages is really short. Here is the output I got.

    root@RT-N66R:/tmp/home/root# opkg install strace
    Installing strace (4.7-1) to root...
    Downloading http://wl500g-repo.googlecode.com/svn/ipkg/openwrt/strace_4.7-1_entware.ipk.
    wget: server returned error: HTTP/1.1 404 Not Found
    Collected errors:
    * opkg_download: Failed to download http://wl500g-repo.googlecode.com/svn/ipkg/openwrt/strace_4.7-1_entware.ipk, wget returned 1.
    * opkg_install_pkg: Failed to download strace. Perhaps you need to run 'opkg update'?
    * opkg_install_cmd: Cannot install package strace.
    root@RT-N66R:/tmp/home/root# opkg update
    Downloading http://wl500g-repo.googlecode.com/svn/ipkg/openwrt/Packages.gz.
    Inflating http://wl500g-repo.googlecode.com/svn/ipkg/openwrt/Packages.gz.
    Updated list of available packages in /opt/var/opkg-lists/openwrt.
    root@RT-N66R:/tmp/home/root# opkg install strace
    Unknown package 'strace'.
    Collected errors:
    * opkg_install_cmd: Cannot install package strace.
    root@RT-N66R:/tmp/home/root# opkg list
    busybox - 1.19.4-7
    findutils - 4.5.11-1
    findutils - 4.5.12-1 - GNU Find Utilities are the basic directory searching utilities of the GNU OS.
    ldconfig - 0.9.32-4
    ldconfig - 0.9.32-6 - Shared library path configuration
    libc - 0.9.32-6 - C library
    libcurl - 7.29.0-1a
    libevent2 - 2.0.21-1
    libffi - 3.0.11-1
    libgcc - 4.6.3-4
    libgcc - 4.6.4-6 - GCC support library
    libidn - 1.18-1
    libminiupnpc - 1.8-1
    libopenssl - 1.0.1e-2
    libpthread - 0.9.32-4
    libpthread - 0.9.32-6 - POSIX thread library
    librt - 0.9.32-4
    librt - 0.9.32-6 - POSIX.1b RealTime extension library
    librtmp - 2.4-20121209-1
    libstdcpp - 4.6.3-4
    libstdcpp - 4.6.4-6 - GNU Standard C++ Library v3
    msmtp - 1.4.31-1
    python - 2.7.3-2
    python-mini - 2.7.3-2
    transmission-daemon - 2.82-1
    transmission-web - 2.82-1
    uclibc-opt - 0.9.32-4
    uclibc-opt - 0.9.32-5 - uclibc-opt is a metapackage to install Entware basic libraries.
    zlib - 1.2.8-1
  7. koitsu

    koitsu Network Guru Member

    Works here (and I can confirm the need for opkg update). However, note that my package repository is different from yours (note the URL it downloads from compared to yours):

    root@gw:/tmp/home/root# opkg list-installed | grep strace
    strace - 4.7-1
    root@gw:/tmp/home/root# opkg remove strace
    Removing package strace from root...
    root@gw:/tmp/home/root# opkg list-installed | grep strace
    root@gw:/tmp/home/root# opkg install strace
    Unknown package 'strace'.
    Collected errors:
    * opkg_install_cmd: Cannot install package strace.
    root@gw:/tmp/home/root# opkg update
    Downloading http://entware.wl500g.info/binaries/entware/Packages.gz.
    Updated list of available packages in /opt/var/opkg-lists/openwrt.
    root@gw:/tmp/home/root# opkg install strace
    Installing strace (4.7-1) to root...
    Downloading http://entware.wl500g.info/binaries/entware/strace_4.7-1_entware.ipk.
    Configuring strace.
    root@gw:/tmp/home/root# opkg list-installed | grep strace
    strace - 4.7-1
    root@gw:/tmp/home/root# strace -h
    usage: strace [-CdffhiqrtttTvVxxy] [-I n] [-e expr]...
                  [-a column] [-o file] [-s strsize] [-P path]...
                  -p pid... / [-D] [-E var=val]... [-u username] PROG [ARGS]
       or: strace -c[df] [-I n] [-e expr]... [-O overhead] [-S sortby]
                  -p pid... / [-D] [-E var=val]... [-u username] PROG [ARGS]
    -c -- count time, calls, and errors for each syscall and report summary
    -C -- like -c but also print regular output
    -d -- enable debug output to stderr
    -D -- run tracer process as a detached grandchild, not as parent
    -f -- follow forks, -ff -- with output into separate files
    -F -- attempt to follow vforks (deprecated, use -f)
    -i -- print instruction pointer at time of syscall
    -q -- suppress messages about attaching, detaching, etc.
    -r -- print relative timestamp, -t -- absolute timestamp, -tt -- with usecs
    -T -- print time spent in each syscall
    -v -- verbose mode: print unabbreviated argv, stat, termios, etc. args
    -x -- print non-ascii strings in hex, -xx -- print all strings in hex
    -y -- print paths associated with file descriptor arguments
    -h -- print help message, -V -- print version
    -a column -- alignment COLUMN for printing syscall results (default 40)
    -e expr -- a qualifying expression: option=[!]all or option=[!]val1[,val2]...
       options: trace, abbrev, verbose, raw, signal, read, or write
    -I interruptible --
       1: no signals are blocked
       2: fatal signals are blocked while decoding syscall (default)
       3: fatal signals are always blocked (default if '-o FILE PROG')
       4: fatal signals and SIGTSTP (^Z) are always blocked
          (useful to make 'strace -o FILE PROG' not stop on ^Z)
    -o file -- send trace output to FILE instead of stderr
    -O overhead -- set overhead for tracing syscalls to OVERHEAD usecs
    -p pid -- trace process with process id PID, may be repeated
    -s strsize -- limit length of print strings to STRSIZE chars (default 32)
    -S sortby -- sort syscall counts by: time, calls, name, nothing (default time)
    -u username -- run command as username handling setuid and/or setgid
    -E var=val -- put var=val in the environment for command
    -E var -- remove var from the environment for command
    -P path -- trace accesses to path
    root@gw:/tmp/home/root# cat /opt/etc/opkg.conf
    src/gz openwrt http://entware.wl500g.info/binaries/entware
    dest root /
    lists_dir ext /opt/var/opkg-lists
    Looks to me like some URLs changed. Validation:

  8. lancethepants

    lancethepants Network Guru Member

  9. leandroong

    leandroong LI Guru Member

    or performing 2x "opkg update and okpg upgrade"
  10. Bird333

    Bird333 Network Guru Member

    After I ran the new entware installer and upgraded my installed apps, it is working again. It did complain about some directories/files already existing. One thing though, is there a setting for transmission to automatically update the blocklist file if it is too old? I thought this was the case but my list was from Jan 2013 and it didn't update it.
    Last edited: Apr 23, 2014
  11. stillsober

    stillsober Reformed Router Member

    I'm using tomato inbuilt transmission (hdd is NTFS, can't install entware right?)

    I've found that the some torrent can only run 100-400 kbs on tomato but it can run at 1mb+ when run from qbittorrent on laptop, dl speed limit is max(no limit) on both. Is there some magic configuration setting on transmission that I'm not aware of? Also only getting few peers on transmission (limit set at 60,getting maybe 8)whereas the same torrent can have 90+ peer on qbittorrent
    Both set to tolerate encryption
    I don't need to forward port of for transmission on tomato right?

    How can I diagnose what's going on?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice