Windows Media Center cannot get IP

Discussion in 'Networking Issues' started by MaxWilder, Mar 16, 2008.

  1. MaxWilder

    MaxWilder LI Guru Member

    The computer was working fine for about 6 months, then the internet connection started getting inconsistent. After a week or two, I could not get an IP no matter how many combinations of newb troubleshooting techniques I used. IPCONFIG release and renew, rebooting, reinstalling the NIC driver, everything. I even tried bypassing the router and plugging it straight into the cable modem. Nothing worked.

    It was a built-in NIC, on an ASUS M2A-VM HDMI motherboard. I figured the NIC chip died, so I bought a new Linksys EG1032 PCI Gigabit ethernet card. I know the WRT54GS isn't gigabit, but I might upgrade someday.

    Anyway, the card didn't work at first, but after a couple reboots it started working and was fine for about two months. Then it started to lose the IP address as well. I mean that when the computer boots up, Windows just sits there for five minutes and declares that it can't get a connection. But it can tell whether a cable is plugged in or not. I discovered that while testing different cat-5 cables.

    Now I've switched to the Tomato firmware to try to get a little more info, and sure enough, whenever I do an IPCONFIG /RENEW, the computer shows up in the device list. (I can see it from another computer on the router.) But the media center pc doesn't recieve an IP address. It's the right MAC address for the media center pc, so I know I'm not getting it mixed up with another device. I've checked all the Windows settings, and they're all on Automatic DHCP, which has always worked in the past. I even tried shutting off the Windows Firewall, nothing helps.

    Every other device I own works fine: a Windows XP pc, a Windows 2000 pc, an Xbox 360, a Wii (through wi-fi), and a PS3. Not a hicup from any of them. So this has got to be a Windows MCE problem, right?

    And now, as I write this, the damn thing started working again. I'm so confused. After rebooting the last time to double check the motherboard model (it was about four reboots after switching to Tomato, and after a dozen or so release and renews during that time), the ipconfig brought up the correct settings. It very slowly loaded up a web page confirming my last Firefox update. Then worked, then I was able to refresh other tabs that had failed at first, and they slowly but surely started working. Does anybody have any idea what is going on with this thing?
  2. MaxWilder

    MaxWilder LI Guru Member

    Now it seems to be getting sporadic net access. I just can't figure out what might be doing this. I'm going to start analyzing the software now. It's a clean system, no downloaded software aside from Firefox and a codec or two. And it uses AVG for virus scans. Maybe I'll do a full OS reinstall. It just makes no sense.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice