Windows Messenger UPNP WRT54G XP SP2 2.04.4 Problem!

Discussion in 'Cisco/Linksys Wireless Routers' started by fairyliquidizer, Aug 26, 2004.

  1. fairyliquidizer

    fairyliquidizer Network Guru Member


    I have a Linksys WRT54G version 1 hardware running 2.04.4 and am having problems with MSN Messenger file transfers. Port forwarding doesn't seam to fix the problem. I have tried turning off the firewall, using the DMZ, all sorts and no joy.

    I am running XP SP 2 but have the same problem with my wirelessly connected laptop which is on old school SP1. The gateway detection and UPNP services seam to be installed however:

    1. messenger says "You are currently connected to .NET Messenger Service using a direct connection (no firewall)" on desktop and when connected laptop

    2. My internet gateway is described under network connections ar "Internet Connection" with a descriptions of "shared connection on another computer"

    3. I have installed the option for Icons for networked UPNP devices but My Network Places doesn't show any.

    The UPNP service is enabled, I am currently running the SPI firewall on the WRT54G and no software firewalls. I have tried (and hated doing it) no firewall!

    Any ideas how to get this UPNP stuff working?

  2. Esquire

    Esquire Mesquire Staff Member Member

    A) MSN Messenger file transfer doesn't require UPnP, only audio does.

    Just what kind of problems are you experiencing?

    B) Assuming you have installed UPnP User Interface (is that what you are trying to say in point #3?) on your Windows XP, the presence of Internet Connection indicates your Windows XP's UPnP Discovery is working. The question is what is its status shown in Network Connections? It should say Enabled (for pre-SP1 and SP1) and Connected for SP2 (see attached image below).


    C) To what type of broadband connection are you subscribed? Cable or DSL/ADSL/VDSL?

    Since your WRT54G is already on 2.04.4, UPnP is already enabled when booting up - what happens to the Internet Connection status when you reboot the router?
  3. fairyliquidizer

    fairyliquidizer Network Guru Member

    From your URL:
    "# Currently, certain extended features of MSN Messenger, such as voice conversations and file transfer, might not work behind Internet Connection Sharing applications and hardware (often called NATs). Basic functionality such as signing in, instant messaging, and checking e-mail should not be affected at all.
    # File transfer and audio or video conversations will fail if both you and the person you are communicating with are on computers that have Windows XP ICS NATs. MSN Messenger fails to detect this type of NAT as a Universal Plug-n-Play (UPnP) NAT."

    However I am behind a UPNP firewall/NAT Router so it should work

    Port forwarding isn't allowing messenger to receive files on my machine(s). I even checked the list of ports with Linksys and it isn't working. Even turning off the firewall isn't enabling me to send files via messenger because of the NAT Traversal issue.

    The main one is messenger a secondary one that UPNP wont help with is problems with hosting C&C Generals. The performance when I host is very POOR.

    Oh I have internet connectivity fine it just doesn't automatically open ports (and this includes voice).


    Cable (Blueyonder, UK).

    I am just off the phone to Linksys and they have said that the symptoms I am having are rare but are indicative of a hardware fault and I should return my router to the place where I bought it. However I am out of warranty so it looks like I either live with the issues or buy a new router.

    Any ideas?


    PS-PM me if you'd like to help test this Esquire :)
  4. Esquire

    Esquire Mesquire Staff Member Member

    Yes, it definitely should. In fact, I used to perform file transfer and video (w/o audio) without UPnP, and with no performance degradation. The URL I posted is merely for your reference about what issues are involved with MSN Messenger.

    Ahhh.... I don't have any experience with this - I only run my private FTP server through my router and UPnP works every time I load it - it opens up the necessarily ports (command and data ports) for people to log in.

    It does look like your router could be faulty - MSN Messenger should report the presence of the UPnP connection since Windows can detect it as well. This is what my MSN Messenger is reporting. Yours should be similar but not necessary the same.

    • [​IMG]

    Have you tried manually configure the UPnP ports? If not, try this. Right click Internet Connection, select Properties, click Settings button, then configure which ports to manually, then test to see if it is opened with (change the port 21 to whatever port you wish to test) - your server needs to be running and online ready for access for this test to work. The result should say the port is Open.

    I have to do this when I have to reset my router, and all UPnP settings are lost and I have to manually configure it for my FTP server.

    Since you are on SP2, you should also check your Windows Firewall setting if you are using it. Have you enabled the UPnP Framework under the Exceptions tab? I haven't noticed a difference on mine, but you should enable it just in case it works in your case.

    A rare possibility is your ISP is intentionally blocking access to your ports - it is not unheard of, and certainly in practice with many of the ISPs where I reside currently, especially since they don't want users hogging the bandwidths with their servers or P2P file sharing apps. You should see if you can get a written confirmation from your ISP about blocked ports.

    PS. Is your nickname in any reference to "The Fairy Liquid"? [​IMG]
  5. fairyliquidizer

    fairyliquidizer Network Guru Member

    I assume you noticed what it says in my similar screenshot above.

    This is a great tip! Thanks :) Basically I get stealthed (even though Block WAN Requests is OFF for my WRT54G). If I set up Port forwarding on the router I get Closed. Bah!

    The SP2 Firewall is disabled.

    My friends are on the same ISP and no problem! :-(

    It's a play on words, one reason is that their is a famous washing liquid called Fairy Liquid here the other is that there was a little known serial killer where I live which the Police secretly called the Fairyliquidizer.... I play online under this tag.

    Once again thanks,
  6. fairyliquidizer

    fairyliquidizer Network Guru Member

    Fixed it! MSN Messenger works fine! It's just Windows Messenger that doesnt!
  7. Esquire

    Esquire Mesquire Staff Member Member

    Hahaa. I didn't notice what your screen capture was showing Windows Messenger (the .NET Messenger Service reference). :oops:

    Windows Messenger doesn't support UPnP - there is no fix.
  8. fairyliquidizer

    fairyliquidizer Network Guru Member


    Thanks for all your help! I was going nuts trying to fix it, however I have bit the bullet and gone MSN and it works (I didn't realise the Windows Messenger didn't do UPNPN).

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice