Windows XP Service Pack 2 Woes

Discussion in 'Networking Issues' started by mab, Sep 3, 2004.

  1. mab

    mab Network Guru Member

    I have a WRT54G 1.1 running 2.04.4 Linksys Firmware and a
    Sony Vayo FX-702 with WPC54G PCMCIA card running XP Home SP1
    I use WPA TKIP security.

    It was all running OK with some occasional disconnects. now and then.
    I recently upgraded to SP2 and there the problems began. :(

    The wlan shows up and connects but does not grab a DHCP address any more. Creating a fixed address solves this part, but when I try to ping
    the lan or router, there is no traffic possible. :cry:

    Basically, the network shows up as connected and running but no communication is possible, completely dead.
    I disabled the firewall stuff, still nothing.
    Disabled WLAN security, still nothing.

    A chat with online Linksys support solves the mystery.
    There seems to be a problem in the driver of the WPC54G card in SP2
    No indication given when this will be solved.
    To double check this, I rolled back to SP1 yesterday
    All WLAN traffic is back to normal now. :D

    Anyone who got this combination working in XP SP2 ?

  2. Esquire

    Esquire Mesquire Staff Member Member

    All my computers have been upgraded to SP2 without a glitch. Wireless connection seems to be a tiny bit more steady - probably due to the fact that with the update IEEE802.1x Authentication is not needed for WPA-PSK.

    I have seen your situation before, but not because of SP2.

    Presumably your WPC54G driver is up-to-date (v3.30.15)?

    Have you tried using WEP and see if the situation improves?

    Have you also tried unplugging your WPC54G, wait about 20-30 seconds then reinsert the card? This works on my notebooks.

    Good luck.
  3. mab

    mab Network Guru Member

    I tried all authentication methods and that's not really the problem
    The problem is there is really no TCP traffic possible on the interface.

    A fixed adress configuration gave me a connected lan without
    any traffic possible

    No Ping, No DNS, No traceroute , just dead.

    I rolled back SP1 and all became normal again.

    Interesting is the following chat I had with linksys online support:
    I upgraded to XP SP 2 and the WPC54G does see and connect the network, but does not get a DHCP address any more.
    I have a WRT54G WLAN Router wit latest firmware applied.



    Linksys Support: Welcome to Linksys Live Tech Support.
    Linksys Support: Possible that the SP2 that you downloaded causes the problem.
    Me: I have installed the SP2 update and it worked without errors.
    Me: Before the SP2 update it all worked
    Linksys Support: You can try doing a system restore on your computer, like restoring it on an earlier time when you haven't installed the SP2.
    Me: The Network packet counter is updated, it sends a DHCP request , and gets something back which is not interpreted
    Me: Yes, I am about to rollback SP2 to SP1 to check if that's the case, but I hope there is a more permanent solution than sticking to SP1.
    Linksys Support: One moment please...
    Linksys Support: basically we are really having problems with the SP2, our developing team is trying to create a new driver that will work with SP2
    Me: Any ideas when it's ready for public release ?
    Linksys Support: No, possible a couple of month.
    Me: Oh, no :-( Bad news.


  4. Esquire

    Esquire Mesquire Staff Member Member

    Just out of curiosity, did you update to SP2 with the WPC54G inserted? I downloaded the 266MB network installation and updated using it offline without any network connection or peripherals attached.
  5. mab

    mab Network Guru Member

    I updated with both the UTP Lan and the wireless active with the full download version from MS. Windows Update did not pull it due to busy servers I guess.

    Anyway, the rollback worked, and I intend to stick with it until Linksys
    releases a new driver for the WPC54G

  6. mab

    mab Network Guru Member

    Problem SOLVED!

    After a more or less related problem on my boss W2K Laptop at work
    (Lots of Instabillities and a error log of the embedded firewall in the VPN SW)
    I finally found the real problem of the W2K WLAN problems

    I'ts CISCO's VPN Ver. 4.0.3D software

    I removed this stuff and applied SP2 and BANG, it finally worked
    I get a DHCP addres on the WLAN card and traffic on the wlan card works now.

    Strange that it did not influenced my regular 100Mb LAN adapter.
    Anyway , I'm a happy camper now :)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice