Windows XP to NSLU2 Network Browsing Very SLow

Discussion in 'Cisco/Linksys Network Storage Devices' started by GeekStarPilot, May 28, 2006.

  1. GeekStarPilot

    GeekStarPilot LI Guru Member

    I hope the collective wisdom of the forum can help me with my NSLU2 problem.

    I have a NSLU2 running firmware V2.3RA5 and 1 x Maxtor OneTouch 250GB connected to USB port 1.

    NSLU2 is connected to a 100Mbps LAN with two Win XP SP2 PCs.

    Workgroup and other LAN settings on the NSLU2 appear to be correct.

    Network browsing to shared folders between the Win XP PCs on the LAN work very quickly...just like they were local folders.

    My problem is that I am experiencing extremely slow network browsing from either on the Win XP PCs.

    Example of the slowness are:

    1) I open Network Neighbourhood and when I click on the icon for the NSLU2 device it can take up to 3 minutes for the icon to highlight.

    2) When I double-click on one of the shared folder icons withing the NSLU2 it takes about 1 minute for the folder to open.

    In short basic browsing of folders and files on the NSLU2 is unusably

    The problem seems to only be related to network browsing and not necessarily speed of file transfer. I am getting good (for a unmodified NSLU2 at least) file transfer speeds when transferring files either by FTP or Windows file sharing.

    I hope I can resolve this problem because at the moment my NSLU2 is basically unusable.

    Thanks in advance to all who reply.

  2. d__l

    d__l Network Guru Member

    Have you tried power cycling all routers and switches that connect the NSLU2 and PCs? I've had the problem that you describe and a power cycle of the intervening equipment cures it.
  3. GeekStarPilot

    GeekStarPilot LI Guru Member


    Thanks for your suggestion.

    I powered down all network devices on my network (including the NSLU2), waited the obligatory short period of time, and turned everything back on starting at the DSL modem and finishing with the NSLU2.

    I opened "My Network Places", selected "View workgroup computers" and then double-clicked the icon for the NSLU2. It took 1min 55sec to present the available shared folders. I then double-clicked one of the shares and it took 1min 10sec to open the folder.

    It appears that this was not the solution to my specific problem.

    Any other suggestions would be appreciated as I'd really like to be able to use my NSLU2 more effectively.

    Thanks again to all who reply.

  4. d__l

    d__l Network Guru Member

    Sorry that this didn't work for you. When I had those access lags, they were only intermittent. If I immediately re-accessed the drive or folder after the lag, the access would be prompt and would remain prompt for hours afterwards when the access lag would suddenly re-appear.

    Now that I re-read your description, I see that you are also having the lags when accessing files from within the NSLU's GUI. This was never part of my problem.

    Is your access alway slow or has it ever been faster?

    Something that I have noticed is that when I have written/erased/read about 10,000 files to the NSLU2, the subsequent reading of files seems to slow down until I reboot the device. I don't think this applies to your directory access problem though but you might give it a try.

    Have you ever run a scan disk? I know that the NSLU2 counts the number of disk accesses and will enter a read-only mode if a scan disk isn't run periodically. Perhaps there is a disk error that is slowing your directory access?
  5. GeekStarPilot

    GeekStarPilot LI Guru Member

    Problem Solved.

    I double checked everything and still had the slow network browsing problem.

    I decided to risk a phone call to Linksys Technical Support to see if they had any answers.

    Firstly I must say I was pleasantly surprised with the quality of the technical support.

    Second, after explaining my problem, what i had done to try and fix it and a few checks tht they asked me to carry out.

    They came to the conclusion that my NSLU2 must be faulty at the hardware level. Fortunately it was still under warranty and they offered to replace it and set up an RMA for me.

    I took my sick NSLU2 back to my retailer and they replaced it straight away.

    I came home. Installed it, configured it, reformatted the drives (just in case) and gave it a try.

    Network browsing in Windows now only takes a couple of seconds for each double-click to a new folder / share.

    Go figure.

  6. d__l

    d__l Network Guru Member

    Glad it got fixed for you. Too bad there isn't a better way to diagnose hardware problems like these than just flogging around looking for configuration problems/solutions until the hardware is suspected as a last resort.
  7. Helevitia

    Helevitia Guest

    I have had my NSLU2 for a few years now and have had this problem 3 times now. It is very annoying and nothing seems to fix the problem. I have to move all of the data off of the drive, format the drive, set the NSL back to default and everything works again...for awhile. I searched for a fix a year ago with nothing. This is the first thread I've seen on this issue. Interestinly, I have the exact same HDD as the original poster. Incompatibility issue? Anyway, just thought I'd post that someone else has seen this problem, actually it currently is a problem and very annoying since all of my music, pictures, and backups are on the network drive. I want to upgrade to something else, but I'm broke right now :(
  8. LordFlux

    LordFlux Network Guru Member

    I highly recommend putting the NSLU2 and additional hard drive(s) on a UPS if you have not already. I was having some intermittent lock-ups and slow downs with the unit until I placed it on a UPS. Our house is old and the electrical isn't up to snuff (using my laser printer causes a surge). I've had it on a UPS now for about a year and a half and haven't had a single problem.
  9. sdubose99

    sdubose99 LI Guru Member

    I had the same issue... Maxtor USB2.0 160GB drive... my Music folder is 70GB and takes a long time to open through the Slug.

    Linksys tech support recommended a change today involving my Linksys wireless G router as follows. This improved things dramatically although there is still about a 28 second lag to initially browse the folder. Smaller folders open much faster...

    FWIW, and YMMV.


    Actually all we have to do is lower the MTU settings of the router to 
    1300 then change the advance wireless settings. Set the Beacon Interval 
    to 50, RTS and Fragmentation Threshold to 2304.
    1. Open Internet Explorer Browser and type on the address 
    bar, hit GO or enter.
    Leave the username blank and type admin as the password.
    2. Click on the Wireless Tab. Set the wireless network mode to mixed.
    For the wireless channel, change it to 11., The SSID broadcast should be 
    enabled. Then click on save settings.
    3. Click on the advance wireless settings sub tab.
    Set the Beacon Interval to 50, RTS and Fragmentation Threshold to 2304, then 
    save the settings
    4. Click on the Setup Tab.
    Look for the MTU. Set it to Manual and change the size to 1300.
    Then Save the settings. Once everything is saved. Please do a power cycle. 
    Power Cycle
    1. Shut down PC's, router and the modem for one minute.
    2. Power on modem first, then the router and lastly your PC's.
    Note: Please make sure that the lights on the modem are stable before you 
    power the router on.
    MTU is the Maximum transmission Unit of the router. We lower it down to 
    prevent packet loss that causes slow connection and eventually disconnects. 
  10. hilliard

    hilliard LI Guru Member

    Directory browsing is very very slow...

    The solution to my long-standing "slow browsing" problem was solved by the steps proposed in the reply posted above by sdubose99 on 9/11/06.
    So, many thanks sdubose99....
  11. Toxic

    Toxic Administrator Staff Member

  12. fshagan

    fshagan Guest

    I had a similar problem ... it took about 2 minutes to connect when first mapping the NSLU2 drive in XP. It didn't matter if I was mapping from within Network Neighborhood or via the command line using the NET USE command. If the mapping was "persistent", then the log on time was extended by that two minutes when I logged on next, and log off was also very slow.

    I don't know why this helped, but removing the DNS information from the NSLU2 configuration screen solved the "slow to map drive" problem.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice