WinXP Networking: Missing Advanced button on TCP/IP Properties on wireless adapter. Any suggestion

Discussion in 'Networking Issues' started by adamcole, Sep 17, 2007.

  1. adamcole

    adamcole LI Guru Member

    I'm almost 100% positive that this is an easy 5 minute fix and I'm just overlooking something minor but so far I'm stumped.

    I manage about 100 PCs throughout my current location and recently I upgraded the WinXP PCs that have the WUSB54G v4s to the driver. After doing this I wanted to go into the advanced settings on the TCP/IP properties and check a few things, Enable NetBIOS over TCP/IP since they are all using static IP addresses now, etc. It was business as usual on every PC until I started working on the one PC (out of the 6 updated at this time) that can not reach anything on the network when it establishes the wireless connection. It will connect .... but "the internet cannot be found". It will never obtain an IP address from the DHCP server if I have it set to auto assign the IP/DNS. If I assign one it will show that it's connected but nothing on the network is reachable at all. The strangest thing is that there is no advanced button on the TCP/IP properties page. It just has the second tab at the top to setup an alternate IP address (as if you were using a laptop and went between locations but didn't want to manually switch the IP every time)

    I know I've seen this somewhere before but I can not remember why it is like that or what is causing it. I almost remember the advanced button missing because a PC is lacking some update but this computer is all up to date. I can't find another PC in our network that has the same TCP/IP settings page. I've tried searching all around but have come up empty handed.

    Is the key to solving this in one of the "net" commands for XP? I'm heading in that direction as soon as this is posted.

    Any help would be greatly appreciated. I know one of you has seen this or knows what I'm talking about. I'm surprised it's not an issue found on google more often.
  2. adamcole

    adamcole LI Guru Member

    The solution to the broken wireless (in this situation at least)

    Well, when I went back to working on this particular PC this morning the advanced button was there. I'm almost positive it really was gone when I was working on it forever Friday. Even though it was back and I could change the settings the wireless still would not get an IP through DHCP and setting one manually would result in a wireless connection but access to no other machines (internal or external)

    Finally I decided that it must be some sort of hardware issue with the WUSB54g and I decided to buy a replacement. I picked up the Belkin Wireless G USB Adapter and it connected immediately after adding the encryption info and selecting the SSID. It's nice and fast too. Almost like the connection software is less taxing for the Belkin than the Linksys.

    Another thing to note is that the WUSB54g would show both SSIDs from the AP and the Repeater (even though the manual says it'll be reduced to 1) The belkin only shows the closest SSID (the repeater) and has full signal strenght. I can only see one SSID for this wireless network even if I select the option to view any wireless connection within range. It's a nice a simple solution at least.

    I will probably pick up another one of the same type Belkin wireless adapters if I run into issues again in the future and see if I have the same luck.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice