Wireless bridge help

Discussion in 'Tomato Firmware' started by Zirak, May 26, 2010.

  1. Zirak

    Zirak Networkin' Nut Member

    I recently have found a need to extend my wireless network, and went with tomato to bridge 2 routers. I purchased an asus rt-n16 to go with the old standard wrt54gl. I have used the standard linksys firmware until now; I didn't have need for anything fancy.

    I was able to flash without issue and get both routers up and running. Both routers work from both the lan and wan sides, they just don't seem to talk to each other. I set them up with the same SSID, channel, as AP+WDS. I tried entering the MAC addresses of the other wireless on both, as well as automatic. I tried with and without DHCP on the remote router. I was able to connect to each with a wireless device (changed SSID on remote) so it wouldn't seem to be a WPA password issue. I tried G only, and B+G.

    I'm using the stock front page version on the GL and (obviously?) the teddybear mod on the asus. My thoughts at this point (probably wrong) are that either the two versions of firmware are incompatible for this purpose, or the differing hardware is causing a problem. Frankly, neither explanation makes sense to me.

    I am a newb here, but not exactly a tech newb. I've done some serious Tivo hacking and run the corporate IT. I say that only to mean that although I'm probably stupid here, just not completely stupid.

    Perhaps someone has already chewed up this road and can save me hours of trial and error.

    Thanks in advance!
  2. Shimakaze

    Shimakaze Addicted to LI Member

    Are you using WPA2 on both routers by any chance? If I remember correctly, the "bridge" router cannot authenticate with the base router if it's configured to use WPA2. WPA will work, however.
  3. Zirak

    Zirak Networkin' Nut Member

    I set it to WPA/WPA2, and gave it a password. I would have assumed that would still work as that would seem to imply WPA is an option. Its certainly worth a look. I don't recall that there was a WPA only option in the interface, but I equally don't recall that there wasn't. Thanks for the suggestion.
  4. Zirak

    Zirak Networkin' Nut Member


    I found the setup reference in the tomato faq, followed it exactly and it worked perfectly. I suspect the culprit being a) not being set to WPA Personal, and b) It seems to take a little extra time for it to become active after a reboot.

    I also was using a different IP than dot 2. I doubt that had anything to do with it though.

    For anyone else with issues, search this page for WDS for exact instructions. (Looked before, but searching "bridge" and the like didn't do it!) http://www.polarcloud.com/tomatofaq Hope this helps the next weary traveler.

    I can now watch the game on my blackberry sitting by the pool courtesy of tomato and slingbox!

    Many thanks.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice