Wireless Bridge Issues - E4200 & WRT54GL - Tomato RAF

Discussion in 'Tomato Firmware' started by TheKid, Jul 21, 2013.

  1. TheKid

    TheKid LI Guru Member

    Hi All,

    Well... I thought I was networking savvy. I guess not! ... Because I've tried and read EVERYTHING! I'm down to having to ask for help! Please!

    I'm using a E4200 with Tomato RAF v1.28.9013 as my primary router now. It works great; everything connects and B, G, & N function well per whatever device connects. I used to have a WRT54Gv2 with the stock v1.28 Tomato as my primary.

    I have a media rack in the living room that relied on a wireless bridge also running the stock Tomato v1.28 on a WRT54GL v1.1 in, of course, 'Wireless Bridge' mode. The devices that were connected to it physically (DirecTV receiver and Samsun Blu-Ray Player) were able to access the primary router, get a DHCP static assignment, and hit the Internet without issue. I was using G, of course, on Channel 6, with WPA/WPA2 Personal & AES on the main router and WPA Personal & AES on the Bridge. This was the only that seemed operable. The bridge was also set to use the same channel as the primary router, same SSID, etc.

    Main router is at; bridge is at

    Once I upgraded to the E4200 and installed Tomato RAF, I have not been able to get the WRT54GL Wireless Bridge (I switched out the WRT54Gv2 to the WRT54GL v1.1 for the bridge when I upgraded the main router) to see the Internet. It connects to the WAN/LAN, but will not allow the devices physically connected to see the Internet even though the Bridge has been set to use as the gateway and DNS. I have flashed the WRT54GL (the bridge) to the standard Tomato v1.28 and also 'tomato.RAF-K24-1.28.8515_lite' and regardless of firmware, they both seem to connect to the WAN/LAN, but cannot get my racked media devices to see the Internet for some reason. I'm totally stumped -- there shouldn't be much to setting up a wireless bridge. <g> I've put the bridge in 'Router' mode and to not use 'Internal DNS' when using the latter firmware. I thought that just the stock Tomato v1.28 on the bridge should be compatible with Tomato RAF.

    But, to make things mesh all the more, I flashed to 'tomato.RAF-K24-1.28.8515_lite' on the WRT54GL bridge and set it up the same way. Same results... Both firmwares will not allow devices plugged into the bridge to access the Internet. I even tried dropping back to the WRT54Gv2, trying both firmwares again... Same results. That confirmed it wasn't a hardware issue.

    So, I have to suspect that I have something set up incorrectly on the main router -- the E4200 running Tomato RAF v1.28.9013. I'm not sure what, but since stock Tomato 1.28 on both, one as an AP and one as a Wireless Bridge worked fine, that it has to be something to do with the E4200's config.

    At present, I have the E4200 Router/AP at Tomato RAF v1.28.9013 and the WRT54GL Wireless Bridge at Tomato.RAF-K24-1.28.8515_lite. Again, I am able to see and access the bridge (via the E4200) and the devices connected to the WRT54GL bridge can access all but the Internet.

    Sorry for all the redundancy, but I wanted to provide as much detail as possible.

    Any help would be GREATLY appreciated! I love the new E4200 and having N up on the WAN/LAN, but I'd like to get a bridge back and operable as well, if only running G. Figure it's something simple I'm missing 'cuz I've been using these routers and Tomato for over 5 years now and never had an issues.

    Thanks much!
  2. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Could you post screenshots of the Basic settings page from the E4200 and bridged WRT54G?
  3. TheKid

    TheKid LI Guru Member

    Sure... Thanks! Note, the currently running firmwares:

    E4200: tomato-E4200USB-NVRAM60K-1.28.9013MIPSR2--RAF-VLAN-VPN-NOCAT.bin

    Screenshots follow...

    E4200 Main Router:


    WRT54GL Bridge:


    Again... It used to operate in this mode, with these settings when the main router was a WRT54GL running the stock Tomato firmware. Nothing else was really required, however, I did tweak out the other options on the bridge, once operational, to make things as complete as possible.

    Also, notice the difference in themes. I created a personalized one. For WHATEVER reason, even though I have the Bridge set up with CIFS1, seeing the share (reporting disk space), it does not pull the theme down via my script, under WAN Up. This used to work with the stock Tomato firmware on the Bridge. Note, it DOES work as expected on the main E4200 router, once booted, using the exact same CIFS1 mechanism and script under WAN Up:

    sleep 300
    mkdir /var/wwwext
    cp /cifs1/theme/custom.css /var/wwwext/custom.css
    cp /cifs1/theme/red_tomato_top.gif /var/wwwext/red_tomato_top.gif

    (Just a side issue. But, since capturing the screenshots, I figured I'd bring it up as well.)

    Thank you so much for whatever help you could provide!!!
  4. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Have you tried setting security on both routers to WPA2 Personal?

    As an aside, you may end up with more reliable performance with 20MHz channel width on 2.4GHz.
  5. mvsgeek

    mvsgeek LI Guru Member

    Couple of suggestions...

    Can you ping a well-known dotted decimal Internet IP (e.g. from a PC connected to the WRT54GL?
    Try specifying your ISP's DNS servers in the E4200 settings - I see you have them all set to

    Can you ping from

    Have you tried setting mode explicitly to G or N vs. Auto?

    I also concur with Marcel Tunks' recommendations.

    FWIW I have a working ethernet bridge setup using Toastman F/W on Asus RT-N16 & RT-N12 routers using these settings:
    Mode : N only
    Channel : 1
    Channel width : 20
    Security : WPA personal
  6. TheKid

    TheKid LI Guru Member

    Well, I set the encryption to WPA2 Personal exclusively and also set the channel width on 2.4GHz to 20MHz. Also, I added Comcast's DNS servers to the Static DNS list. Note, the DNS servers are set via DHCP with Comcast and even though are empty, when things connect to as a gateway, they understand to use the DNS servers that were acquired, so setting them statically isn't required, but I tried anyway in an attempt to get this working. Also, I tested 'Auto' vs. 'Only B' and 'Only G', since these are the only 802.11 specs supported by the WRT54G's. Long and short, nothing seemed to change a thing. It's a very strange issue. I can connect a computer, physically, to the WRT54GL Bridge and manually set the computer's NIC to:


    ... and everything works perfectly. DNS passes through, again, with Static DNS assigned or not. I can ping the router ( and also Google's DNS servers,,, browsers work correctly, etc.

    But, the DirecTV receiver and the Samsung Blu-Ray... "Can't connect to Internet," although every other network test passes. In other words, they CAN see the LAN. It just doesn't make any sense.
  7. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    I had some devices that didn't work on WET bridge but worked with WDS, but if those devices worked with your previous configuration then that's probably not the issue.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice