wireless bridge not working w/ gigabit switch

Discussion in 'General Discussion' started by justinmiller621, Nov 25, 2008.

  1. justinmiller621

    justinmiller621 Addicted to LI Member

    My setup is such that I have two routers running tomato configured for Wireless Ethernet Bridge mode. Everything works fine like this. I have connectivity wirelessly as well as when I'm connected, wired, to the router configured as the bridge.

    I recently bought a wired, gigabit switch and connected it to the bridge, then connected a few clients to the gigabit switch. Those clients can all ping each other, but they have no internet connectivity.

    If I switch to WDS mode, then everything works as expected. This configuration is fine, just unnecessary. I'd prefer bridge mode.

    Is there any reason bridge mode should not work given this configuration?

    Thanks in advance,
  2. HennieM

    HennieM Network Guru Member

    There is a MAC address issue with bridge mode which is not present in WDS mode. This is more a cosmetic - don't SEE the correct MAC address - rather than a network deficiency issue.

    However, if your Gb switch don't like this funny-ish MAC business, it might be blocking or sending packets to the wrong place, but I can't think why it would do that. Anyway, a way to test would be to plug a few PCs directly into the bridge, i.e. bypass the Gb switch, and see if the link still works.

    If you can't resolve bridge mode:

    Running WDS adds a little bit of overhead relative to bridge mode, in that 4 MAC addresses are handled over the wireless link instead of 3 MAC addresses. So, if your comms involve a lot of small packets, you might see a speed drop. Normally though, you should not notice a significant speed difference between bridge and WDS mode as you have only 2 nodes involved, so there's no signal being repeated by a single router/radio.
  3. justinmiller621

    justinmiller621 Addicted to LI Member

    Hmmm.... I was just playing around, and realized that wireless bridge mode works fine if I plug into my other wired nic (the one built-in to the laptop) rather than the gigabit.

    This occurs when I'm in either Windows or Linux (Ubuntu). I've tried both the driver that ships with Ubuntu 8.04 (r8169) as well as ndiswrapper with the windows version of the driver. I've tried plugging the gigabit card into both the bridge router and the gigabit switch with the same results. The built in nic works fine in either the gigabit switch or the bridge.

    So it appears that it's the gigabit card that's the problem, not the router's mode.

    Any thoughts?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice